Strange colour issue in 4K SDR

Hi there,

I have a LG OLED (C6) TV and the Vero is emitting strange behaviour when outputting 4K in SDR. Basically there is a green tint to everything, as if the colour space is incorrect. The result is that 2160p SDR video content all looks a little too green. I don’t have this with any of my other devices.

It can be highlighted easily in the examples attached just simply of the Estuary skin at the different resolutions - 1080p is how the colours are supposed to look, 2160p and too much green push. It’s much more obvious in real life.

Any idea why this is happening?

You should not change the UI resolution higher than Full HD. For video playback OSMC will switch automatically to the resolution of the Video Material but for UI the recommendation is to keep it at 1080p

No I think you’re misunderstanding. I do that,but 2160p SDR content has the green tint when it automatically changes resolution for it. I’m only changing the UI resolution to easily highlight the issue.

Ok, then we need to wait for @sam_nazarko if he has an idea. Only idea I have is try another HDMI cable.

Thanks, the hdmi cable is fine. Let’s see what Sam suggests…

I had an LG 4K HDR TV (2016) and i had some problem with colours on some source.
Try the following:

1- Change the source type to PC or game console. You should find option to change in source list, I seem to remember it was something like ICON

2- Enable (or disable) HDMI ULTRA HD Deep Colour. It should be in general menu, i don’t remember.

Let us know.

1 Like

I don’t have this issue with my NUC running Libreelec at the same resolution. If I disable Deep colour then I’ll lose support for HDR. And if I change to PC I’ll list support for 24p. But I’ll try both shortly to see if either makes a difference to the colour issue out of interest.

Ok, so I tried both of those and they made no difference at all. This is really frustrating, I like the Vero but this is a deal breaker if it can’t be resolved. I just tried my Libreelec NUC again and there’s no issue on there at all, nor if I play SDR 2160p files with my Samsung Blu-ray, so it’s not the TV.

Please provide logs so we can see how the TV is recognized.

1 Like

Here you go: osmc log -


Thanks for the photos that clearly demonstrate the problem.

I have noticed that some displays sometimes have different colour settings at different resolutions; or even at difference refresh rates.

Assuming you’re not using a discreted GPU on the NUC, LE has a patch for the i915 (Intel iGPU) which allows colour gamut to be configured from Kodi. Does changing this introduce the green tint at 4K60 on the NUC as well?

Adjusting the colour space and colour depth may help. With your TV and AV receiver, if you have one on, you can get a list of supported formats with:

cat /sys/class/amhdmitx/amhdmitx0/dc_cap

You can then adjust with:

echo .... | sudo tee /sys/class/amhdmitx/amhdmitx0/attr

For an LG OLED, you probably want:

echo '444,10bit' | sudo tee /sys/class/amhdmitx/amhdmitx0/attr

If that works and you want to make it persistent, you can add this line before ‘exit 0’ in rc.local:

echo '444,10bit' > /sys/class/amhdmitx/amhdmitx0/attr


1 Like

Hey Sam, thanks for the detailed response! I’ve never tried adjusting the colour gamut on Libreelec - i didn’t know you could and I’m on the latest version - where can I find that setting?

I’ll fire up Putty later this evening and give those commands a try on the Vero, hopefully that’ll fix the issue - could changing the colour space inadvertently negatively affect the output of HDR content though? I’ll let you know how I get on.

The Setting is called CSettings::SETTING_VIDEOSCREEN_LIMITEDRANGE, so I think it will be under Settings -> Video.

For HDR on an LG OLED TV, you should actually set the setting recommended above.



1 Like

Ah yes, that changes the RGB black level in Libreelec (either limited or full range) but it doesn’t change the colour space/gamut. If I change to the incorrect black level it doesn’t change the colours, just makes the blacks become grey.

I’ll give your suggestions a try on the Vero later though and let you know if have any success, fingers crossed! Thanks again

Sam, I’m tried your command above via SSH but it doesn’t seem to be working. The first command works and I get the list of options, but when I try the second command the colour space doesn’t change. My TV doesn’t go black as if it’s changing modes etc either. Just nothing happens. I’m typing in exactly, only changing the red text to try different modes. Any idea why it might not be working?

Edit: Problem solved! I just needed to switch resolutions and back in Kodi to force the change through. And… now the colours are perfect at 2160p. 444,10bit is indeed the correct setting for my LG OLED. Very pleased now, thanks :slight_smile:


Glad to hear this.
If you put it in rc.local as suggested, it will persist across reboots.


1 Like

Thanks Sam

I think you are a genius. I got my Vero4k a couple of days ago and set it all up very simply by the living room TV, but when I took it to plug into the receiver and projector I got a purple / green tinge on everything - no matter what I switched it was still there. When the projector was directly to the Vero it was all fine.

I followed your instructions exactly and found that the Receiver reported only 8bit spaces. So I adjusted settings as above and put to persistent and now I have perfect video and audio.

Mentioning this both to say thanks and to help others find this solution!


I’m glad to hear this.