Strange external hdd problem

This drives me crazy, so I hope someone will have useful insights on how to fix.
I was running Crystalbuntu on my ATV for years, and installed OSMC only today. The source of my troubles is an external, USB-only powered, NTFS-formatted HDD, which worked with Crystalbuntu as a charm, and which also works with my Windows based PCs, but OSMC throws serious errors and deny to mount it.

Please have a look at the dmesg log: ext hdd troubles -

I’ve already tried to attach it to Windows and “remove it safely”, tried “chkdsk /f” there,
“ntfs-3g /dev/sdb1 /media” on OSMC, but in vain, I’m just getting these I/O errors, though that HDD works everywhere else fine.

If anyone have any thoughts or ideas on this, please!

Most likely the problem.

Maybe, but

  • it wasn’t problem when my ATV hosted Crystalbuntu (even today, in the morning) - then why is it now?
  • my other USB-only powered ext HDD works under OSMC fine

You could test and confirm this is the issue by using a powered USB hub.

OK, just tried it with a home-made power hub: an Y - USB cable and an additional phone charger. The problem persists, no mount, same I/O errors in dmesg, while flawless operation when attached to my Windows PC.