Strange NFS problem


#1

Hi,

Im using NFS shares mounted via FSTAB. Most of the time its working perfectly but sometimes some shares are gone, but not all of them?! They are all from the same NAS and are configured identically.
Restarting ths NAS, VERO or the switch doesn’t solve the problem it just suddenly start working again.
What do you think is wrong with my setup? (I know it might not be the vero but i need some help find the source)
I have followed these guides.


https://kodi.wiki/view/NFS#Synology_DSM_5.1

The permissions on the shares seems a bit strange…

bild

shares from the NAS…

bild

FSTAB

osmc@osmc:/mnt$ cat /etc/fstab
# rootfs is not mounted in fstab as we do it via initramfs. Uncomment for remount (slower boot)
#/dev/vero-nand/root  /    ext4      defaults,noatime    0   0
192.168.1.51:/volume1/Serier /mnt/Serier         nfs     noauto,x-systemd.automount  0  0
192.168.1.51:/volume1/Barnens /mnt/Barnens         nfs     noauto,x-systemd.automount  0  0
192.168.1.51:/volume1/Film /mnt/Film         nfs     noauto,x-systemd.automount  0  0
192.168.1.51:/volume1/Barnens\040Serier /mnt/Barnens\040Serier         nfs     noauto,x-systemd.automount  0  0

#2

Hi,

Sorry to hear you are having issues, but unfortunately we need more information, please provide full debug logs when the issue occurs:

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request

Also it would be worth checking the synology’s logs when the issue occurs:

/var/log/syslog
/var/log/messages

Thanks Tom.


#3

Yes, more log information could be helpful. Besides, the Synology screenshot shows that this specific share is permitted for 192.168.1.1 … which would be a quite unusual IP address for the Vero but is more often given to the router/gateway of your network.

If you want to allow NFS access to all devices in your network, you could use 192.168.1.0/24.


#4

ops… I must have missed that. I will correct that so I allow the net instead of that host. But then, how is this even working?! :slight_smile:


#5

https://paste.osmc.tv/fivisofoli

did two tests.

  1. play a file from 192.168.1.51:/volume1/Barnens\040Serier (working)
  2. browse 192.168.1.51:/volume1/Serier /mnt/Serier (not working)

#6

/etc/exports

/volume1/Barnens 192.168.1.0/24(rw,async,no_wdelay,crossmnt,insecure,all_squash,insecure_locks,sec=sys,anonuid=1024,anongid=100)
/volume1/Barnens\040Serier 192.168.1.0/24(rw,async,no_wdelay,crossmnt,insecure,all_squash,insecure_locks,sec=sys,anonuid=1024,anongid=100)
/volume1/Film 192.168.1.0/24(rw,async,no_wdelay,crossmnt,insecure,all_squash,insecure_locks,sec=sys,anonuid=1024,anongid=100)
/volume1/Serier 192.168.1.0/24(rw,async,no_wdelay,crossmnt,insecure,all_squash,insecure_locks,sec=sys,anonuid=1024,anongid=100)


#7

Hi,

The first attempt to mount is occurring before the network is up, I assume a library scan on startup. Have you got wait for network enabled in MyOSMC?

Thanks Tom.


#8

Hi Tom,
I have now enabled the wait for network. And did a reboot of the Vero. But no ciggar… Then I did a second reboot, browsed the nfs mount using ssh and suddenly it worked?!
https://paste.osmc.tv/qogiwegeqe


#9

Hi,

Unfortunately the reboot has cleared the part of the log that would let us know why it failed to mount. If you can reproduce again, please upload a log without a reboot.

Thanks Tom.


#10
20:58:53.743 T:4055888640 WARNING: Process directory '/mnt/Serier/The OA/' does not exist - skipping scan.
20:58:53.743 T:4055888640 WARNING: Process directory '/mnt/Serier/The Terror/' does not exist - skipping scan.
20:58:53.743 T:4055888640 WARNING: Process directory '/mnt/Serier/True Detective/' does not exist - skipping scan.
20:58:53.941 T:4055888640 WARNING: Process directory 'smb://192.168.1.51/Serier/Australia/' does not exist - skipping scan.
20:58:53.996 T:4055888640 WARNING: Process directory 'smb://192.168.1.51/Serier/GOBLIN SLAYER/' does not exist - skipping scan.
20:58:54.146 T:4055888640 WARNING: Process directory 'smb://192.168.1.51/Serier/The Seven Deadly Sins/' does not exist - skipping scan.

Obviously there still exist library entries from a previous configuration where you configured a samba video source path within the mediacenter?
I suggest to run a “clean library” at gui -> settings -> media -> library -> clean library.


#11

Hi,

I have run the cleaning several times but it doesnt remove the shows.


#12

Can you see the source “Serier” if you go to Videos -> Files in the mediacenter?


#13

yes


#14

I would try to temporarily set the content type of that item in this menu to ‘none’ and let remove all library entries when asked for. Afterwards set the content type again to ‘TV shows’ and rescan.
So, select this list item and choose the ‘context’ menu on the Vero’s remote control…

If that also will not fix the issue, you can also remove the TV related database and start from scratch without any video source configured. But let’s first try the previous step.


#15

Hi all,

I think that this two issues are now solved.

  • The missconfigured NFS share are now corrected and it has worked four days now.
  • The “none content type” fix solved the old smb shows.

Thank you for your time and support!


#16

Glad to hear this is now solved for you