Stream audio from osmc KODI to bluetooth audio device

systemctl status bluetooth

/var/log$ grep blue syslog.1|more

i’ve tested it on a xbian installation…
and there i can’t connect as well - i will test with a clean OSMC (latest version - i used the 20150830 image on my working installation)

EDIT: you have changed the audio settings in Kodi to Pulse?
without changing this before connecting the device, i got the same error as you on a fresh osmc installation

1 Like

That did the trick! I have to change the sound output BEFORE i connect the bluetooth devices. God that an easy solution… i spend a lot of hours to find this. Thanks a lot! I love you…

Unluckily after the sucess i faced the next problem.
It seems that my running bluetooth stick is disturbing my wlan connection.
Using audio output at my headset and try to stream videos, i.e. TwitchTV, the wlan stiick is crashing and loosing connection.

Streaming without bluetooth audio running it works fine.

First i thought it is a problem about the distance from both sticks to each other because both of them are realy close. So i used a USB extender cable but placing the Wlan stick away from the bluetooth does not help…

Have you noticed the same problem?

Hi @hellmaker, I have an idea (maybe dull one :smile: ) can you try to use wired internet connection while you’re streaming audio because this problem is maybe related to USB speed capacity or maybe this is problem to Pi’s power management.

P.S. Can you please share what model of BT adapters are you using?

First thing you should do is confirm that this is not a problem with not supplying enough power to the Pi and connected devices. An insufficient power supply could easily produce these symptoms.

so yes, power supply was my first thought.

I´m using a 5V DC 2A supply. This should be enough. You also have on Raspi2 that low power indicator at the upper right corner at the screen. It shows / flash when voltage is going lower than a specific value. First i was having a bad regulated powers source (it was also 2A) where this “low power square” pops up everytime when wlan starts transfering data.
With the new power supply the square is not showing anymore. So i think its alright.

I´m using a EDIMAX EW-7811UN Wireless USB Adapter


a CSL - USB nano Bluetooth-Adapter V4.0 mit LED

When it is a internal speed problem with the USB bus im doomed!!!

Have you tried max_usb_current in MyOSMC PiConfig yet? Reboot required.

Of course, i tried with and without max_current much more than 1 times…

I also noticed, that i´m not able to control OSMC via Yatse when bluetooth audio is activ.

It kills the wlan and sometimes even the whole osmc (bad smilie screen) …

when i’m at home i will test, i have nearly same hardware (also a Edimax WLAN) - i guess here in the office my wlan at all isn’t that stable…

did you tried with an extarnal powerd USB Hub?

I have followed these instructions but now even without bluetooth enabled osmc keeps crashing. Has anyone had this too?

EDIT: Added logs, even if I don’t think they’ll be useful…

Start a new thread. Looks like you have Library Watchdog enabled which is giving you problems. Don’t know much about it, but could be a problematic file in your library


So it’s not related to bluetooth? Strange… Thanks for helping!

can you post a
sudo journalctl log? if it is a bluetooth problem we see it there before kodi runs!

Sorry for not replying earlier, the problem was indeed Watchdog addon, once disabled the reboot loop stopped!

Anyway, I have another issue now, I have enabled module-switch-on-connect, and the headset automatically pairs with the raspberry, but i can see in console Connected: Yes and after Connected: No.

If I try to manually connect, i get a bluez error. I can only manually connect when a movie is playing, is this normal?

i had this once with an other bluetooth device… my fix was to completly reset this device…
but i don’t know if this work in your case!

is the connecting script comming and the linked service comming up after pulseaudio? it must be at the end of the whole booting process…


I installed Alsa drivers on Raspberry Pi with OSMC. In KODI Audio output, I can select: ALSA: PulseAudio Sound Server or ALSA: Playback/recording through the PulseAudio sound server. If I select one of them there is no sound from audio jack or HDMI.

Is it possible to stream from Raspberry Pi via bluetooth to bluetooth speaker and use audio jack/HDMI at the same time?


i’m not sure if this is working, but maybe try this one:

PulseAudio CombinedAudio

Perhaps related: streaming to OSMC and playing back via HiFiBerry is not possible, this has been asked and answered in the main Bluetooth streaming topic:

Hey guys so im trying to set up my pi to connect with my bluetooth wireless headphones i have followed the steps above but i cant seem to get past this one problem it wont let me pair or trust my devices i have tried multiple devices and looked at all the stuff you guy have suggested the error i get is that the device is “not available” but it shows up on the scan and i can connect to it through the osmr main menu but not through the terminal. my audio imput for kodi is set to the pulse sever but i dont get anything. Hope you guys can help

See [Deprecated] [TESTING] Bluetooth audio streaming (A2DP).