Stream buffering with active VPN


I have a very strange issue with the IPTV stream when connected to VPN. Each time i start the stream in tvheadend, few seconds later the picture stalls. Everything works fine when I disconnect from VPN. I have tried two different VPN providers, many different VPN locations, and had the same problem with stream stalling. I recall, that there were no issues with streaming over VPN sometime ago. I think, the provider changed something on their end recently, but I am not sure. I also recall, that around the time when the problem started, the vero4k+ was getting a lot of updates, few per day. I tried to debug the problem, and did not see anything unusual. The CPU cores show very little load, except for #3 (100%). The only difference is, when the stream works the FPS shows about 20, but when it stalls it shows around 60. The eth0 port is connected at 1000/Full, and there are no errors, or packet drops.

Also to note, there are no problems at all with the stream over VPN on the PC with the VLC Player.

Would anybody know what might be causing this issue?

Here is the snippet from the log:

2021-03-02 21:17:54.579 T:3834609888 DEBUG: VPN Mgr : Previous window ID was 10702
2021-03-02 21:17:55.729 T:3063918816 DEBUG: CDVDClock::SetSpeedAdjust - adjusted:-0.050000
2021-03-02 21:17:56.492 T:3224367328 NOTICE: CVideoPlayerAudio::Process - stream stalled pts:1.822 clock:2.105
2021-03-02 21:17:56.530 T:3063918816 DEBUG: Stream stalled, start buffering. Audio: 0 - Video: 1
2021-03-02 21:17:56.530 T:3063918816 DEBUG: CDVDClock::SetSpeedAdjust - adjusted:0.000000
2021-03-02 21:17:56.530 T:3224367328 DEBUG: CDVDAudio::Pause - pausing audio stream
2021-03-02 21:17:56.535 T:4064718864 DEBUG: ------ Window Init (Custom_Cache_Progress.xml) ------
2021-03-02 21:17:56.536 T:4064718864 DEBUG: started alarm with name: iscachingtimer
2021-03-02 21:17:56.838 T:3055526112 INFO: CVideoPlayerVideo - Stillframe detected, switching to forced 25.000000 fps
2021-03-02 21:17:56.838 T:3055526112 DEBUG: CAMLCodec::SetSpeed, speed(0)

That is not that likely unless you are on the development repository.

The VPN is single threaded, could well be that you VPN provider has increased the encryption which consume more CPU time.

We need to see full logs and not snippets to advise further

I have been trying to t-shoot the problem, and found out that it is related to the TVHeadend server v 4.2.8 itself. I connected to the stream via VPN with PVR Simple Client, and had no issues at all. I believe, the previous version of TVHeadend server was much more stable. Is there a way to roll it back the previous version. i don’t think there’s a newer version than 4.2.8 available on tvheadend website.

Also, I will upload logs if needed.

The issue has been resolved. It was on the provider’s side.