Stuck in system screen, when activation IQaudio hat

I have an IQaudio DigiAMP+ hat on my Raspberry Pi 3, and the setup worked fine before the upgrade. If I activate the hat in /boot/config-user.txt with
I have no sound, playback crash and when goin into the “system” menu in settings the ui is stuck and I can only reboot or restart mediacenter service.

Anybody else with similar issues?

I have even tried to completely remove .kodi folder after activating the hat, but it still behaves the same. I have installed pulseaudio, and I will try to revert this and see if it changes anything

alright uninstalling pulseaudio, helped. But I would really like to have the option to use pulseaudio for the IQaudio hat, so more than one sound source can play at the same time.

Is there another way than pulseaudio to do this?

OK, pulseaudio without hat activated worked fine in kodi, so tried to cut loading of pulseaudio a bit closer, and setting only
load-module module-alsa-sink device=hw:1,0

and removing the
load-module module-udev-detect

part from /etc/pulse/ seemed to make kodi stay happy

We don’t plan to support PulseAudio in OSMC.

There was limited support to facilitiate Bluetooth (A2DP) audio streaming, but this is now achieved using ALSA.

I have the same problem: RPi 3b + IQaudio DAC Pro hat.
After the update to version 2021.08-1 no sound from the DAC.
Selecting ‘iqaudio-dacplus’ from MyOSMC the “System” menu hangs on “audio” settings, with no possibility to choose the DAC for audio output.

So did you do this?

1 Like

Ok, I manually edited config-user.txt changing from ‘iqaudio-dacplus-overlay’ to ‘iqaudio-dacplus’ (removing ‘-overlay’) and seems to work.
Thanks fzinken

Just to spread the word, this manual edit (changing from ‘iqaudio-dacplus-overlay’ to ‘iqaudio-dacplus’ (removing ‘-overlay’) ) is required to get an IQaudio digiAMP+ working with a raspberry pi 4.

This is already fixed in the next update and won’t require manual editing.

That’s good to know, many thanks!