Stuck on splash/confirmation screen after last update

The update process went fine and my RPi2 boots nicely into Kodi. For a couple of seconds, that is. Thereafter some kind of conformation screen seeming to be superimposed onto what looks like a region selection. There is a check box for getting news via email and a large “I agree” visible but there is no way to confirm and get back to kodi.

I have tried escape, backspace, arrows+enter, ctrl+alt+F1, …F2 etc. Rebooting does nothing.

There must be some kind of flag in a file to change so that the screen does not pop up but my searches has been in vain.

You are meant to agree to the license, although this is not technically needed and we will remove it in future OSMC versions.

Just sudo touch /walkthru_completed and reboot if you must, but I am not sure why you cannot complete the tutorial.


I don’t know either. It’s a bug, basically, since it’s text on top of other text (unreadable) and non responsive gui.

Your trick worked, but I had to apply the classic spelling of “through” to get it done. “Thru” would just not do. Picky systems nowadays. :wink:

Thanks for your swift reply and good help, mate! I have a pic of the garbled screen of you’re interested. Couldn’t attach it here is all.

The walkthrough will only appear on a fresh install, it shouldn’t appear just after an update as the file /walkthrough_completed should still be there. Only if this file got deleted would the walkthrough trigger a second time.

Are you running a very low resolution screen like 640x480 (or composite video) by any chance ? I think there may be an issue with the text layout of the walkthrough on very low resolutions.

Really weird since this is an installation I’ve been running for months. I’ve never seen it before.

No lowres (720p) but the effect is very much like what you get when content designed for a much larger screen is forced onto a small one.