Stuttering/Bumpy motion when play small x264 files

Morning!
Since month´s I try to fix this issue when playing x264 files with SD-Resolution.
Everytime I play small files (tv shows) less than 800MB, x264 coded and almost 2.0 sound I recognize stuttering, in other words: no smooth motion picture.
On my RPi3 with osmc I had never problems with such files, only in the Vero 4K.
I tried serverl options but no way to fix it.
4K, HDR, 1080p files wiht Atmos, etc…everythin´s no problem and smooth playback. Only my tv shows make troubles.
Can you help?
Thank you

Where are you storing your files? On a drive attached directly to Vero or do you play them via SMB or NFS?

To get a better understanding of the problem you are experiencing we need more information from you. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Hi, I store my files on a home server and the vero is connected via GigabitLan - smb.
But can´t imagine this is the reason why the playback isn´t smooth. All other movies are playing fine - on the RPi3 also the tv shows. Only on the Vero 4K the shows ahve micro bumpers.
Can´t find an english word for “Mikroruckler”.

We need to see mediainfo on the problematic files. Instructions for providing mediainfo are in the link.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

1 Like

I would definitely try playback from a usb stick

Same as SMB - here is a media-info file from one of the file with this issue.

General
UniqueID/String : 70511333425219851565047334099031755313 (0x350BFD2506CC21BF80D1F2D15F210A31)
CompleteName : \SERVER-PC\TV Serien\24 Legacy\24 Legacy - 1x01 - 1200 Uhr - 1300 Uhr.mkv
Format : Matroska
Format_Version : Version 4 / Version 2
FileSize/String : 354 MiB
Duration/String : 42 min 10 s
OverallBitRate/String : 1 174 kb/s
Encoded_Date : UTC 2017-02-13 22:03:57
Encoded_Application/String : mkvmerge v9.7.1 (‘Pandemonium’) 64bit
Encoded_Library/String : libebml v1.3.4 + libmatroska v1.4.5 / Lavf57.62.100

Video
ID/String : 1
Format : AVC
Format/Info : Advanced Video Codec
Format_Profile : High@L3.1
Format_Settings : CABAC / 5 Ref Frames
Format_Settings_CABAC/String : Yes
Format_Settings_RefFrames/String : 5 frames
CodecID : V_MPEG4/ISO/AVC
Duration/String : 42 min 10 s
BitRate/String : 959 kb/s
Width/String : 720 pixels
Height/String : 404 pixels
DisplayAspectRatio/String : 16:9
FrameRate_Mode/String : Constant
FrameRate/String : 25.000 FPS
ColorSpace : YUV
ChromaSubsampling/String : 4:2:0
BitDepth/String : 8 bits
ScanType/String : Progressive
Bits-(Pixel*Frame) : 0.132
StreamSize/String : 289 MiB (82%)
Encoded_Library/String : x264 core 148 r2744 b97ae06
Encoded_Library_Settings : cabac=1 / ref=5 / deblock=1:-2:-2 / analyse=0x3:0x113 / me=hex / subme=8 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=12 / lookahead_threads=2 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=200 / keyint_min=20 / scenecut=40 / intra_refresh=0 / rc_lookahead=50 / rc=crf / mbtree=1 / crf=19.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / ip_ratio=1.40 / aq=1:0.80
Default/String : Yes
Forced/String : No

Audio
ID/String : 2
Format : AC-3
Format/Info : Audio Coding 3
CodecID : A_AC3
Duration/String : 42 min 10 s
BitRate_Mode/String : Constant
BitRate/String : 192 kb/s
Channel(s)/String : 2 channels
ChannelPositions : Front: L R
SamplingRate/String : 48.0 kHz
FrameRate/String : 31.250 FPS (1536 SPF)
BitDepth/String : 16 bits
Compression_Mode/String : Lossy
Video_Delay/String : -965 ms
StreamSize/String : 57.9 MiB (16%)
Encoded_Library/String : Lavc57.75.100 ac3
Language/String : German
ServiceKind/String : Complete Main
Default/String : Yes
Forced/String : No

Please paste as text, not an image that I can’t even read, and am not going to waste bandwidth to download.

Well, at least the low hanging fruits should be checked:

  1. OSMC GUI: Settings -> Player -> Videos and Reset to Defaults at the bottom of the menu
  • Adjust Display Refresh Rate = Start/Stop or even Always (but Always disables the ScreenSaver when playing music)
  1. OSMC GUI: Settings -> System -> Display and Reset to Defaults at the bottom of the menu

  2. If that does not help, try to remux one episode with actual MKVToolnix; the one found by mediainfo was v9.7.1 and is dated Dec 2016. Actual version is v20.0.0. If this works there might be a meanwhile corrected bug that time with mkvmerge.

  3. Next to last idea: Try with disabled hardware acceleration at OSMC GUI: Settings -> System -> Display -> Allow Hardware Acceleration - AMCODEC

  4. Could you provide a short clip, so someone else with a Vero 4k can try to reproduce it? You can split such clip with mkvmerge/MKVToolnix as well.