Stuttering issue with DVDLink (3.4.5) on Vero 4K

Today I have installed the Vero 4K which replaces an Intel NUC. Waiting for the 3D MVC support :-).

Everything is working perfect except for live TV with the DVDLink addon. The video is stuttering a lot unfortunately. Never had this issue with the NUC, PI3b or Android players. So it looks like it is an issue with the Vero 4K. I can play recordings without any issues. I have enabled timeshifting (disabling doesn’t solve the issue) and disabled transcoding.

Couldn’t find much relevant information about this issue. Is anyone else having similar issues? Does anyone have a fix for this issue.

Regards, Olaf.


I believe this issue was recently resolved.

I’d appreciate it if you could test this and provide feedback before we release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Thank you for the prompt reply!

I have tried to edit the file, but unfortunately I am not experienced with Linux.
I am able to login to the command line and go to the right directory. Unfortunately no idea of how to edit the file. Sorry.

Really happy a fix is on its way!

Use nano to edit:

$ nano sources.list

Here is a cheatsheet and some tutorials for how to navigate in a Linux shell: Cheatsheets and Tutorials for users new to Linux based operating systems

Thank you for your help.
Able to edit the file, but when I try to save I get a permission denied error.

Sorry, my bad:

$ sudo nano sources.list

I forgot to add the sudo part.

It’s downloading an update at this moment.
When I install this patch, will I be able to install official updates?

Do as Sam suggested and edit sources.iist again after the update is completed. You will still get normal updates.

Great! It solves the issue. Happy :-).

I have removed the added line. So looking forward to the official release. Thank you for the prompt support. Happy with the Vero 4K. Only thing I am waiting for is 3D MVC support. If this works also it is a 100% fit with all my needs.

Tried to install the patch on the second Vero 4K which arrived yesterday also. Am I correct the patch isn’t available anymore to install?

It’s still available

Thank you! Installed patch on second Vero 4K also. Problem solved with stuttering.