Stuttering playback of 1080p MKV x264

Sorted it for me cheers Sam

1 Like

@sam_nazarko Hi Sam, I wanted to let you know what happened after your update yesterday. 720p mkv videos with 24.576 FPS (American TV) all now are dropping and skipping frames. I had to turn off Adjust Display Refresh in Video settings as this was the only way to make the videos semi watchable. Now as they play every 10 seconds or so is a judder - similar to the regular judder I have been experiencing on HD Movies. I am able to watch videos with a refresh rate of 25 FPS perfectly. I am not sure what needs to be fixed which meant you needed this update but it has definitely been detrimental on my Vero 2. Good luck figuring it out I hope I will be able to playback all videos perfectly soon as I am unable to watch with the judder it is really annoying. I thought given the user base of Vero 2’s out there I would not be alone with this? I think I would like to give the Android version a try just to see if that resolved all my problems. Happy to be a test case for you. Cheers, Wayne

How are you getting on with today’s update?

Do you mean 23.976fps? I don’t think that the refresh rate is to blame here. Try the latest update and let me know.

You definitely don’t seem to be alone, and the situation is being looked at. Let me know how you get on with today’s update.

Sorry Sam I meant 23.976 FPS. Sorry I just woke up… The issues have happened after the latest update I applied yesterday afternoon. I will look again and see if there is anything else to update now. cheers.

Aussie timezone may be confusing things. Check for updates in My OSMC first.


Hi Sam. All fixed thanks. You are a genius. Have a lovely day/night.

1 Like

Very confusing …
Updated to the very latest (22 may) and don’t see any improvement on my setup.
Like I already stated, it is watchable, but I’m still seeing some minor stuttering. Debug log still full of those CalcDropRequirement.

Still very confusing … did a fresh install of 2016.04-1 and still saw some stuttering on GoT intro and Prometheus intro BUT no CalcDropRequirement in the Kodi debug log?!

So I added advancedsettings.xml (this gave also some improvement on may updates):
<advancedsettings> <network> <buffermode>1</buffermode> <cachemembuffersize>90000000</cachemembuffersize> <readbufferfactor>10</readbufferfactor> </network> </advancedsettings>
to increase buffering and it was already much better, still some minor (very minor) glitches.

Maybe I’m too demanding and focus too much on details?

Updated today, and watched different kinds of tv-shows.

All is working perfect for me now :slight_smile:

Tested :
720p - 23.976 fps
720p hdtv - 25 fps
576p (dvd → makemkv → mkv) 25 fps

Hi Sam

What was the issue? and how did you fix it?


We now use HW decoding again for lower resolution files.

There is still a slight microstutter for some videos. This will be ironed out shortly.


Indeed. Just watched GoT, saw some (micro)stuttering indeed. Didn’t dare to turn on debug logging … [quote=“sam_nazarko, post:31, topic:16713”]
This will be ironed out shortly.

Really looking forward to it, will be happy to test it :grin:

Should be ready for testing.

wget -O mediacenter-osmc.deb
sudo dpkg -i mediacenter-osmc.deb
sudo reboot
1 Like

Still seeing stuttering. Tested again with GoT 6x04 and 6x05.
Debug logs still full with CalcDropRequirement. Do other people see this also in their debug log??
Something is fundamentally wrong.

Don’t understand why it got solved for some other people in this topic. Must be related to the encoding of the videos?

Do you have Adjust refresh rate on?

Can you describe your setup in some detail?


I’ve tried this now and it seems to have fixed it, although I’m not entirely convinced that it is 100%.

Can you explain what’s not ‘100%’ for you? Logs or a small clip that shows your problem will help.


Hi @sam_nazarko. I have installed this and it has appeared to have fixed all the issues I was having. cheers Wayne

See my first post. Yes.[quote=“sam_nazarko, post:35, topic:16713”]
Can you describe your setup in some detail?

See my first post. Vero2 connected with HDMI (which was in the box) to Marantz AV7007. Samsung UE55ES8000 is connected with HDMI to Marantz. Already tried different input/output sources on Marantz.
Also tried various display option in Samsung TV.

So am I really the only one which has those CalcDropRequirement in my Debug Log??

I don’t see it with the sample clip you sent but if you have another clip exhibiting the problem that may help.