Stuttering playback of 1080p MKV x264

Fresh install of Vero2 2016.05-1 (several times already).

  • Adjusted display refresh rate to Always. TV switches nicely to 24p.
  • Audio is passthrough with AC3 and DTS capable receiver on.
  • Elevated the video buffer cache (see details in paste log below also) which noticeably helped (less stuttering)!

So Vero2 is connected through HDMI to Marantz 7007 and from Marrantz to Samsung TV. Content is read from a DS415+ and connected to a TP-Link 1Gb switch. All wired, no Wifi!
Also tried with hooking up Vero2 directly to Samsung, same result …

So it stutters very randomly, you can clearly see it ‘hangs’ for several ms and then continues again. To be honest, it is watchable, but it is very annoying coming from using Kodi on a MacMini late 2014 where it always played flawlessly.

Extract of log:
10:48:33 T:2604790768 DEBUG: CDVDPlayerVideo::CalcDropRequirement - hurry: 1 10:48:33 T:2604790768 DEBUG: CDVDPlayerVideo::CalcDropRequirement - hurry: 0 10:48:33 T:2604790768 DEBUG: CDVDPlayerVideo::CalcDropRequirement - hurry: 1 10:48:33 T:2636116976 DEBUG: CDVDClock::Discontinuity - CDVDPlayerAudio::HandleSyncError2 - was:1028395.010781, should be:1007340.003054, error:-21055.007727 10:48:33 T:2604790768 DEBUG: CDVDPlayerVideo::CalcDropRequirement - hurry: 0 10:48:33 T:2604790768 DEBUG: CDVDPlayerVideo::CalcDropRequirement - hurry: 1 10:48:33 T:2604790768 DEBUG: CDVDPlayerVideo::CalcDropRequirement - hurry: 0 10:48:33 T:2604790768 DEBUG: CDVDPlayerVideo::CalcDropRequirement - hurry: 1 10:48:33 T:2604790768 DEBUG: Previous line repeats 3 times. 10:48:33 T:2604790768 DEBUG: CDVDPlayerVideo::CalcDropRequirement - hurry: 0

Full log:

Media info:

Am I watching MKV with too high specs? Should I watch less quality rips?
Any advice please …

The Vero 2 should be able to play this.

If you can produce a small sample file and send it to me, I’ll test it here.

Can you also try playing back off a USB flash drive or local storage to rule out a network problem?


I tried it already from an 8GB thumbdrive and copied it also to /home/osmc. Exact same result. Based on that I could certainly rule out network issues.
I also tried it with a 720p release, network and local, same thing.

I don’t really know how to ‘shrink’ that MKV file, but they are widely spread … it’s s06e04 from Game of Thrones, 1080p HDTV from BATV group.

But what does those CalcDropRequirement entries in the log mean exactly?

I made a small example short example:

Around 0:34 and 0:56, like I already stated … it is watchable, but annoying …
Also it is not a faulty MKV, it plays well on my MacMini and MacBook (Kodi and VLC).

Please try the latest update. You can update via My OSMC -> Updater -> Manual Controls -> Scan for updates.

Updated. Is that a new update as of today? I remember updating yesterday to the latest.

Anyway, much better now. The stuttering is negligible, I used same video and I saw only 2 very small ‘stutters’.

Still lot’s of CalcDropRequirement - hurry in the debug log. Any explanation for that?

I’ll try watching a full movie/show.


CalcDropRequirement should not be happening. At least not frequently. I will investigate further, glad we made some progress

I pushed an update a few hours ago as I noticed a regression in Kodi upstream which could cause stuttering. This was introduced in 16.1


Just updated to the “May 21 update”
Now it’s even worse.

Before it was stuttering every 20-30 sec.
Now it’s stuttering every 7-8 sec. Really noticeable stutter.

NEVER had this kind of problem with Rpi (OSMC) or NUC (OpenELEC)

Not a good start with Vero 2, Sam :wink:

If you want log, please let me know.

Now it stutters in MPEG2 mkv’s too… It didn’t do that earlier today.

Best regards.

Playing what?

We need a log. A log is the only way to see what’s going on. A MediaInfo of the file would also be appreciated.

I think you’re adding more variables to the situation here, and it creates confusion. Here’s my advice to get this fixed as quickly as possible.

  • Find a video that played well before the May update.
  • Produce a log of the file on the April version of OSMC, and let me know that it plays back well.
  • Produce a log of the file on the May version of OSMC and let me know that there is a playback regression.
  • Provide MediaInfo for the affected file.

This thread is about 1080p MKV H264 files, but you have reported problems with an MPEG2 file. Please stick to your original thread. I am getting quite confused with the multiple posting.

If you provide a thread with a sample clip, a description of which version it played fine on, which version is problematic, and a log and MediaInfo, then we can fix it. Simple as :slight_smile:

Everything… All vidoes, mpeg2, x264.
Earlier today, it was only x264 720/1080p that was stuttering.

I have now installed “April version”
Everything plays perfectly.

Don’t know when I will have time, to do all those logs etc.

No problem – I understand busy schedules.

As soon as you can follow the above steps for affected videos, we can get the issues fixed for you :slight_smile:


Sam now all my 730p files that were playing perfectly are having frame issues. Very jumpy watching. Skipping frames like crazy. We never used to have these issues with osmc…

Just so you know to make videos watchable I had to turn off adjust display rate. There is a judder regularly with 720p videos.

Not to be rude or anything.
But it looks like everyone is having problems, with the latest update.

So could you not, check log file on your own Vero 2?

April update : Everything plays fine.
May update : All HD 720/1080p x264 stutter
May 21 update : EVERYTHING stutter.

With the image update of 21may, it is much better on my Vero2.

I even watched a movie (MediaInfo) last night and I only noticed some very small stuttering/jumping. My wife did not notice anything and that is important, so the WAF is okay again :grin:.

But still a debug log filling up with those CalcDropRequirement …

Same problems here. A LOT of videos are much worse and stuttering

Payback of 720p with 25 fps plays perfectly without any drops or skips.

As you can see, I’m getting some conflicting stories here.

There has only been a single change between April and May, and some users reported stuttering in May update. I have reverted this single change, and now there seem to be reports that ‘everything’ stutters from some users, which seems odd to me.

Of course – I haven’t had issues with h264 content that I tested back. I did have a problematic clip (XVID), but that was resolved for me in the last update.

I’ll keep looking – but I can only test what you guys send me as not working and make those clips work, which is what I’ve been doing so far.


I’ll do a fresh install of 2016.04-1 release tomorrow. Will report back. Indeed some conflicting findings on the forums at the moment …

I pushed another update today which may improve things for some users


Alright, glad I’m not the only one with stuttering video playback. I already thought it’s high cpu load etc. causing this stuttering because of openvpn connection, some downloads and upacking in the background. Not happening with vero2 :grin:
I’ll update to latest version, lets see…