Stuttery DVD playback on Vero 4k+

I recently bought a Vero 4k+. My main intended use for it is playing DVDs. Plain old DVDs, not Blu-Ray or anything so fancy. They’re all region 2. I’m using an external DVD drive that connects via USB.

On several occasions, with different DVDs, playback has temporarily become super-stuttery (maybe 5-10fps?) and when the stuttering’s done the audio has drifted multiple seconds apart from the video.

The Vero is connected to a 4k TV over HDMI. The OSMC interface is set to 1080p resolution (I initially set it to 2160p but reduced that in the hope that maybe it would somehow reduce the stuttering; it doesn’t seem to have done).

Playback with the same external DVD drive and my laptop PC is not stuttery, so I doubt the problem is that the DVD drive is somehow failing to deliver data as it should.

This is all a bit surprising, not least when the advertising for the Vero 4k+ says “It will play anything you throw at it”, promises “PC-grade performance”, and so forth.

Is there something I should be configuring differently, or installing that isn’t there by default? Or is the Vero 4k+ simply unable to play back DVD content reliably for some reason?

I haven’t kept careful note of (e.g.) whether stuttering happens at consistent places on each DVD, nor have I looked for signs of trouble in the logs. If that would be helpful for diagnosis, let me know and I’ll investigate more deeply.

I had problems playing DVD once when I tried to open it by selecting the right file inside the file structure instead of selecting the dvd folder ( as a whole) and pressing the 3 line button ( on the 4k remote) and then selecting play.

You can also press the 3 line button during playback and see if Hardware acceleleration is enabled should say HW or SW in the top left corner.

If its SW you can enable HW acceleration in settings -> player ( make sure expert level access is enabled)

First thing I would try is to connect the drive to the 4k+ by using a powered USB hub. It’s very possible (and seen quite often on this forum) that the drive is not receiving enough power if it depends on the 4k+'s USB.

Logs should let us see what’s happening here; I’d try play the ISO from local storage first.

Sam

@k2u3: I’m not doing either of those things; I’m selecting “Play disc” from the top-level menu.

On at least one disc (though this one didn’t stutter too much) hardware acceleration was definitely enabled. I don’t know whether this is a thing that might vary from disc to disc depending on exactly how they’re encoded; I’ll try some more and see.

@ActionA: OK, I’ll procure a powered USB hub and see whether that makes a difference.

@bmillham: No, but the symptoms I’m seeing (occasional super-slow video for seconds at a time) aren’t what I’d expect from having that set wrong. Or am I misunderstanding what you think might be wrong?

Do you have adjust refresh rate turned on?

Having that setting wrong causes this type of problem.

The exact setting is: Settings -> Player -> Video -> Adjust display refresh rate
It should be Always or Start/Stop

Do not have Sync Playback to display, that also can cause problems.

[Executive summary of what follows: I’ve tried most of the things suggested so far and they haven’t improved anything.]

@bmillham: OK, so I had “Adjust display refresh rate” turned off and have now turned it on. I’ll see whether that helps. (See below: doesn’t seem like it does.) “Sync playback to display” was turned off, which sounds like it was the correct setting.

@ActionA: Connecting the DVD drive via a powered hub didn’t make any difference.

I just played a DVD (this was before changing the “Adjust display refresh rate” setting as suggested) and had huge amounts of choppiness – at one point for minutes at a time. This was with the powered USB hub. Stopping and restarting playback didn’t help. A number of log entries like these were generated while it was stuttery (I haven’t yet checked whether it was also happening while it wasn’t stuttery).

21:16:44.942 T:3442512640  NOTICE: CVideoPlayerAudio::Process - stream stalled
21:16:45.246 T:3442512640   ERROR: CVideoPlayerAudio::DecodeFrame - Decode Error. Skipping audio packet (-1094995529)

I have tried again with the same DVD after changing that setting. Nothing seems to be any different. During some sections of the DVD, video plays at maybe half speed while audio continues normally; after a while the video jumps abruptly (catching up with the audio?) and then continues playing way too slowly.

Pressing the menu button on the remote control indicates:

  • am-mpeg2 decoder (HW)
  • Hardware deinterlace
  • Video is H.262 at 576p, 50fps

Toggling on the extra debug info displays a bunch of other things that don’t look obviously suspicious, but I’m not sure exactly what they mean. Let me know if the information in them might be valuable.

CPU usage is variable but never close to 100% on any core.

I haven’t yet tried ripping a DVD to the device’s own storage to see whether that’s any better. (But, again, I can play the same DVD using the same external DVD drive on my laptop, and none of this happens.)

Can you set HW Acceleration to HD and up for MPEG2 under Settings -> Playback for now?

I suspect this’ll get DVD working for now as a stopgap.

A full set of logs will be useful.

Sam

Yup, with MP2 software decoding at ordinary-DVD resolution it seems that DVD playback is now OK. (Sample size of 1; it’s ~1am local time; I’ll try some other DVDs later and report back.)

Presumably you’d like logs from playing back a DVD using HW decoding. Is there anything that would be useful beyond the ordinary thing in kodi.log?

If you enable debug logging + upload a full set of logs, we should have more insight as to what’s going on.

Glad you have a fallback for now.

Cheers

Sam