Subfolder not scraping titles

First off, I’ve seen a few other threads on this but none of the suggestions worked for me and the issues seem to be different from mine.

I have two profiles, one for the master and one for kids. The master profile source is Movies. The Kids profile source is Movies/Kids. Recently (even before the latest update) when scraping movies I noticed all newly added movies were being added to the top of the Movies list even though it’s sorted A-Z.

I found that only files added to the Kids subdirectory were missing title information. Everything else scrapes, but I have to edit the title manually and then it sorts properly. So, for instance if I throw a movie into the Movies directory and another into the Kids subdirectory, the former will get its title and sort properly but the latter has no title and goes to the top of the list.

Now I did have some files in the Movies directory that didn’t scrape their titles as well, but that seems to have resolved itself or just hasn’t happened to the recent files I added. I don’t know, it’s just frustrating and only began happening after years with the exact same setup. I’ve tried deleting files that didn’t scrape their titles, change from universal scraper to tmdb, then refresh and re-scrape, but it seems this occurs with any scraper. If I go to Information and refresh the title from internet data sometimes it works, but mostly not.

Also, when there are files that didn’t get their titles, widgets show a black box with the arrow on the home screen… the up directory/back button. Once I set titles on the files, that disappears until the next failed scrape.

Are there nfo files? Was the Kids profile setup with a shared or separate database? Are you using MySQL? Have you tried just deleting the Kids database since you changed the scraper to TMDB (ie delete userdata/profiles/kids/Database/ myvideos and texturecache13 along with userdata/profiles/kids/Thumbnails) and then reset the scraper settings?

Only some older, existing files have NFO files. The kids profile was simply created and pointed to the source on my NAS. I don’t know if it uses a different DB or not. I’m trying to avoid the days of setup it takes to remove a profile/library/skin settings, etc. Although I love the Vero, starting from scratch or even just rescanning the existing db always scrapes the wrong info for some movies and tv shows even though they’re named exactly as TMDB. One I remember last time was Disney’s Pinocchio. The file is simply named ‘Pinocchio (1940).mkv’ it scraped a foreign film not even related to the story. I spent an hour or more trying to determine what the movie should be by process of elimination on the NAS vs the order of the osmc films. That’s a different thread, though.

I didn’t suggest for you to delete any skin or other non-related to the database settings. If you can’t just do a simple scrape of “title (year).ext” for a Disney movie this would suggest there is something a bit nonstandard about how you have configured your files or scraper settings. Furthermore since you are only saying that this is happening in a profile and not masteruser this adds to the confusion as I assume they are pointing to the same place using similar settings so why should they scrape differently. Perhaps you could delete Pinocchio from Kodi’s library, reboot, turn on debug logging, update your library, then upload your Kodi log and post the returned url in this thread.

Sorry to be confusing on my last message. I solved the pinocchio issue (and a few others) long ago by manually naming the file in the osmc DB and pointing it to the correct tmdb entry. For other files I had to create an NFO to point it to the TMDB URL entry. That’s another issue for another time, though.

The issue in my opening post is happening on both the master profile and kids profile. If I scan for new files from within the KIDS profile, new files will not recieve a title, although it scrapes everything else, including the film name, year, rating, poster art, etc. It simply does not have a sort title. If I log out of the KIDS profile and into the MASTER profile, I need to scan there as well to add the new movie to the profile. It does the same thing - no sort title but all other info is scraped properly. When adding 5 movies I must go into Manage → Edit on every movie and enter a sort title. Otherwise, the file functions - the movie is out of order at the beginning of the Movies section, but the poster is correct and I can watch the film.

If I was not clear on this being a new issue, that is important. It started happening a couple months ago out of the blue. No changes to OSMC, I just noticed the black back arrow in the widgets and that new movies weren’t in alphabetcal order as they were before. They were being placed at the beginning of the movies section.

My aim was not to solve “Pinocchio” but rather to try to gain some insight into how you have your files structured and what the scraping process looks like. I don’t remember running across a similar issue so I don’t really have much in the way of reference to go off of. Sometimes people setup files in a way they don’t realize are more problematic such as having movies and series sources nested or using subfolders like a-z for organization but not disabling the ‘movies are in a seperate folder’ and enabling recursive scanning to compensate.

On one of these movies at issue if you bring up the movie info does it show the movie title? Is the title being populated but the just don’t have a sort title field. If this is the case then I would think that maybe the issue is a user made skin change where you pointed the movie main menu item to display sort titles instead of titles which would use the sort title if it existed and title if doesn’t.

For affected files, no, there is no title or sort title. All other info is there, though. The poster is correct, the description, the rating… all information EXCEPT for title. TITLE is blank when I go to Information.

The Master profile is setup as:

  • Movies (root source)
  • Kids (subfolder - \Movies\Kids)
  • ‘movies are in separate folders’ is not enabled
  • ‘recursive scanning’ is enabled

The Kids profile is set up as:

  • Kids (root source)
  • ‘movies are in separate folders’ is not enabled
  • ‘recursive scanning’ is enabled (I have subfolders like Christmas and Halloween under the Kids directory)

Just as a test earlier I deleted the Kids profile completely, then in the master profile I deleted a movie that resides in the Kids subdirectory (Up), did a ‘clean library’, then rebooted. I updated the library and again - UP scraped perfectly fine except for title and sort title being empty.

Then I deleted a movie from the Movies root source, cleaned library and rescanned. That movie scraped everything! Title, sort title and all and appeard alphabetically where it was before.

Please post some debug logs.

The Vero fails to upload. It looks like the kodi.log is 2800KB, so shouldn’t bee too large. Can I upload another route?

Did you not reboot first? That is pretty big for just a Kodi log that hasn’t been on for too long. Also that size should still upload. I’m pretty sure I read the current limit was around 10MB.

I tried again by rebooting with logging disabled, then enabled debug logging, rebooted again, performed a delete of a couple files, then rescanned with the expected results. The log upload failed with ‘could not retrieve url’. This time the log file is 556KB.

Delete ~/.kodi/temp and then reboot twice and then try again. You could also try a “grab-logs -A” or “paste-log ~/.kodi/temp/kodi.log” from the terminal. If all else fails you could also just go to and copy it manually although this is starting to sound like more things are going on than just a simple scraping issue so having a full set of logs would probably be prefered.

Deleting the temp directory worked and the log uploaded. Reproduced the issue again before uploading. I deleted one file from Movies and one from Movies/Kids. Updated library and the movie under Movies got everything and sorted but the movie under /Kids did not sort as it had no title but did have the poster and all other info.

paste url is opehimuhiy

It appears the issue is that the Kids subdirectory has been set with different scraping settings and the setting that is causing an issue is get titles from IMDB. It looks like the scraper is pulling in a tag for original title but is not populating the title field. You can just go to videos>files and then navigate to the kids subdirectory and then context menu>change content>settings> and then change that first option for where to get titles from to TMDB. Once you have done that then you can refresh from the info screens to fix the mistakes. If there is a bunch of files to fix then you may want to instead set the content to none, hit OK, and then select the option to remove these items from your library. Once it has removed all these kids movies then set content and setup your scraper again. You may want to consider using TMDB Python instead of the Universal scraper as it seems to have less quirks.

On an unrelated note you may want to consider enabling refresh rate switching in your video player settings.

And don’t forget to remove that debug entry from advancedsettings.xml. There is no reason to increase the writes on your device.

As always the support here is amazing and much appreciated! Everything is set now, thanks. I think I turned off refresh rate change because it was taking extremely long times to begin playing movies but it seems to be less of an issue now. Appreciate the help!

1 Like