Subtitle offset > 60s?

Is there a way to specify an offset in excess of 60s? I would have use for this when watching stuff recorded from TV as I generally get a minute or two of announcer in the beginning.

Thanks in advance!

Have a look at that link, I’ve pre written the basics but adjust the values to suit.

Should be something like:

nano /home/osmc/.kodi/userdata/advancedsettings.xml


    <subsdelayrange>10</subsdelayrange>  <!-- Delay range for subtitles, in seconds. -->
    <audiodelayrange>10</audiodelayrange>  <!-- Delay range for audio/video sync, in seconds. -->

Ctrl+X (to exit), Y (to save)

sudo reboot

1 Like

Thanks. I will look into that. Another option I guess, is to strip the extra from the beginning of the file. Tried doing so, but ffmpeg just segfaulted.

It depends how you do this. If the file is an MKV, you can probably use mkvtoolnix to remove the parts you don’t want and remux it. I believe that the GUI based version also supports batch processing, so you could do this quite quickly, especially as remuxing is mainly an IO operation, unlike transcoding.

I find with messed up subtitles it’s easier to just download a better version of the subtitle or use a program called Subtitle Edit. Great program for editing subtitles. Subtitle Edit I give it a plug.:slight_smile:

mkvtoolnix looks promising, but do you have any idea if you can do that from the commandline? (server is in the basement). I checked the GUI and found no option to just cut from a certain timecode.

Yes, it can run from the command line.

To cut from 1:19 and create a new file:

tvburk:/home/dalton/Videos # mkvmerge --split parts:00:01:19-01:50:00 “Star Wreck VI In The Pirkinning.ts” -o Toppy/out.mkv
mkvmerge v9.4.0 (‘Knurl’) 64bit
‘Star Wreck VI In The Pirkinning.ts’: Using the demultiplexer for the format ‘MPEG transport stream’.
‘Star Wreck VI In The Pirkinning.ts’ track 0: Using the output module for the format ‘MPEG-1/2’.
‘Star Wreck VI In The Pirkinning.ts’ track 1: Using the output module for the format ‘MP3’.
Warning: Found at least one B frame without second reference in a non closed GOP.
The file ‘Toppy/out.ts’ has been opened for writing.
Progress: 99%
The cue entries (the index) are being written…
Muxing took 44 seconds.