Subtitle Preference Cannot Be Saved

#1

Hi. I’m using 2019.07-1 firmware already. I try to enable subtitle for a video and select “save as default for all media” and select yes. But it doesn’t save the preference and next video I have to enable subtitle again. Video of what I meant.

Is this an OSMC bug or Kodi bug?

#2

Can you briefly try with another skin and post a log?

Sam

1 Like
#3

gotcha

#4

Changed skin to Estuary.

Here’s the log.

#5
    <showsubtitles>true</showsubtitles>

The default setting is changing.
It looks like there are no subtitles for the file you are playing though until they are searched for. I’m guessing you don’t have an SRT file locally?

#6

The subtitle is embedded in the file.

#7

It’s the issue I spoke here before Set as default settings for all media doesn't work

I fixed it with setting Prefered subtitle language to Use Interface language ( in my case English) in Settings-> player-> Language ( osmc skin )

2 Likes
#8

Thanks @k2u3. I’ll try this out.

#9

@k2u3 this one worked! Thank you! I will observe for now if it will work 100% of the time.