Subtitle problem with MKV

First of all, i’ve been using the Vero 4K for two weeks now and it is amazing! The issues i’m having is definitely dust behind the keyboard issues!
My main problem right now is when i’m trying to watch an MKV file, the softcoded subtitles does not appear on screen (it appears when i go into subtitle menu though as local subtitles). I’ve tried different languages but no one appears on screen. I’ve checked the same files in my computer with VLC and all the subtitles appears. I’ve tried two separate files and the problem remains with both. Is there settings I can check? I’m not the most experienced user i’m afraid but i’ll try to provide you with any information you might need!

Best of regards

Try pressing L to turn on subtitles

That shows me wether or not it is on, and although ON even though it is the spanish one or the english one. Nothing is shown on the screen, could be it be a font error?

Try to make a media info log of the file you are trying to play.

Subtitles come in a variety of different formats from srt to sub and sup and ass there is a lot of formats for subtitles so it could be that your format is not supported but I think that is unlikely. Are the subtitles muxed into the mkv file or are they in a separate file ?

Try to mux the subtitles into the mkv with something like mkvtoolnix if they don’t come included

Hope that helps

I’ll try to get a media info log!
For the rest of your notes, the subtitles are in ASS / Restyled according to the nfo and yes they are already muxed ! =)

Thank you for trying to help me ! I’ll post again when I have a media info log.

.Ass can be tricky to handle but I would not know if the 4K and kodi know how to or not. All the subtitles worked for me so far but I don’t watch anime and .ass is popular in the anime community

oh, maybe that could be the case! It is true that it is anime I am trying to watch. I think that it worked before I updated the other day, but I’m not 100%, many of my old files are .mp4 and they work flawless. Is there a way for me to check this? Thank you for your kind support!

Kodi supports ASS and we build our own version of the library to fix up some memory and performance issues.

Can you paste the MediaInfo of the file?

I think Kodi should list the subtitles under the Audio settings during playback


Okey! I used an external program for the Media Info Log. Here it comes, I hope it might give a clearer image on what the problem is!

Format : Matroska
Format version : Version 4 / Version 2
File size : 137 MiB
Duration : 23 min 23 s
Overall bit rate : 816 kb/s
Encoded date : UTC 2017-04-16 06:56:52
Writing application : mkvmerge v9.2.0 (‘Photograph’) 64bit
Writing library : libebml v1.3.3 + libmatroska v1.4.4
Attachments : KingthingsClarityPTFixN.ttf / Cocon-Regular.otf / DejaVuSansBold.ttf

ID/String : 1
Format : HEVC
Format/Info : High Efficiency Video Coding
Format_Profile : Main@L4@Main
Duration/String : 23 min 22 s
BitRate/String : 716 kb/s
Width/String : 1 280 pixels
Height/String : 720 pixels
DisplayAspectRatio/String : 16:9
FrameRate_Mode/String : Constant
FrameRate/String : 23.976 (24000/1001) FPS
ColorSpace : YUV
ChromaSubsampling/String : 4:2:0
BitDepth/String : 8 bits
Bits-(Pixel*Frame) : 0.032
StreamSize/String : 120 MiB (88%)
Encoded_Library/String : x265 2.3+1-7e225aefd389:[Windows][GCC 6.3.0][64 bit] 8bit+10bit+12bit

Default/String : Yes
Forced/String : No
colour_range : Limited
colour_primaries : BT.709
transfer_characteristics : BT.709
matrix_coefficients : BT.709

ID/String : 2
Format : AAC
Format/Info : Advanced Audio Codec
Format_Profile : LC
CodecID : A_AAC
Duration/String : 23 min 22 s
BitRate/String : 96.0 kb/s
Channel(s)/String : 2 channels
ChannelPositions : Front: L R
SamplingRate/String : 44.1 kHz
FrameRate/String : 43.066 FPS (1024 spf)
Compression_Mode/String : Lossy
Video_Delay/String : 22 ms
StreamSize/String : 16.0 MiB (12%)
Title : Japanese Stereo
Language/String : Japanese
Default/String : Yes
Forced/String : No

Text #1
ID/String : 3
Format : ASS
CodecID/Info : Advanced Sub Station Alpha
Duration/String : 22 min 55 s
BitRate/String : 102 b/s
ElementCount : 310
Compression_Mode/String : Lossless
StreamSize/String : 17.2 KiB (0%)
Language/String : English
Default/String : No
Forced/String : No

Text #2
ID/String : 4
Format : ASS
CodecID/Info : Advanced Sub Station Alpha
Duration/String : 22 min 51 s
BitRate/String : 91 b/s
ElementCount : 304
Compression_Mode/String : Lossless
StreamSize/String : 15.4 KiB (0%)
Language/String : Portuguese
Default/String : Yes
Forced/String : No

Text #3
ID/String : 5
Format : ASS
CodecID/Info : Advanced Sub Station Alpha
Duration/String : 22 min 51 s
BitRate/String : 96 b/s
ElementCount : 296
Compression_Mode/String : Lossless
StreamSize/String : 16.2 KiB (0%)
Language/String : Spanish
Default/String : No
Forced/String : No


Does Kodi list the subtitle track under Audio?
I’ve checked and OSMC’s libass library is present, so support should be there. This was something that I thought could have been an issue.

Kodi debug log may provide some clues


Hi again Sam!

Yes Kodi lists the three subtitle tracks under Audio, but the third one (spanish) is automatically chosen so I change it to english and presses OK but no subtitle, when I go into audio menu again its back to being set on spanish. (To clarify, Neither Spanish, Portugese or English subtitle is working. This problem is not only in this file but on all the files from the same anime source, which works on my computer in VLC)

I started the debug log, I apologize but i’m not exactly sure on how to use it. But here is what it shows below after i started the file, changed to english subtitle

20:02:40.705 T:3602191344 DEBUG: CDVDAudio::Pause - pausing audio stream
20:02:40.725 T:4114232304 DEBUG: CAnnouncementManager - Announcement: OnSeek from xbmc
20:02:40.725 T:4114232304 DEBUG: GOT ANNOUNCEMENT, type: 1, from xbmc, message OnSeek
20:02:40.752 T:3602191344 DEBUG: CDVDAudio::Flush - flush audio stream
20:02:40.753 T:3602191344 DEBUG: CDVDAudio::Pause - pausing audio stream
20:02:40.867 T:3602191344 DEBUG: CVideoPlayerAudio - CDVDMsg::GENERAL_SYNCHRONIZE
20:02:40.867 T:3627234288 DEBUG: CVideoPlayerVideo - CDVDMsg::GENERAL_SYNCHRONIZE
20:02:40.867 T:4114240432 DEBUG: ------ Window Init (Custom_Cache_Progress.xml) ------
20:02:40.868 T:4114240432 DEBUG: started alarm with name: iscachingtimer
20:02:40.871 T:3627234288 INFO: CVideoPlayerVideo - Stillframe left, switching to normal playback
20:02:40.880 T:3539694576 DEBUG: CVideoPlayer::HandleMessages - player started 1
20:02:40.886 T:3539694576 DEBUG: CVideoPlayer::HandleMessages - player started 2
20:02:40.886 T:3539694576 DEBUG: CVideoPlayer::SetCaching - caching state 3
20:02:40.886 T:3539694576 DEBUG: CDVDClock::SetSpeedAdjust - adjusted:0.000000
20:02:40.886 T:3539694576 DEBUG: CVideoPlayer::SetCaching - caching state 0
20:02:40.887 T:3539694576 DEBUG: CDVDClock::SetSpeedAdjust - adjusted:0.000000
20:02:40.887 T:3539694576 DEBUG: VideoPlayer::Sync - Audio - pts: 1144950000.000000, cache: 311304.160921, totalcache: 585759.639740
20:02:40.887 T:3539694576 DEBUG: VideoPlayer::Sync - Video - pts: 1144810000.000000, cache: 50000.000000, totalcache: 100000.000000
20:02:40.887 T:3602191344 DEBUG: CVideoPlayerAudio - CDVDMsg::GENERAL_RESYNC(1144638695.839079)
20:02:40.887 T:3602191344 DEBUG: CDVDAudio::Resume - resume audio stream
20:02:40.887 T:4085249008 DEBUG: ActiveAE - start sync of audio stream
20:02:40.902 T:4114240432 DEBUG: ------ Window Deinit (Custom_Cache_Progress.xml) ------
20:02:41.029 T:4085249008 DEBUG: ActiveAE::SyncStream - average error of 10.426208, start adjusting
20:02:41.029 T:4085249008 DEBUG: ActiveAE::SyncStream - average error 0.426208 below threshold of 30.000000
20:02:41.085 T:3627234288 DEBUG: CAMLCodec::SetSpeed, speed(1000)
20:02:41.085 T:3627234288 DEBUG: CVideoPlayerVideo - CDVDMsg::GENERAL_RESYNC(1144638695.839079)
20:02:42.052 T:3602191344 DEBUG: CDVDClock::ErrorAdjust - CVideoPlayerAudio::OutputPacket - error:-26581.856623, adjusted:-26581.856623
20:02:43.369 T:4114240432 DEBUG: ------ Window Deinit (DialogSeekBar.xml) ------
20:02:48.161 T:3627234288 DEBUG: CPullupCorrection: detected pattern of length 1: 41702.50, frameduration: 41708.333333
20:02:49.091 T:4114240432 DEBUG: LIRC: Update - NEW at 120006749:160 0 KEY_OK linux-input-layer (KEY_OK)
20:02:49.091 T:4114240432 DEBUG: OnKey: 11 (0x0b, obc244) pressed, action is OSD
20:02:49.091 T:4114240432 DEBUG: ------ Window Init (VideoOSD.xml) ------
20:02:49.109 T:4114240432 DEBUG: LIRC: Update - NEW at 120006767:160 0 KEY_OK_UP linux-input-layer (KEY_OK_UP)
20:02:50.059 T:4114240432 DEBUG: LIRC: Update - NEW at 120007718:160 0 KEY_OK linux-input-layer (KEY_OK)
20:02:50.060 T:4114240432 DEBUG: OnKey: 11 (0x0b, obc244) pressed, action is Select

We really need to see complete logs, not snippets.

Yes sure! However, it appears to be too much text to post the entire debug log from this morning, and I am only allowed to upload image files. How do you usually post the debug logs? I’m sorry that I take up your time with unnecessary question but I’m new to the forum and the community.

See How to submit a useful support request - General - OSMC for a quick primer

Oh i feel stupid! Of Course!

Mediainfo log

Does running:

sudo apt-get update
sudo apt-get -y install libharfbuzz0b
sudo reboot

Resolve the problem? If not, please upload another log.

Yes this worked! Thank you!

Thanks for confirming.

I’ll fix this in the next update


Fixed in

Will be in the next update