Subtitles and movie way out of sync

I don’t know how to go about fixing this.
Is it an Addon issue, RPi, KODI, or OSMC ?

I tried adjusting the audio offset but no amount of adjusting could repair this.

Additionally, I tried using a different subtitle file and it seemed like it got the completely wrong subtitle.

Are there some settings that can help with this or logs that I can look at to try and track it down,


Hi, got the exact same issue yesterday. Did you download the subtitle using the opensubtitles subtitle addon?

It feels to me the issue was on their side. I used Subscene directly after and no problem.

Subtitle timing errors will either be a problem with the subtitle file or your subtitle file doesn’t quite match the “version” of the movie that you have…

If the error is a constant offset right through the movie there is a separate subtitle offset you can adjust to compensate but it’s usually better to look for another subtitle file.

I was using the subtitles from the pop up that is available while the movie is playing.
What is Subscene ? This is the 1st time that I have heard that word.

You should check the frame rate of your video (25fps, 30fps, … ?) and see if it is matching the frame rate of the subtitle file. If they differ, you should use an external tool to re-sync the subtitle timecode to match your video framerate.

Thank you tanaka for your suggestion. As was expected I tried viewing a movie to see wassup and of course everything was syncing properly.
In any respect what do I look for in the subtitle files ?
Most of what I see are stuff like::

And nothing that I see lets me look at its properties.

Well, actually if you see that the subtitle is always out of sync (no matter the delay you set), and if your video is 25fps, the first guess is that the subtitle framerate is 29,97fps (or 23,97fps). Usually TV frame rates in the US are different from European ones, for example. The same could be with discs coming from the US and discs from other regions.
With the subtitle re-sync tool you can try to export the subtitle file with a different frame rate timecode.
First of all find out your video fps, then you must set that as output fps, and try with different input fps. It’s mostly try and error. With a couple of tries you usually find the right one.
I don’t think that from the subtitle filename you can tell what framerate it is based on, unless it contains something like nnfps.