Subtitles enigma2

Hello, I would like to display subtitles to recordings of movies obtained with openatv enigma2. I think I’ve tried everything but I could be wrong. I thought a new version of OSMC would solve this difficulty.

Have you tried settings>player>subtitles>enable parsing for closed captions>[enable]

parsing for closed captions is enable but no subtitles.

I’m not familiar with this add-on but I’m guessing it is a PVR solution. Is this correct? If so have you checked the settings of the add-on to see if there is an option to enable subs there. In my setup (using a different backend) I believe it is needed to both enable then in the PVR add-on and enable parsing (since they are CC and not subs).

The recordings come from a dvb satellite receiver. It’s not an add-on. Each recording is divided in seven files and the subtitles are in those files. If I play these recordings with vlc (windows ) on my laptop, the subtitles are displayed and synchronized with the soundtrack. If I play with vlc (linux) raspberri pi, the subtitles are displayed but not synchronized. If I play with osmc, there are no subtitles.

So your just using the file browser or library? What are the file names of these seven files?

Yes, the file browser. Files .EIT, .JPG, .TS, .CUTS, .AP, .META, .SC

Which one of those are the sub/cc and what format is it encoded in?

I don’t know. Thanks for your help.

Although I’m not familiar with the particulars of your setup Kodi will normally let closed captions imbedded in a transport stream show up when you have parsing enabled. External subtitles in a variety of formats are supported but they must be named exactly the same as the video file (the part before period at least as it allows for things such as and either be sitting in the same folder or a location set in Kodi’s settings and use a file extension that Kodi recognizes. Maybe you could upload a small sample somewhere.

The only other thing that comes to mind is that maybe it is using teletext for the subs/cc in which case you can enable that in the Player>videos> section.

Thanks. I will try as soon as possible : Player>videos>section.

Hello Sam. I will send you a sample of a recording.

You can find the sample here :

That clip contains no subtitles or closed captions. That file has only teletext subs and as such to view those you have to first have teletext enabled in Kodi’s settings and during playback you have to bring up the player controls and click on the teletext button. How it works beyond this I’m not sure but you should be able to find more information over on Kodi’s wiki and forum.

Did you get the Teletext Subtitles in playing the clip ?

I got the subtitles to appear with that test clip by enabling teletext in the settings and then during playback bringing up player controls and then pressing the teletext button and then when a test screen came up pressing the up or down direction arrows displayed subtitle text. On this test clip when played on OSMC the subs didn’t advance unless I hit the enter/OK/select button which manually advanced them one by one. When I tried the same in Kodi running on Windows they automatically advanced but the timing was very far off. At this point I had no idea if the issues were with the test clip, bugs, limitations of Kodi, or what. I also have zero familiarity with teletext as it never saw any kind of widespread adoption where I live. So at this point the most prudent thing to do would be to search the topic of teletext over at Kodi, which is what I suggested you do.

thanks darwindesign, I made a research for Teletext Subtitles support through the forum but I found nothing. I do not desperate that Sam implements the functionnality if it’s technically possible not making the code impossible to handle for an exception.

Nothing? I just googled “kodi teletext subtitle” and the first link seemed to point to something relevant…

thanks. I had searched through the forum