Subtitles not working (used to work) [Solved]

I hope that this is a simple problem to fix.

Subtitles seem to have stopped working on my installation of OSMC.

When choosing the options whilst playing the files it shows the full list of subtitles available, but selecting any subtitle and switching subtitles on does not display the subtitles.

I downloaded external subtitles to try that way, but although I can select the external subs they also do not display on the screen.

These are files I’ve played before successfully with the subtitles embedded in the mkv files so I’m guessing that an update since I last watched them has caused this issue.

If I play the files using VLC Media Player on another machine I can turn the subtitles on and off so I don’t think there is an issue with the files themselves.

Logfile is at

P.S. If anyone know how to stop the recurring issue in the logs (see next few lines) that would be awesome :slight_smile:

WARNING: CAddonSettings[metadata.universal]: failed to load value "TomatoMeter" for setting tomato
WARNING: CAddonSettings[metadata.universal]: failed to load value "USA" for setting imdbcertcountry

This is a stab in the dark but I would test it without the custom cache settings in your advancedsettings.xml

1 Like


That worked.

I don’t know why it worked though, those settings were there since 25th June and the subtitles definitely worked much more recently than that.

There must be a conflict between that setting and something in the October update.

1 Like