Sudden NFS Issues With Previously Working Config


#1

I have 4 Raspberry Pi’s of various hardware versions. I have a Win 7 PC that I am sharing directories from while utilizing HaneWIN NFS Server. I changed nothing in the config on any Raspberry or the PC. Suddenly the NFS share for my video directory would not connect on any Raspberry. I updated one of the Raspberries to the latest available OSMC via manual update: 4.14.78-4-osmc

I did an uninstall / install of HaneWIN NFS Server, as well.

A showmount -e from the host:
osmc@Brooke-Pi:/mnt$ sudo showmount -e 192.168.1.7
Export list for 192.168.1.7:
/e/my videos 192.168.1.2,192.168.1.253,-range
/e 192.168.1.2,192.168.1.253,-range
osmc@Brooke-Pi:/mnt$

My fstab:
osmc@Brooke-Pi:/mnt$ cat /etc/fstab
/dev/mmcblk0p1 /boot vfat defaults,noatime,noauto,x-systemd.automount 0 0
192.168.1.7:/e/my\040videos /mnt/videos/ nfs _netdev,ro,intr,noatime,rsize=32768,wsize=32768,nolock,async 0 0

When I attempt to “sudo mount /mnt/videos” the command hangs until timeout. If I attempt to mount just from command line, bypassing fstab:
osmc@Brooke-Pi:/mnt$ sudo mount -v 192.168.1.7:/e/My\ Videos /mnt/videos
mount.nfs: timeout set for Sat Jan 5 15:45:52 2019
mount.nfs: trying text-based options ‘vers=4.2,addr=192.168.1.7,clientaddr=192.168.1.112’
mount.nfs: mount(2): Protocol not supported
mount.nfs: trying text-based options ‘vers=4.1,addr=192.168.1.7,clientaddr=192.168.1.112’
mount.nfs: mount(2): Protocol not supported
mount.nfs: trying text-based options ‘vers=4.0,addr=192.168.1.7,clientaddr=192.168.1.112’
mount.nfs: mount(2): Protocol not supported
mount.nfs: trying text-based options ‘addr=192.168.1.7’
mount.nfs: prog 100003, trying vers=3, prot=6
mount.nfs: trying 192.168.1.7 prog 100003 vers 3 prot TCP port 2049
mount.nfs: prog 100005, trying vers=3, prot=17
mount.nfs: trying 192.168.1.7 prog 100005 vers 3 prot UDP port 1058
mount.nfs: mount(2): No such file or directory
mount.nfs: mounting 192.168.1.7:/e/My Videos failed, reason given by server: No such file or directory

If I just mount E:, it works. I am then able to browse into My Videos:
osmc@Brooke-Pi:/mnt$ sudo mount 192.168.1.7:/e/ /mnt/videos
osmc@Brooke-Pi:/mnt$ ls /mnt/videos | grep “My Videos”
My Videos
My Videos.scn
osmc@Brooke-Pi:/mnt$ cd /mnt/videos/My\ Videos
osmc@Brooke-Pi:/mnt/videos/My Videos$ pwd
/mnt/videos/My Videos
osmc@Brooke-Pi:/mnt/videos/My Videos$ cd /mnt
osmc@Brooke-Pi:/mnt$ sudo umount videos/
osmc@Brooke-Pi:/mnt$ sudo mount 192.168.1.7:/e/My\ Videos /mnt/videos
mount.nfs: mounting 192.168.1.7:/e/My Videos failed, reason given by server: No such file or directory

I’ve messed with this for several hours now and I can’t find the fix. I do have SMB setup pointing to the same directory on the PC and it’s functional.

I did temporarily create an export to another subfolder of E:, to confirm it wasn’t a subfolder issue. It worked without a problem. That folder did not have a space in the name but again, it was working with the \040 space call.

https://paste.osmc.tv/igevezekez


#2

Verify that the folder that you temporarily exported has the same permissions (and NFS config) as “My Videos”.

Next, try mounting “/e/my\040videos”, since that is what is exported.

NTFS is case-preserving, but insensitive, while NFS mounts are case sensitive. Also verify that the HaneWIN config is pointing the NFS export of “/e/my videos” to the right Windows folder, and that folder really exists (no accidental move/rename/etc.).


#3

@nabsltd I tried a command line mount as described, no joy.

osmc@Brooke-Pi:/mnt$ sudo mount -v 192.168.1.7:/e/my\040videos /mnt/videos
mount.nfs: timeout set for Sat Jan 5 18:44:33 2019
mount.nfs: trying text-based options ‘vers=4.2,addr=192.168.1.7,clientaddr=192.168.1.112’
mount.nfs: mount(2): Protocol not supported
mount.nfs: trying text-based options ‘vers=4.1,addr=192.168.1.7,clientaddr=192.168.1.112’
mount.nfs: mount(2): Protocol not supported
mount.nfs: trying text-based options ‘vers=4.0,addr=192.168.1.7,clientaddr=192.168.1.112’
mount.nfs: mount(2): Protocol not supported
mount.nfs: trying text-based options ‘addr=192.168.1.7’
mount.nfs: prog 100003, trying vers=3, prot=6
mount.nfs: trying 192.168.1.7 prog 100003 vers 3 prot TCP port 2049
mount.nfs: prog 100005, trying vers=3, prot=17
mount.nfs: trying 192.168.1.7 prog 100005 vers 3 prot UDP port 1058
mount.nfs: mount(2): No such file or directory
mount.nfs: mounting 192.168.1.7:/e/my040videos failed, reason given by server: No such file or directory
osmc@Brooke-Pi:/mnt$

On the PC, I copied the export line into windows explorer and confirmed it opened E:\My Videos. I have “everyone” set to full control of E:\ and E:\My Videos, for troubleshooting purposes.

Here I tried again to mount My Videos, then just E:. As you can see, I can list the contents of the My Videos folder when E:\ alone is mounted.

osmc@Brooke-Pi:/mnt$ sudo mount -v 192.168.1.7:/e/my\040videos/ /mnt/videos
mount.nfs: timeout set for Sat Jan 5 18:49:39 2019
mount.nfs: trying text-based options ‘vers=4.2,addr=192.168.1.7,clientaddr=192.168.1.112’
mount.nfs: mount(2): Protocol not supported
mount.nfs: trying text-based options ‘vers=4.1,addr=192.168.1.7,clientaddr=192.168.1.112’
mount.nfs: mount(2): Protocol not supported
mount.nfs: trying text-based options ‘vers=4.0,addr=192.168.1.7,clientaddr=192.168.1.112’
mount.nfs: mount(2): Protocol not supported
mount.nfs: trying text-based options ‘addr=192.168.1.7’
mount.nfs: prog 100003, trying vers=3, prot=6
mount.nfs: trying 192.168.1.7 prog 100003 vers 3 prot TCP port 2049
mount.nfs: prog 100005, trying vers=3, prot=17
mount.nfs: trying 192.168.1.7 prog 100005 vers 3 prot UDP port 1058
mount.nfs: mount(2): No such file or directory
mount.nfs: mounting 192.168.1.7:/e/my040videos/ failed, reason given by server: No such file or directory
osmc@Brooke-Pi:/mnt$ sudo mount -v 192.168.1.7:/e /mnt/videos
mount.nfs: timeout set for Sat Jan 5 18:49:46 2019
mount.nfs: trying text-based options ‘vers=4.2,addr=192.168.1.7,clientaddr=192.168.1.112’
mount.nfs: mount(2): Protocol not supported
mount.nfs: trying text-based options ‘vers=4.1,addr=192.168.1.7,clientaddr=192.168.1.112’
mount.nfs: mount(2): Protocol not supported
mount.nfs: trying text-based options ‘vers=4.0,addr=192.168.1.7,clientaddr=192.168.1.112’
mount.nfs: mount(2): Protocol not supported
mount.nfs: trying text-based options ‘addr=192.168.1.7’
mount.nfs: prog 100003, trying vers=3, prot=6
mount.nfs: trying 192.168.1.7 prog 100003 vers 3 prot TCP port 2049
mount.nfs: prog 100005, trying vers=3, prot=17
mount.nfs: trying 192.168.1.7 prog 100005 vers 3 prot UDP port 1058
osmc@Brooke-Pi:/mnt$ ls videos/My\ Videos | grep Halloween
Halloween
osmc@Brooke-Pi:/mnt$


#4

From command line, this is incorrect, use:

osmc@Brooke-Pi:/mnt$ sudo mount -v 192.168.1.7:/e/my\ videos/ /mnt/videos

You only use \040 in fstab. From command line just a <space> is needed.


#5

You haven’t recently upgraded to a newer version of HaneWin, have you? Or removed it and reinstalled? I had some very weird stuff happening with HaneWin a month or two back, which turned out to be the result of some settings that had been added since the last time I had installed it.

If I recall correctly, the two that were causing most of the problems were on the “Server” tab in the control panel app: make sure “Use Windows file ID as inode on NTFS volumes” is not checked, and set the extended character set to UTF-8.


#6

You are a genius! This started after a power outage, yes I had not changed any settings, myself. I did upgrade HaneWIN NFS during my troubleshooting process and I cannot recall if those settings were on the previous iteration of the software. I figured the issue was somewhere in translation (which those settings confirm) but I couldn’t find an error to point to it. Thank you, Angry.Sardine!


#7

You’re welcome. :sunglasses:


#8

I was just having similar issues as well on version 1.2.29. Nothing was showing up on the exports list. I Upgraded and did your solution and all is good.