Suddenly videos takes a minute to start

If you followed the commands above exactly as they were written then it would restore back to exactly as it was as you would just be shifting the entire user data folders around. I suspect that you moved a folder to an existing location and got some kind of a merge out of the deal.

Hm, I was very careful. But sure could be.

However now I made a new .kodi and deleted everything else (all the baks from testing) and I only dropped the “userdata” from my full backup I made yesterday into this fresh kodi.

All my old shares still do not work and I really dont know why. It has something to do with password Im sure. I can no longer browse to the share which is the way I have setup everything initially. I have tried different SMB protocols to no avail.

However if I add it as a network location instead, then Im forced to enter user/pass and then that share works beautifully.

It even start the media directly now as its supposed to so It could very well have been some addon I didnt manage to get rid of before.

I do really need help to understand what is going on with my shares tho and why they suddenly are not working, because my entire library on both profiles is based on them.

Any thoughts?

The way it works with Kodi and the passwords file is with path substitution. When you add a new source that is smb and add a user/pass it adds the path in sources.xml and then it makes a passwords.xml where it does a from/to that changes <path> to user:pass@<path>. You can setup a new share which would make this passwords file again or just manually create it on your own via ssh

nano ~/.kodi/userdata/passwords.xml

and the contents would be an edited version of this

<passwords>
    <path>
        <from pathversion="1">smb://192.168.254.201/</from>
        <to pathversion="1">smb://User%20Name:password@192.168.254.201/</to>
    </path>
</passwords>

The %20 takes the place of a space if you happen to have one in your username. The username and password are separated with the colon. You would of course replace the ip address with your own or computer name. This MUST match how your existing sources are setup. If you have more than one path you have to configure you just add more <path></path> sections. It works the same as what I outline in this how-to for a different type of path substitution.

I will try that, I just find it wierd that I couldnt find that passwords.xml file in any of my full backups, nor in any of the .kodi or kodi.bak I made, its just not anywhere. Im looking at hidden files etc and its nowhere.

Could it be something about using another SMB version before? I made my library when I was on Win7.

//edit - since this post is marked as the solution I want to sum up that the solution to the minute-long start of play of a file from the clicking on it - did solve itselv by:

  • making a new .kodi and dropping the entire userdata folder into that, from my latest backup. The culprit is still unknown but probably some add-on.
  • getting a passwords-xml file into the new .kodi since it doesn`t get backed up.

Dude, I just tried one of my shares for funsies right now before fixing things, and everything works!

So adding that network share yesterday did actually make a passwords.xml in my userdata.

So everything works, files play beautifully imediately (and its so good you wont believe the feeling, I was going crazy with this 1-minute waiting), both profiles work etc.

I will enable some ad-ons that I need, like subscene and Extras for starters, but will do it one by one and if I find it goes back to the slow playing I will notify in this thread.

Also want to give a shout out @sam_nazarko for adding the Samba Server in My OSMC, it really helps us non Linux nerds to get a good perspective of the files on the device and its easy to drag and drop from the backup!

1 Like

Glad you got it going. I took a look and it would seem that the backup in the My OSMC add-on is lacking an option to grab passwords.xml and doesn’t do it automatically . I also noticed it also lacks an option to backup mediasources.xml and the peripheral_data folder which is not ideal. Perhaps this is something @sam_nazarko can look into improving.

Yeah you can get a little panicky when restoring from backup and “nothing works” :sweat_smile:

We still dont know the culprit of the wierd anomaly I had with a minute chill before starting videos. As I said, I will report back if it comes back.

Suddenly I got this long startup again (which is more 30seks then a minute to be honest). I have not installed any addons since i fixed this.

It just started by seemingly not taking commands from the remote, and then after a good while you hear all the clicks coming in at once. 2 reboots didnt help. I have also shut it down and cut the power and double rebooted after but its still the same both on master user and kids profile.

Right now most files do play after this very long pause, but some actually dont play at all. Everything plays fine directly logging into the server and starting the files from the hardrive.

Am I the only one this happens to? I can probably fix it the same way I did before but Im a little interested to see whats goig on.

Testing today is a little less buggy (not all clicks come in at once and also all files seems to play) but the videos still takes long to load:
( a donald rip from dvd and a mr.bean also from dvd in the logs, but the same behaviour is on all files. Browsing etc works good)

https://paste.osmc.tv/fuxosesaze

So its fixed by doin this:

have a backup for safety

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bak
systemctl start mediacenter

logout
drop “userdata” from kodi.bak to .kodi

rm -r ~/kodi.bak

But still…a little annoying to do after 2 months…so…anyone?