Suddenly videos takes a minute to start


Suddenly when I start a video it takes a very long time to start. It kinda freezes and just stays there until the video starts (30sec to a minute seems like larger files takes longer) its no icon buffering or anything else. With debugging on that text also stays completely still while the video is “starting”.

After starting it plays fine, I can stop, skip forward etc without troubble. Audio is fine, subs works its basically only the starting time that is wierd.

I rebooted, turned on debug, started a video and uploaded:

All I could think of was to go in and see if the space was full on the unit (I stream everything but has alot of thumbnails) but it looked alright 60% full or something. Noticed 2pcs of backups (tarballs) and the oldest one was from 2018 so I deleted that to free up some space but otherwise I have done nothing.

I couldn’t spot anything off in your logs. Have you tried playing the same file on your PC to see if maybe the drive is slow? If that plays okay I would put the same file on USB storage and play it directly from that on the Vero to see if the playback is okay if your not going through the network. If it is then I would run iperf between your PC and Vero to get an idea of how your network connection is doing.

It plays fine on the PC.

It starts as slow from the usb directly into the vero. No change.
(Copyed the file to a usb stick and inserted it into the vero and found it through automount 100% sure i actually played from the stick).

Just to be sure another log set from the try to play the video from the USB stick would be fine.

So reboot, start debug, play…stop…upload logs?

Start debug, reboot, play, stop, provide logs.

From USB stick:

There is a time gap between 01:47:18 and 01:47:58 but the logs does not give any help what is causing this

Dec 24 01:47:18 osmc kernel: hdmitx: audio: aout notify rate 44100
Dec 24 01:47:18 osmc kernel: hdmitx: audio: aout notify size 32
Dec 24 01:47:18 osmc kernel: hdmitx: audio: hdmi_ch: 0 speaker_layout: 0
Dec 24 01:47:18 osmc kernel: hdmitx: audio: no update

Dec 24 01:47:58 osmc kernel: vout_serve: vmode set to null
Dec 24 01:47:58 osmc kernel: vout_serve: disable HDMI PHY as soon as possible
Dec 24 01:47:58 osmc kernel: hdmitx: video: vinfo: 1080p60hz 2997 50
Dec 24 01:47:58 osmc kernel: hdmitx: video: vinfo recalc: 1080p60hz 2997 50
Dec 24 01:47:58 osmc kernel: fb: osd current vmode=1080p60hz, cmd: 0x50000
Dec 24 01:47:58 osmc kernel: tv_vout: tv_set_current_vmode[919]fps_target_mode=67
Dec 24 01:47:58 osmc kernel: tv_vout: mode is 67,sync_duration_den=1,sync_duration_num=60

kodi log
2020-12-24 01:47:18.517 T:4071637008   DEBUG: HandleKey: return (0xf00d) pressed, action is Select
2020-12-24 01:47:18.525 T:4071637008   DEBUG: OnPlayMedia /media/Therese 2/Insert.Coin.2020.1080p.WEB-DL.DDP2.0.H.264.mkv

2020-12-24 01:47:47.113 T:3749703904   DEBUG: Thread JobWorker 3749703904 terminating (autodelete)
2020-12-24 01:47:47.114 T:3847176416   DEBUG: Thread JobWorker 3847176416 terminating (autodelete)
2020-12-24 01:47:47.114 T:3889139936   DEBUG: Thread JobWorker 3889139936 terminating (autodelete)
2020-12-24 01:47:47.134 T:3965890784   DEBUG: Thread JobWorker 3965890784 terminating (autodelete)
2020-12-24 01:47:58.799 T:4071637008   DEBUG: CPlayerCoreFactory::GetPlayers(/media/Therese 2/Insert.Coin.2020.1080p.WEB-DL.DDP2.0.H.264.mkv)

3 out of the 4 jobworkers terminating belong to the yahoo weather service … but I think this is not related. I’m out of ideas with that info. Others are welcome to think about possible root causes.

Additon: These are installed plugins I suggest to deactivate one by one and check whether the current one influences the behaviour:

2020-12-24 01:46:45.279 T:4071637008  NOTICE: ADDON: v3.0.3 installed
2020-12-24 01:46:45.279 T:4071637008  NOTICE: ADDON: v2.0.0-beta21 installed
2020-12-24 01:46:45.279 T:4071637008  NOTICE: ADDON: v2.2.3 installed
2020-12-24 01:46:45.279 T:4071637008  NOTICE: ADDON: v4.0.5 installed
2020-12-24 01:46:45.279 T:4071637008  NOTICE: ADDON: v4.7.0 installed
2020-12-24 01:46:45.279 T:4071637008  NOTICE: ADDON: v5.1.11 installed
2020-12-24 01:46:45.279 T:4071637008  NOTICE: ADDON: v2.5.3 installed

That is the 40secs it just stands there frozen after I click “ok”. The debug-ovelay also freezes here.

I will remove those addons, and if it doesnt work I will also remove the weather…it is nice to have but its nicer to be able to use the device normally so :stuck_out_tongue:

I removed everything one by one and rebooted and no luck. Nothing changed.

Its also the same on the kids profile.

Can i revert a version and see if that helps? How do I do that? (Need commands to run)

If the kids profile is running an independent database (you have to scan for media separately) then it is probably something on the OS side of things. What in particular, I’ve no clue. In this case I would use the backup feature in the My OSMC add-on and make sure you are saving it to an external location. Once you have that I would do a full reinstall. Note that the backup may be large and time consuming as there is no option to exclude thumbs from profiles (the option presented only affects the master profile). With the clean install try playing from USB before restoring from backup to make sure the issue is not present.

If your using a shared library with the profiles you might try temporarily moving to clean user data (much faster than a full install) to test if the issue is somewhere in config. You can use the following to effect this…

Let’s test with Kodi default settings. Enter the following commands with an SSH connection.

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bak
systemctl start mediacenter

If needed you can restore:

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bk2
mv ~/kodi.bak ~/.kodi
systemctl start mediacenter

If your original setup was restored as expected and you want get rid of the unneeded clean install you can delete that with the following command.

rm -r ~/kodi.bk2

1 Like

So this basically enables kodi anew, and with the data renamed it will populate with a clean set of files/configs? (and keeping my stuff in the .bak) presenting me with what will basically be the eqvivalent of a reinstall in sorts, just to see if the problems goes away?


Running the command to start with a fresh mediacenter - it works flawlessly. Files play imediatly from USB and network share.

Now what to do? I have so many custom thumbnails its not even funny.

Suggestions? :stuck_out_tongue:

Fresh install and then use backup? I am alittle afraid of that option since i did that once many years ago and it did not end up looking like it should, i remember having to manually move stuff over from the backup and its very timeconsuming.

Ok so I have a full backup from yesterday, so Im doin another backup with only my thumbs, sources, profiles and none of the addons and settings and can try to place that back on a fresh mediacenter just to see if that works and if the problems comes within that?

If your worried about loosing custom art then exporting your library to individual files might be something to consider.

As for the backup solution to do a partial restore this is going to be an issue with profiles as neither the OSMC or the backup add-on in the Kodi repository support partial restore of profiles. Actually support for profiles across the board in Kodi isn’t great. You might just try disabling add-ons to see if that clears it up first.

I use profiles myself but rather than mess around in Kodi I just install smb server and manually edit and copy things from my PC. You can install smb server from the My OSMC add-on and in windows you can just type in the file explorer address bar \\[ip.of.your.vero] to bring up the osmc home folder of your Vero. You just need to make sure you logoff in Kodi (or just stop it via ssh) before trying to do something like swapping a database or the guisettings.xml.

Well this didnt work.

With the backup restored onto the clean .kodi the file takes even longer to start (or at least as long).

Furthermore, moving back my .bak and restoring everything to the way it was (mv ~/kodi.bak ~/.kodi) also doesnt work, no files can play and no mounts are working.

I renamed the addons folder (to be sure to disable all addons) but that didnt help.

So im moving the entire userdata to a clean .kodi and lets see how that works.

Now I get the “Operation not permitted” on all shares. Wasnt there a “passwords.xml” in the userdata-folder before? I cant find it anymore, feeling this is the culprit for that error?

If you are using Kodi smb paths and set them up the normal way there should be a passwords.xml file in .kodi/userdata and depending on how you hade them configured also maybe .kodi/userdata/profiles/[profile name]

If you didn’t select that in backup and restore then the former would be missing. If you restored your profiles and they use the same passwords you may just be able to copy from there.

So basically since nothing worked I just moved my kodi.bak to .kodi

And this error just happend. No shares work.

It should go back to the way it was right?