Suddenly won't boot, can't connect remotely and no visual output

I have a Raspberry Pi 3 Model B running OSMC with an external USB hard-drive connected. I was copying some files over via SMB, while also trying to set up Kodi on a Fire Stick so I could access the files on that and OSMC as and when I want to.

However, all of a sudden - literally one second to the next - I lost connection with OSMC. I now can’t get the Raspberry Pi to boot into OSMC, and I can’t SSH in through my PC either. I’ve tried all the basic stuff, like turning the Pi on and off, checking the HDMI cable, taking out and putting back in the SD card etc., but nothing seems to be working.

I have a solid red light and a blinking yellow light on the Pi, and the SD card still reads when I plug it into my PC.

Any help would be very much appreciated!

Try another power supply. Is your hard-drive self powered?

A different power supply didn’t work. The hard-drive is powered through the Pi, but I’ve tried unplugging it and restarting the Pi with no luck. It’s been working fine for well over a year before this.

Edit: I do have another Pi 3B I could try. Would shoving the SD card straight into that work?
Edit 2: Tried in my other Pi, the exact same problem. On both, the green light is blinking three times, then one long light.

Edit 3: A clean install of OSMC on a second SD card works, although I don’t know how to get my settings off my other SD/fix that one to work?

A bit of a stab in the dark but you could plug the working SD into a PC and make a copy of everything on the boot partition and then plug the non working SD into your PC and copy those files over to that SD replacing what is there.

I had a SD stop booting a while back and I managed to figure out that the config.txt had gone MIA out of the blue. I don’t know why it did that but the SD card tested fine and once I copied over a new config.txt it booted right up and has been working flawless since.


That worked! Thanks a bunch!

1 Like

Did you test with h2testw

Of course. This was on my main machine I mess with a lot (testing for figuring out issues here etc.) so it was a bit difficult to say I did X and then it got borked, and I have not had a repeat, so I kept it to myself. I’m still running on that SD mainly to see if it was going to crap out but i’ve been stable and that happened on March 23.