Sudo alsactl store just hangs

#1

I would like for the settings to remain when rebooting, but when I try sudo alsactl store it just hangs, ie the command prompt?

#2

Correct. There’s a bug in the ALSA driver.

#3

The ALSA driver doesn’t implement enough functionality to support this well.
As a result, we also mask the alsa restore service if the alsa-utils package is installed to prevent issues on bootup

#4

OK. So, what are the options. Ie how can I set the alsamixer levels manually so they survive a reboot?

#5

What adjustments are you making?
Have you checked that they make an effect

If it’s for a USB DAC etc, it’s probably possible to restore just one card (i.e. not the built in)

Sam

#6

If you can control it from the command line, you can use rc.local to set them at each boot.

#7

I am just increasing the volume. Yes it is for an USB sound card. For some reason does it default to -20dB:

lqqqqqqqqqqqqqqqqqqqqqqqqqqqqqq AlsaMixer v1.1.3 qqqqqqqqqqqqqqqqqqqqqqqqqqqqqqk
x Card: USB Sound Device                               F1:  Help               x
x Chip: USB Mixer                                      F2:  System information x
x View: F3:[Playback] F4: Capture  F5: All             F6:  Select sound card  x
x Item: Speaker [dB gain: -20.06, -20.06]              Esc: Exit               x
x                                                                              x
x     lqqk     lqqk     lqqk     lqqk     lqqk              lqqk     lqqk      x
x     x  x     x  x     x  x     x  x     x  x              x  x     x  x      x
x     x  x     x  x     x  x     x  x     x  x              x  x     x  x      x
x     x  x     x  x     x  x     x  x     x  x              x  x     x  x      x
x     x  x     x  x     x  x     x  x     x  x              x  x     x  x      x
x     x  x     x  x     x  x     x  x     x  x              xaax     xaax      x
x     x  x     x  x     x  x     x  x     x  x              xaax     xaax      x
x     x  x     x  x     x  x     x  x     x  x              xaax     xaax      x
x     xaax     xaax     xaax     xaax     xaax              xaax     xaax      x
x     xaax     xaax     xaax     xaax     xaax              xaax     xaax      x
x     xaax     xaax     xaax     xaax     xaax              xaax     xaax      x
x     tqqu     tqqu     tqqu     tqqu     tqqu     Mic      tqqu     tqqu      x
x     xOOx     xOOx     xOOx     xOOx     xOOx              xMMx     xMMx      x
x     mqqj     mqqj     mqqj     mqqj     mqqj              mqqj     mqqj      x
x    29<>29   29<>29     29       29     29<>29            64<>64   64<>64     x
x  <Speaker >Speaker  Speaker  Speaker  Speaker  PCM Capt   Line     Mic       x
x    Front     Rear    Center   Woofer    Side                                 x
mqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqj
#8

Even if you do alsactl store, we won’t load those changes on boot.
Instead you should use amixer in rc.local.

Something like:

amixer set ‘USB Mixer’ 100%+

#9

OK.amixer -c 1 sset 'Speaker' 0dB it is. Let me put that in rc.local

#10

IIRC there’s a setting somewhere in the labyrinth of alsa config files that sets this boot-up value. The idea is to not blow people’s ears out when you turn the device on.

II didn’t RC, it must be in the driver code somewhere.

#11

Understood. I put it in /etc/rc.local

1 Like