Sudo apt-get dist-upgrade error

Hi all,

I’ve been using OSMC for a couple of weeks now and I’m really impressed with it. But I recently tried to update using apt-get and have hit a snag.

When I run

sudo apt-get dist-upgrade

It tells me there are2 upgrades
Z-image- will be installed
Z-kernel-osmc will be upgraded

but it then returns these error and reverts back

There is a symbolic link /lib/modules/4.3.3-2-osmc/buildver, I cannot read it: no such file or directory therefore, I am deleting /lib/modules/4.3.3-2-osmc/source


The package shipped with a symbolic link /lib/modules/4.3.3-2-osmc/source ver, I can not read the target: No such file ot directory therefore, I am deleting /lib/modules/4.3.3-2-osmc/source

Can anyone help ?


I also have a problem where I can’t see there entire screen when using the command prompt. The 1st few lines and characters are missing off the display, so I have had to guess at the beginning of the output above.

Sorry for muppetry, forgot to state I’m running version 2015.12-1

This indicates you are on the latest release and the symbolic link error you get is nothing to worry about. If you want as to check it out provide logs via grab-logs -A and posting the URL.

Sounds like an overscan issue of your TV. Check the settings on your TV.

Sorted. Thanks for swift response.

The two things you posted above are not errors, and a search would have revealed this.

If your system is not running fine, please post the full log.

We also recommend you update via the GUI in future

I am curious, why? I thought the approaches did the same thing? I run a couple of headless Pi, so it would be problematic if update by GUI became necessary.

You’re OK to upgrade with dist-upgrade. The only reason I recommend to update with the GUI is some users don’t run dist-upgrade and we don’t restart Kodi automatically if it is upgraded via the command line