Sync and video questions

I just got a Vero4k and I have a few questions.

My audio is out of sync and I have to change audio to ahead 100 ms every time I start a video. Is there a global setting, like on my bluray player so that I don’t have to change this on every movie?

I have resolution set to 2160p, but I often get a black screen when the Vero4k is connected to my LG TV directly. Connecting it to my receiver solves the problem. If I change frame rate to 30 Hz and turn on Force 422 color sub sampling it works with it connected to the TV. Is there any drawbacks of enabling Force 422 color sub sampling. Any loss of quality? Also, setting the menu to 1080p solves the problem, but then the Vero4k doesn’t upscale the videos to 4k.

Playing 2160p H.264 videos encoded in 60 fps result in the video lagging behind the audio. Looks like it can’t handle the high framerate. Is there support for 60 fps 2160p H.264 videos? My TV supports 2160p 60 fps H.265 video, but not H.264. My bluray-player supports both though.

60 fps 1080p video works but plays at 30 fps if the menu is set to 2160p 60hz. Setting the menu to 1080p 60hz plays the videos at 60 fps.

My settings are:

sync playback to display: off
adjust display refresh rate: always

The suggestion is to run the GUI at 1080p

Since the original video is probably 420 - no.

Usually, your TV will make a better job of upscaling than Vero.

We’ll look into that. Have you upgraded to the latest release (with Kodi v18)?

Yes – you can select ‘Set as default for all videos’.

Sam

Yes, I upgraded to Kodi v18 and it’s still the same.

Providing logs will give us the ability to see how you are configured and if there are any issues there.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

I tested a 1080p 60 fps clip again, and now it worked with the menu at 2160p. I might have been wrong when I said I tested with the new version.

I will upload the logs when playing a h.264 2160p clip at 60 fps. h.265 2160p at 60 fps plays fine but h.264 clips are very slow.

I followed this guide to mount a NFS share, but I noticed that when my NAS is turned off the vero4k hangs when accessing movies. Sometimes my NAS is turned off and I want to be able to watch videos from a USB. Is this possible?

Please keep the support discussion here in the forum rather than sending PM’s to mods directly.

I’m just not sure that I want to share my logs with everyone since I read that it can contain passwords and other personal information. That is why I sent the logs directly to a mod.

Can you try playing that 2160p h264 clip after setting 8-bit output:

echo 8bitnow | sudo tee /sys/class/amhdmitx/amhdmitx0/attr

I’ll try 8-bit output, but how do I go back to the default value after I have tried that?

echo now | sudo tee /sys/class/amhdmitx/amhdmitx0/attr

Or reboot

I tried 8-bit output, but it did not make a difference. Do you want me to send you the clip? It’s only 70 MB.

good idea, thanks

Here is the clip

Did you find out why the clip doesn’t play in normal speed?

No, sorry. h264 at 4k60fps just doesn’t work very well generally.