System freezes while playing video on Kodi

I always accept update of my OSMC and never had an issues. But last week I had a problem with Kodi v.15.2. Since I installed V.15.2 Kodi was playing everything I throw in without a hitch. But last few days it started acting on me by freezing video at least once during an hour program. I mostly watch videos from my NAS or desktop accessed via NFS or SMB. When it happens I cannot do anything but to unplug the power cord and restart my Pi. I did not install any new plugins. The only thing I did was to disable hardware acceleration because some videos would not play video only audio so this fixed that issue so I can play these file now.

I would be very thankful if someone can look at my log and help me find out what is the issue here.

Thanks in advance!


Use the myosmc addon for uploading logs instead

or in ssh grab-logs -a

To get a better understanding of the problem you are experiencing we need more information from you. Please see How to submit a useful support request - General - OSMC for advice on how to help us.

Sorry for not following the rules.

Here is my log

Thanks for replying promptly

hmm thats not all of the logs running it overclocked by any chance ?

I might. I really don’t remember. The log I posted i got using grab-logs -a. That is all I got

sry my mistake it supposed to be -A capital kinda hungover today :slightly_smiling:

so grap-logs -A

it might take a while

You should be sleeping and resting not helping clueless noobs, :wink:

Here it is

hehe yepp but i need to stay awake cause im going to deadpool in an hour or two so i need to kill some time before that

think this is related to overclocking and corruption of the filesystem had a similar issue the yesterday with a guy that had no ethernet so turn off or atleast set it to modest overclocking and run a fsck on the filesystem.

I am afraid I do not understand fully. I downloaded fstab and it has only this in it:

/dev/mmcblk0p1 /boot vfat defaults,noatime 0 0 /dev/mmcblk0p2 / ext4 defaults,noatime 0 0

So I don’t know where to put 1?

Or should I just disable overclocking? Mind you I had a system set as such for 4-5 months and never had an issue till last few days.

corruption doesnt happen overnight it takes a while like you said 4.5 months of wear and tear

last digit to 1 on both lines then the rest that the post suggest you should do

Ok. So what I have now in my fstab is:
/dev/mmcblk0p1 /boot vfat defaults,noatime 0 1 /dev/mmcblk0p2 / ext4 defaults,noatime 0 1

and my comdline.txt:
root=/dev/mmcblk0p2 rootfstype=ext4 rootwait quiet osmcdev=rbp2 forcefsck
Should I also disable overclocking before I restart OSMC?

yes please

I am trying to ftp comdline.txt to my pi via Filezilla ftp program but it won’t overwrite original. What should I do?

Never mind I did with sudo nano edited both files. Restarted and see what happens?