"System information" wrong locale or codepage after changing system language

#1

After I changing system language from English to Russian I have this mess in “System information”


I remember, that I fixed that on my other device something about 1-1,5 years ago, but I can’t remember how. Can someone help me pls?

#2

Change your font (Settings > Interface > Font) from Default to Arial should fix that.

#3

Thnx for fast answer.
This helped a little )


Why all other titles looks normal and only here I have this problems?
And btw on my old system everything works fine with default font. Maybe there is something more I can do?

#4

We changed some things about our skin font and I only noticed these issues with Cyrillic glyphs now… Will have a look into how this can be fixed. :+1:t2:

#5

Hm… is there ant way that I missed some localisation files? On my old system I have a lot folders with localization files like:

/home/osmc/.kodi/addons/resource.language.ms_my
/home/osmc/.kodi/addons/resource.language.os_os
/home/osmc/.kodi/addons/resource.language.pl_pl

/home/osmc/.kodi/addons/resource.language.pt_pt
/home/osmc/.kodi/addons/resource.language.ro_ro
/home/osmc/.kodi/addons/resource.language.ru_ru
/home/osmc/.kodi/addons/resource.language.si_lk
/home/osmc/.kodi/addons/resource.language.sk_sk
… and so on.

and on new system there isn’t anything like this.

#6

Well, I’m happy that this is not my driver hands.sys ))

#7

Hi

Hopefully the issue is now addressed with the following commit: Update font files · osmc/skin.osmc@1eef9c5

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. It will take about an hour to be available in our staging repo. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

#8

Yeah, now it looks fine.


Just one little question - is it OK that not everything translated from English? I mean menu items like “Interface” and so on

#9

Unfortunately, yes. Those items either don’t have a translation by Kodi or by us. We add localizes to the skin that Kodi doesn’t have, but currently we only offer English versions of the localizes for a lack of a good translation solution.

I’ll fix the Interface subsection of settings though for the next update. There’s a translated localizes by Kodi that I can use… :+1:t2:

#10

Thank you for your work and very fast answers. )