System locks up/ boot issues


A few issues which may or may not be connected :slight_smile:
I had an issue with insufficient power being delivered to 6x portable HDDS in a powered dock so purchase another so each conncted to one of the usb ports on 4k+ and each powering 3x HDDs.

Recently, when trying to boot, it will get to the ‘please wait’ screen, I hear the drives spin/up down, and then the wait screen reloads. This continues until I shot down the hubs and then it boots into osmc. I have checked all drives and they are clean.

Additionally, randomly when watching content, it will stutter then stop and freeze the system neccessiatting a hard reboot. I grabbed logs from when this happened yesteday at about 7.15pm (freeze) and then shortly after the reboot issue.

Any advice would be welcomed.


If you connect these drives to a PC using the same hardware configuration do they still have issues with the spinning up/down?

I can try but they do power up and function most of the time, it’s just apparent at boot on vero4k+

Unfortunately if it’s during the initial boot – the logs won’t show what’s going on.
Finding out what’s going on would only be possible with UART access – which is a bit tricky.

Can you check if the issue occurs with a reboot (via OSMC or command line) and with a shutdown? If it only occurs in one of these situations it would be interesting.

Hi Sam,

Just tried this and while there was a prolonged pause on the ‘please wait’ screen for a minute or so (disk check?) it did boot successfully.

How many drives are attached? It might just be the bootloader spinning up each drive and looking for installation media on each one.


6 HDDs - 3x each on 2 powered hubs - see OP

I suspect the bootloader is enumerating each drive and trying to boot OSMC installer from it. This could cause some delays with so many drives attached.

You could run this command via SSH:

sudo fw_setenv osmcfromusb "true"

Keep in mind that you will not be able to reinstall OSMC from a USB stick again (SD will still work); unless you use a non-conductive pin on the recovery switch inside the box.


1 Like

Thanks. Have run and will report back if occurs again

This seems to have fixed it. Any ideas why it was doing?

It’s looking on each drive for installation media. This could take a while if you have a lot of drives attached.