System wipe issues

The network setup was not working properly, and the menu hang for a very long time every time I changed device, and when I got to wifi, it couldn’t scan for networks, so I wanted to wipe the system and start over.

After using the toothpick method for booting into adb and performed a factory reset, because it wouldn’t detect the official SD-card formatted with the newest 2017.03-build when named kernel.img, I now get a FATAL ERROR: Could not find root filesystem device /dev/vero-nand/root, so I try to boot up the installer from sdcard. It wouldn’t work. I got multiple failed to mount /dev/block/mmcblk0 on /sdcard by read-only (Device or resource busy) and once in a while failed to mount /sdcard (No such file or directory). So I tried from a formatted USB-drive, since the SD-card slot is not an option. Furthermore you can’t insert a card straight. I think the slot might be defective. Also, card fall out when you have pushed in the eject mechanism and they slide back to entrance position.

This worked out. Finally I got to the install screen, but now it says Install failed: could not mount bootfs. So I’m pretty much stuck after hours of different tricks and feel the urge to return this crappy device to the United States instead go for a much cheaper Raspberry-setup.

PS: Why didn’t you think about a power off-button on the remote? Seems quite non-convenient to me, when it seems to booting-capability is fragile after an erroneous shutdown.


I’m sorry to hear you’re having a problem with your Vero 4K. If you look around, you’ll find that this isn’t a typical experience. I’d be happy to look at this and help you get up and running again.

The toothpick method is not intended for booting in to the Android based recovery system; and you are not expected to mount the SD card there. Instead, the toothpick should force a search on MSD and load the installer. But if the SD card wasn’t in properly, it wouldn’t be reading the installer, so it would fall back to the recovery on the device. I suspect you expected this was normal, and then got a bit confused as to why things weren’t working.

Did you see this: Reinstalling OSMC - Vero 4K - OSMC

The Vero 4K would have been imaged using an SD card before we shipped it out, which means the slot would have been tested and should be working, particularly if Android was able to detect the SD card. Newer versions are imaged using a PXE-like based system; but we haven’t started shipping these units yet.

The ‘could not mount bootfs’ message appears because reinstalling and booting OSMC from a USB stick is not supported at this time. We have added support for USB based booting to the bootloader; but the installer cannot yet take advantage of this. I’ll add a more friendly warning about this in the next update; and add support for USB installation shortly after that.

You can safely shut down the device by going to Power → Shut Down. This can be done from the remote or any other device which can be used to control OSMC.

My suggestions are:

  • Insert the SD card in your computer; and make sure kernel.img and the tarball are present. Also copy the kernel.img, and rename the copy to recovery.img.
  • Try seating the SD card with the Vero 4K stood on one side. You should see the SD cards, rather than the card’s brand. This photo is blurry, but I hope it helps:
  • Push the SD card in until it clicks in
  • Boot holding in the non-conductive pin or toothpick for 5 seconds.

I’m confident we can get you up and running quickly, and if anything’s wrong with the hardware (faulty SD slot), we’ll take care of it.


As you remarked that USB booting is working for you, I’ll compile a version of the installer that works from USB for you.


I have tried all of your suggestions, unfortunately.

Here’s a picture of my SD-card slot when the card is inserted after the click. The SD-card logo and capacity amount is upwards, just like the brand logo on the top of the box. You can push it in sideways so it is slightly off, and then it won’t click. When I turn it around and push it in, so that the bottom side is upwards, it gets stuck and I must use tweezers or a tiny, flat screwdriver to force it out. To make it not fall out, you have to have it non-straight.

As said earlier, do not try and install packages via the Android based recovery system. It won’t access the SD card properly and it’s not the correct way to reinstall OSMC.

From your photo, it looks like you’re putting in the SD card the wrong way.

I have done the same accidentally sometimes and the result is the same: the SD card is at an angle and doesn’t click in properly.

The contacts of the SD card should be facing upwards. When the (M) on the device is visible, the metal contacts should be visible, but in your photo it looks like the logo of the SD card is visible, which means it’s upside down. The logo of the SD card should be pointing towards the floor.

Like this:



Here is an image that will allow you to install OSMC from USB. You can either manually dd this to a USB stick, or using the official OSMC installer, select ‘use local image’ and navigate to the file.

If you have a faulty SD card slot, we would be happy to look at the unit and replace it. But this should hopefully get you up and running and let you watch some TV over the weekend. I think the issue is that you were putting in the SD card upside down however.



Sorry for the late reply, have been busy working last week. I managed to reinstall by SD-card by turning it the right way, as you specified. It was a little difficult to get the eject-function working. Maybe it’s because the port is a little skewed inside, but at least I know how now. Maybe you should note it on the FAQ page for future problems, which way the card has to face, because many people will undoubtedly confuse it, since the presumed standard way is logo up.

That also explains why my USB-keys face the opposite direction in the Vero, than the computer. The whole board is simply upside down. You notice it when you look at the ports for HDMI and ethernet.

I was even able to run a system update scan now, after a flawless wifi discovery (which was the original fault that led to all this)! The network settings seem to be working now. I initially ran into a problem because I plugged in a USB-keyboard/mouse device, which seems to screw up during the introduction screen.

Anyway thanks for the USB image - that might come in handy for other troubled users, who don’t “get it”, like me, or who seem to have an even more faulty port than me. I will keep the device for now and don’t feel like returning it for such a small issue. Thanks a lot for your time and patience. You are really keen on analyzing a situation! Kudos for that.

I am glad this is now working for you