Systemd, jackett, and errors (oh my!)

In the latest episode of “Guy doesn’t know anything about linux”…

I’m trying to install jackett (for use with Sonarr). I have it up and running when I run the manual launch command:

mono /opt/jackett/JackettConsole.exe

No problem getting to the web server. However, my systemd script seems to be failing to initialize. If I run:

sudo service jackett status -l

The following is displayed:

* jackett.service - Jackett Daemon
   Loaded: loaded (/etc/systemd/system/jackett.service; enabled)
   Active: activating (auto-restart) (Result: exit-code) since Sat 2017-08-26 18:43:13 PDT; 4s ago
  Process: 18876 ExecStart=/usr/bin/mono /opt/jackett/JackettConsole.exe (code=exited, status=2)
 Main PID: 18876 (code=exited, status=2)

Aug 26 18:43:13 osmc systemd[1]: Unit jackett.service entered failed state.

Here is the content of my jackett.service file:

Description=Jackett Daemon

ExecStart=/usr/bin/mono /opt/jackett/JackettConsole.exe


I’ve also tried it with the ExecStart to be:

ExecStart=/usr/local/bin/mono --debug /opt/jackett/JackettConsole.exe

but I get exactly the same results. Any thoughts on what I’m doing wrong?

That’s probably the problem, since linux does not use .exe for executables :wink:

You probably will get more help if you contact the Jackett developer.

They use .exe for whatever reason (I also thought it odd).

Since the executable itself is fine when I run it through the mono command I figured their system is working as intended and thought it was more of a problem with how systemd is working. But I don’t know much of anything about Linux, so its all greek to me. :slight_smile:

Like I said, take it up with the jackett developer. (Just a hint however, I suspect that the error snippet had a little more info, like to run journaltcl to see more information about the error)

If the developer is using .exe on a file targeted for Linux, I’d be cautious…

Excellent! Thanks for telling me about Journalctl. Ran that command (then realized running it -r was a much better plan…), it said “no file or directory”. Looked back and realized that I forgot to capitalize the J in the directory. Sheesh.

Also, regarding the .exe thing. I read that you have to use mono because they are coding in .net or something like that. Maybe that’s why its a .exe by default, because that is how that framework works?

No idea, but either way its working. Thank you much for your assistance!

AH, I didn’t really notice the mono bit. Glad that you got it working!