Terratec USB TV Tuner with OSMC?

Hi guys.

So I just got myself a Raspberry Pi 2 and I’ve got everything up and running with OSMC. However, the final part is to figure out a way to display TV. I got cable TV and previously I’ve been using my Terratec H7 USB with my Windows desktop setup. However, ideally I would like to get the same Terratec H7 to run with my RPI2 as it’s going to be my media center via HDMI to my projector.

I know it’s probably a long shot, however I’d like to give it a shot. As this is my first time running this type of Linux setup, how do I identify whether OSMC has identified my Terratec box at all? In case it hasn’t I’ve found these drivers for OpenElec:

I’m not sure if there’s any way of getting them to work on OSMC though. Any suggestions on how to proceed?



dmesg | grep dvb

lsusb -v

So I just tried to check this, and unfortunately the “lsusb” command is not supported by the OSMC 2015.06 build. However, the dmesg command yields the following:

[ 5.075076] usb 1-1.4: dvb_usb_v2: found a ‘Terratec H7’ in cold state
[ 5.086858] usb 1-1.4: Direct firmware load for dvb-usb-terratec-h7-az6007.fw failed with error -2
[ 5.086925] usb 1-1.4: dvb_usb_v2: Did not find the firmware file ‘dvb-usb-terratec-h7-az6007.fw’. Please see linux/Documentation/dvb/ for more details on firmware-problems. Status -2
[ 5.086980] dvb_usb_az6007: probe of 1-1.4:1.0 failed with error -2
[ 5.087200] usbcore: registered new interface driver dvb_usb_az6007

So for this I got a Google hit Add Terratec H7 firmware file · Issue #1361 · OpenELEC/OpenELEC.tv · GitHub here that states that I have to implement the firmware file as described on the link. Is this a viable way to go?

Additionally I tried a “lsmod” command and it finds the following:

Module Size Used by
8021q 22150 0
garp 7398 1 8021q
stp 2179 1 garp
llc 5879 2 stp,garp
uinput 9625 1
dvb_usb_az6007 14848 0
cypress_firmware 1990 1 dvb_usb_az6007
dvb_usb_v2 17172 1 dvb_usb_az6007
dvb_core 106951 2 dvb_usb_v2,dvb_usb_az6007
evdev 11328 1
lirc_rpi 9355 3
lirc_dev 11364 1 lirc_rpi
rc_core 25741 3 lirc_dev,dvb_usb_v2,dvb_usb_az6007
uio_pdrv_genirq 3637 0
uio 10030 1 uio_pdrv_genirq
fuse 102057 1
ipv6 425787 32

Here the dvb_usb_az6007 seems to me to be the TV-tuner, however I’m not sure what to make of it.

Looks promising.
Download the firmware file (from a reputable source) and put it in /lib/firmware and reboot