[TESTING] Debian 11 Bullseye

Thanks! 24p VC1 tested and working again on ISOs and MKVs. :+1:

2 Likes

No - there’s no need. I’m pushing updates to both testing and release as this is still a testing build so there is no expectation of stability on the normally stable branch yet. Updates can take an hour to reach a mirror and you probably didn’t wait that long — ie tried my instructions immediately. I didn’t wait the hour to post as I was out for the evening.

New video stack should improve VC-1 further. This will come after v19.5.

Thanks for confirming.

Hi Jez

I’ll try reproduce this in a couple of days.

In the meantime, can you try write to the drive from another device such as a PC to rule out an issue?

Cheers

Sam

Thanks Sam,
Appreciated!!

Yes, same issue when trying to copy from another pc (linux pc, and macbook-intel, both tried). Obviously there’s no problem writing to drive when physically connecting to either of these pc’s.

When ssh’ing to drive, i have to sudo in order execute commands such as mkdir, and scp, which makes me think this is purely some sort of permissions issue.

Cheers,
Jez

SOrry, I meant installs compiled from source

We don’t have a mechanism for that because it’s unclear how it was compiled / whether a PPA was used etc.

I have 2 Vero 4k+ boxes running with new testing version of debian 11. Both boxes have experienced this in the last week or so.
When leaving the boxes idling for a day or so, usually while the tv is in standby, I come back to a sad face.
Box is still contacteable by ssh and a sudo reboot brings it back up. I managed to capture it with debug enabled

https://paste.osmc.tv/ahesutobow

Hope it helps
Thanks

1 Like

Quick note:
As a work around to copy files, I’m having to manually mount the drive with custom permissions (I.e. un-mount drives, and re-mount, as below)

sudo mount -o rw,users,uid=1000,dmask=007,fmask=117 /dev/sdc1 /mnt/xxxx which allows me to write to drive.

A permissions check below shows

drwxrwx---  7 osmc root 1.0M Jun  5 09:21 sc1
drwxrwx--- 11 osmc root 128K Jun  5 09:17 sd1

3D mode is no longer triggered on my tv after upgrading. Here is my log. Hopefully it’s helpful

https://paste.osmc.tv/eforanoxob

Hm, the log doesn’t show any unexpected behaviour :frowning: . Is it possible to manually switch your TV/projector into 3D mode? And if yes, is the 3D playback ok?

Weird. It works now. I turned everything off and back on and now it triggers the tv. Must have been a glitch.

Good to hear :+1:

1 Like

Just updated but see only 19.4?

NVM I just saw this:

Kodi v19.5 is not officially tagged yet. We are building top of tree Matrix.

1 Like

Thanks for the solution. @sam_nazarko I can reproduce the same issue here.

4k movies that played fine before now buffer a lot (don’t know if it’s related to the mounting issue or something else)

Here are logs: https://paste.osmc.tv/jisajuguwe

1 Like

In your case it’s a permission error:

2022-06-09 22:39:03.275 T:3890    ERROR <general>: AML: no proper permission, please contact the device vendor. Skipping codec...

that’s why the SW decoder is being used for playback. The log message

2022-06-09 22:34:03.347 T:3785    ERROR <general>: AML: no rw on /dev/amstream*

is telling me that there’re no kernel modules loaded. It seems something went wrong with the update?

There’re also some emmc related errors in the kernel log:

[  193.762681] meson-mmc: emmc: desc_timeout,vstat:0xa1ff3000,virqc:3fff
[  193.762690] meson-mmc: emmc: err: wait for irq service, bus_fsm:0x8
[  193.762695] meson-mmc: emmc: cmd 18, arg 0x31ef8, operation is in [reserved] disk!
[  193.762719] meson-mmc: meson_mmc_irq_thread 2778 emmc: cmd:18
[  193.762726] meson-mmc: meson_mmc_irq_thread() 2794: set 1st retry!
[  193.762730] meson-mmc: retry cmd 18 the 10-th time(s)
[  193.762733] meson-mmc: emmc, 10 retry, adj 4 -> 5
[  193.762794] emmc: req failed (CMD18): -110, retrying...

and Mali is playing up, too :frowning:

[ 5182.409228] Mali: ERR: drivers/osmc/gpu/mali/linux/mali_memory_os_alloc.c
[ 5182.409238]            mali_mem_os_alloc_pages() 230
                          alloc_page() return NULL! try again!

Maybe @sam_nazarko can help here?

Yeah my device’s mmc has been having some issues since long time. I’ve seen some packages that failed installing and / or configuring, I’ll try reinstalling them. If that won’t solve the problems, I’ll reinstall from scratch.

Thanks!

EDIT: ran sudo apt-get install -f which reconfigured all packages that had errors and now everything is fine and dandy! The issue with automounted exfat drives is still present though, the workaround will do for now.

Cheers!

We can deal with it in comms.

@sam_nazarko Hi, any update regarding exfat drives not being writable on automount (with these drives showing with “root” uid/gid, as opposed to ntfs drives with “osmc” uid,gid).

drwxr-xr-x 11 root root 128K Jun 19 03:17  Expansion
drwxr-xr-x  7 root root 1.0M Jun 19 03:17  Five
drwxrwxrwx  1 osmc osmc 4.0K Dec  2  2021  Maxtor
drwxrwxrwx  1 osmc osmc 4.0K Dec  2  2021 'My Passport'
drwxrwxrwx  1 osmc osmc 4.0K Dec  2  2021 'Seagate 2T' 

As per above, the 1st 2 drives are ex-FAT, and i’m currently having to remount in order to make writable.
Is there any config i can change so that on boot-up these drives are writable?
Thanks in advance,