[TESTING] Debian 11 Bullseye

Haven’t had a chance to look at this yet. You can use an fstab mount to override this for now.

1 Like

I have no idea if this is specific to the Bullseye test build or not, but I’m not getting any audio output on some YouTube videos.

Here’s an example: “Spot Me Up” | The Rolling Stones & Boston Dynamics - YouTube

Logs: https://paste.osmc.tv/urucigohot

This could be the 4k+44.1k bug that came with the 4.9 kernel. Can you check if it works at 720p and/or with forcing audio to Fixed 48ks/s.

I’m still on OSMC March 2022 2022.03-1 and the audio plays fine however the video doesn’t play at all (2160p24). I downloaded the “Spot Me Up” video using youtube-dl. Media info below.

. I have had the same problem with other 2160p24 (4K)) mkvs, using the AV1 codec.

The March version isn’t Bullseye based.

AV-1 isn’t supported on OSMC at this time.
It will need a hardware refresh to play this codec reliably on ARM hardware.

Thanks for that.

Is there a plan for a hardware ‘refresh’ , i.e. the next gen Vero ?

Not for now.

Hi all,

Just did a quick test with this and unfortunately the issue is still a thing (almost a year now :frowning: )…

@sam_nazarko , in that thread you mentioned something about making arm64 builds available. Any plan for that?

Also to mention that I did a fresh install of the disk image and ran apt full-upgrade after flashing it…

I tried changing the output resolution from 2160p/23.98 to 2160p/59.94, and that makes it produce sound. So that may well be the problem.

Could be related, but in my testing the video framerate was irrelevant. The key parameter was the audio samplerate. But can’t remember whether I tried video framerate conversion.

Changing audio “Output configuration” to “Fixed” also gives me audio output, as does playing the 720p stream rather than the 2160p one, so it’s probably that.

1 Like

New video stack should solve that.
We can look at ARM64 builds next year. No support for Widevine however.



I’ve been having an intermittant issue with the latest debian build where autoplayed content occasionally results in a crash. When the crash happens, the media stops playing, the screen goes black, then I get the usual blue unhappy face screen, except only the top ~30px are visible. Kodi then automatically restarts, yet only the top ~30px or so are visible. From there, only a reboot solves the display problem.

It happens with a variety of content at different resolutions, only when played via an autoplaying up next addon (up next by im85288), and only occurs ~10% of the time.

I’ve a theory that it is perhaps due to some form of race condition with resolution or mode changing that occurs at playback start and stop, which also seems to occur when changing content.

Logs are here: removed

If the logs aren’t reflecting the kodi crash, I’ll grab the logs again on next crash.

For some reason, I have the feeling this is something related with ffmpeg for 32bit ARM. Is something happening related to that in the new stack? More importantly, is there any idea when the new stack will available (for testing at least) :slight_smile: ?

Hopefully the new stack solves it because this is still a long time to wait (and to be on the last leia release; is already starting to become painful with some addons). the only reason I’m talking about 64bit mode is because of the feeling I stated above (but it might solve nothing).

Why do you think that?
The stack has been available for testing for some time.

Just from some stuff I digged online (like kodi github) and from the fact it works on x86 and on the firestick (even though I’m not sure the stick is running in 64bit mode). Anyways, It might have nothing to do with it…

Can you point me to an image I can used which has it? I’m surely interested in checking if it solves the issue…

I see this testing thread which is closed. Is this the video stack you are referring too? AFAIU, it’s already part of the latest release (which I tested and is still not working). Am I missing something?

No – I’ve sent you the details.

Thanks… I will give it a try

I’m interested…