Vero 4K won't read USB HD drive

I’ve been using a USB hub since you helped me resolve the hard drive issue 2 months ago, but now it doesn’t recognize the hard drive even when using the hub. Or are you saying that the Vero is broken and is no longer able to be used to read from a USB drive?
If so, was that because I used it without the hub for so long?

Both Vero USB ports work: One sees the remote dongle attached and on the other there is a ‘GenesysLogic’ USB hub attached with 4 ports … but no sign of life of any other device connected to this hub.

Apr 15 15:37:38 osmc kernel: usb 1-2: new high-speed USB device number 3 using xhci-hcd
Apr 15 15:37:38 osmc kernel: usb 1-2: New USB device found, idVendor=05e3, idProduct=0610
Apr 15 15:37:38 osmc kernel: usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Apr 15 15:37:38 osmc kernel: usb 1-2: Product: USB2.0 Hub
Apr 15 15:37:38 osmc kernel: usb 1-2: Manufacturer: GenesysLogic
Apr 15 15:37:38 osmc kernel: hub 1-2:1.0: USB hub found
Apr 15 15:37:38 osmc kernel: hub 1-2:1.0: 4 ports detected 

Just some ideas:

  • Does the missing (Western Digital as seen in the first logs) hdd work on another device like a PC?
  • Is the hub’s power supply correctly inserted into a wall socket?
  • What happens, if you disconnect the powered hub with attached hdd from the Vero’s usb port and reconnect it, again?

Hi Jim,
Yes, the hdd works on my desktop pc and with another media player (without the hub).
The hub’s power supply is correctly inserted into a surge protector and it powers up the hdd.
Nothing happens if I disconnect the hub with attached hdd from either of the Vero’s usb ports and reconnect.
I tried using another working WD portable hdd but get the same result.

From the logs both USB ports of the Vero work. From the logic the USB hub seems to be the issue. Is there a chance that you try another powered USB hub just for tests to isolate the issue?

Maybe try on the PC with the hub to check if it’s the hub that’s the problem. Have you tried all the ports on the hub?

Tried with a different hub and it’s working again so it looks like you’re right, the problem was the usb hub.
Thanks for your help!

1 Like

I suspect the PSU for that hub. The one I have seems a bit … weak.

1 Like

This problem appeared to be resolved when I switched USB hubs but all of a sudden the Vero 4K won’t read files from the portable HDD again. I tried the drive on my pc and with an old media player and it works fine on both.
Log: https://paste.osmc.tv/oxonahokah
Sometimes it will mount the drive and display the folders on it but when selecting a file within one of the folders it goes into a loop showing the OSMC logo over and over and not starting the video.
Any suggestions?

That doesn’t look good, a lot of this kind of errors

Jun 17 21:41:47 osmc kernel: sd 0:0:0:0: [sda] tag#0 ASC=0x11 ASCQ=0x0 
Jun 17 21:41:47 osmc kernel: sd 0:0:0:0: [sda] tag#0 CDB: opcode=0x28 28 00 00 60 0c 30 00 00 18 00
Jun 17 21:41:47 osmc kernel: blk_update_request: critical medium error, dev sda, sector 6294576

ASC=11 means unrecovered read error.

Could you ssh login to the vero with the hdd connected (and mounted), do

sudo apt update
sudo apt install smartmontools
sudo smartctl -x /dev/sda

and provide the output of the last command or use sudo smartctl -x /dev/sda | paste-log and mention the returned url here?

Thanks for the reply Jim. Unfortunately your suggestions are beyond my knowledge level. I guess I’ll just have to assume that the Vero 4k has reached the end of it’s useful life.

Well I fear it’s the hdd which has reached the end if its life cycle. I appended a link which should help to reach the command line of the osmc device.
So the idea is to install putty on a windows pc and log in with the user osmc, password osmc. Once you’re logged in, you can just proceed step-by-step with the commands I’ve suggested.

I understand if this is all beyond what you can/want to handle. In that case, look for a tool from WD that can fully scan/verify the My Passport Ultra hdd.


For details regarding how to access the command line interface, see our Wiki: Accessing the command line - General - OSMC

OK, so I installed WD Drive Utilities and ran the diagnostics with the following results:
Drive Status Check - passed
Quick Drive Test - passed
Complete Drive Test - passed

I also installed putty on my windows pc but when I attach the hdd to the Vero 4K it doesn’t even mount it. (I can feel the hdd spinning.) So I haven’t been able to run the commands you suggested.

Please note that I’ve tried a couple of other working portable drives with the Vero and get the same result. Either they can’t read the files or the drive doesn’t mount at all. All of the drives in question work fine connected to my pc or to a cheap Chinese media player.

If I had to fathom a guess (from your post history), I’d say that the Vero’s power supply has probably degraded from powering hard drives directly over time and the hub cannot handle powering both the drive and the load of Vero at the same time.

Hi Sam,
I was thinking the same thing actually. Probably the same thing that happened to a couple of friends of mine who were also connecting portable drives directly to WDTV players.
So if I purchase a new Vero 4K+ I’m assuming that I should also use the hub to connect my portable drives to it?

Yes – that’s not changed.

Sam

Thanks Sam.

I just placed an order for a 4K+.

Perhaps it would be a good idea to add a precaution about using a powered hub for USB drives in the Set-up Guide.

I don’t think you need to upgrade your hardware – although you may wish to update to a Vero 4K +

You probably just need a new power supply for your Vero 4K.

Don’t want to mislead / make you buy something you don’t need.

I won’t send anything until you confirm.

I just bought a new power supply (OSMC) back in December when I first started having these problems. If you think that will solve the issue please cancel and refund my order and I’ll try another new power supply.

I was under the impression that the 5 year support for the 4K+ will end soon so would prefer to wait until you release a new player if I can get around the problem with just a new power supply for now.

If you bought a new PSU and this didn’t solve the issue, then I don’t think this will resolve your issue.

No new Vero any time soon.

OK, please process my order then. Thank You.