Vero 4K won't read USB HD drive

My Vero 4k was slowing down for a couple of days (please wait… for many seconds when selecting a video device or file) and now won’t even recognize the attached device (WD portable drive). I tried using a USB hub to connect the drive to the Vero but same result. Tried a different drive but again same result. Both work fine attached to my desktop.
Has my Vero reached the end of its useful life or is there any further troubleshooting I can try?
Here’s a log captured when attaching the HD:

Is the hub a powered hub? There are lots of read errors when you connect the drive.

I see that it’s formatted NTFS, maybe it would help to connect it to a windows system and run a chkdsk on it.

The hub is an OSMC powered hub. Ran chkdsk on the drive - no problems found. I also tried it on an old Nexbox player that I was using prior to purchasing the Vero 4K and it works fine. So it appears that the problem isn’t with the drive.

Can you try the other USB port on the Vero?

What else is connected?

I have the USB bt dongle in the other port. Tried switching ports but no luck.

Do you have another drive you can check with?

I tried another (newer) drive. It comes on but just makes a clicking noise and doesn’t show up on the Vero 4K. That drive also works fine on my old media player.

This suggests a power issue. Power supplies can downgrade over time. It could be that the power supply for your Vero isn’t sufficient anymore and needs replacing.

I just replaced the power supply about a month ago (OSMC). I’ve also tried using an OSMC hub, but that didn’t help.

I’m not sure then. Maybe the drive consumes a high amount of power.

Can you try power it with a different USB hub to rule out an issue?


Tried my other hub and the Vero is now able to read the drive. I don’t think I connected the other hub properly when I first tried it as it’s working with that hub now too.
I’ve been using both drives with the Vero for months now and they also work without using a powered hub on a cheap Chinese player so I don’t think it’s a case of the drive consuming a high amount of power but rather the Vero suddenly not providing enough power to the drive. Would you agree?

The Vero isn’t designed to power hard drives without a powered hub.

Thanks for your help as always Sam. I didn’t know that the Vero wasn’t designed to power HD’s without a powered hub. I’ll continue to use it with one from now on. I’ve been using it without one for over 4 years now so I guess I was living on borrowed time.

You can sometimes get away with it — but I wouldn’t do it for any files you don’t want to lose.


I was able to solve this issue by using an OSMC powered hub to connect my portable drive to the Vero 4k. It was working fine for a couple of months but suddenly the Vero 4k no longer recognizes the hard drive. As before I tried a different USB hub (also OSMC), a different hard drive, and switched USB ports on the Vero with no success.
Here’s a log -
Any suggestions?

You need to use a USB hub when you attach any drive for reliable behaviour.

OSMC updates can use more power with each update as we improve performance.


I’ve been using a USB hub since you helped me resolve the hard drive issue 2 months ago, but now it doesn’t recognize the hard drive even when using the hub. Or are you saying that the Vero is broken and is no longer able to be used to read from a USB drive?
If so, was that because I used it without the hub for so long?

Both Vero USB ports work: One sees the remote dongle attached and on the other there is a ‘GenesysLogic’ USB hub attached with 4 ports … but no sign of life of any other device connected to this hub.

Apr 15 15:37:38 osmc kernel: usb 1-2: new high-speed USB device number 3 using xhci-hcd
Apr 15 15:37:38 osmc kernel: usb 1-2: New USB device found, idVendor=05e3, idProduct=0610
Apr 15 15:37:38 osmc kernel: usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Apr 15 15:37:38 osmc kernel: usb 1-2: Product: USB2.0 Hub
Apr 15 15:37:38 osmc kernel: usb 1-2: Manufacturer: GenesysLogic
Apr 15 15:37:38 osmc kernel: hub 1-2:1.0: USB hub found
Apr 15 15:37:38 osmc kernel: hub 1-2:1.0: 4 ports detected 

Just some ideas:

  • Does the missing (Western Digital as seen in the first logs) hdd work on another device like a PC?
  • Is the hub’s power supply correctly inserted into a wall socket?
  • What happens, if you disconnect the powered hub with attached hdd from the Vero’s usb port and reconnect it, again?

Hi Jim,
Yes, the hdd works on my desktop pc and with another media player (without the hub).
The hub’s power supply is correctly inserted into a surge protector and it powers up the hdd.
Nothing happens if I disconnect the hub with attached hdd from either of the Vero’s usb ports and reconnect.
I tried using another working WD portable hdd but get the same result.

From the logs both USB ports of the Vero work. From the logic the USB hub seems to be the issue. Is there a chance that you try another powered USB hub just for tests to isolate the issue?