Vero 4k iptv issues after August update


I’m having a lot of trouble with the pvr iptv client . I’m experiencing audio out of sync with video and the are also channels taking significant time to load and to change between them. Also to mention that if I enable the new timeshift/catchup feature than it becomes completely broken (streams completely black or constantly buffering). I think this might also be related with some other threads I saw about issues with deinterlacing issues.

I already tried to move .kodi to a backup directory to start fresh with no luck. I was about to do a fresh installation when I stumbled against some threads that can be related to my issues so I’m holding it for now. On top of this, I have some h265 channels that I realized that they work just fine. This makes me wonder that this can be a more subtle issue related with h264 interlaced streams that a fresh install might not really fix. Hopefully this is not some regression on the kernel drivers.

Also to note that I’m only having issues with live tv playback…

This is very unfortunate as the rest of the update actually went fairly smooth and I was really looking forward for this update to get the timeshift/catchup feature…

Here are some logs:

Note that I removed a lot of stuff from the pvr addon (Loading channels) otherwise I could not even upload the whole log. Hopefully I did not removed anything important…


  • Nuno Sá
2021-09-05 00:29:20.564 T:3067    DEBUG <general>: CAMLCodec::SetSpeed, speed(1000)
2021-09-05 00:29:20.565 T:3064    DEBUG <general>: CVideoPlayer::CheckContinuity - resync forward :1, prev:18442241078923337728.000000, curr:36884481552954867712.000000, diff:18442240474031403008.000000
2021-09-05 00:29:20.565 T:2901  WARNING <general>: ActiveAE - large audio sync error: -18446744073705928.000000
2021-09-05 00:29:20.565 T:3064    DEBUG <general>: CVideoPlayer::CheckContinuity - resync forward :1, prev:18442241078923337728.000000, curr:36884481552954867712.000000, diff:18442240474031403008.000000
2021-09-05 00:29:20.574 T:3064    DEBUG <general>: Skipped 3 duplicate messages..
2021-09-05 00:29:20.574 T:3064    DEBUG <general>: CVideoPlayer::CheckContinuity - resync forward :1, prev:18442241078923507712.000000, curr:36884481552954867712.000000, diff:18442240474031243264.000000
2021-09-05 00:29:20.576 T:2901  WARNING <general>: Skipped 6 duplicate messages..
2021-09-05 00:29:20.576 T:2901  WARNING <general>: ActiveAE - large audio sync error: -18446744073705928.000000
2021-09-05 00:29:20.577 T:2901  WARNING <general>: ActiveAE - large audio sync error: -18446744073705924.000000
2021-09-05 00:29:20.621 T:2901  WARNING <general>: ActiveAE - large audio sync error: -18446744073705920.000000
2021-09-05 00:29:20.661 T:2901  WARNING <general>: ActiveAE - large audio sync error: -18446744073705916.000000
2021-09-05 00:29:20.701 T:2901    DEBUG <general>: Skipped 1 duplicate messages..
2021-09-05 00:29:20.701 T:2901    DEBUG <general>: ActiveAE::SyncStream - average error of -5000.000000, start adjusting
2021-09-05 00:29:20.701 T:2901  WARNING <general>: ActiveAE - large audio sync error: -18446744073705876.000000

Are recordings of the same channel affected?

I’m not sure I’m following the question but I think the records are fine. I mean, I can use the feature (catchup/timeshift) on the same channel on both my phone and laptop (linux based) but not on OSMC/Vero.

  • Nuno Sá

What @sam_nazarko meant is if you record a TV Show to a file and then try to play that file on the Vero instead of live TV is the issue the same?

Ahh, I see. Not sure, any easy way to record the stream? I know there was an IPTV recorder addon that no longer works in Matrix. Other way I have is to just install Leia and try that addon to record a small sample…

Hey guys, my PVR playback is suffering from the same issue as described here after August update. The source is H.264 interlaced.

Unlike OP, I don’t use IPTV in the sense of OTT, but rather “IPTV” coming from Tvheadend/DVB-S2 on my local network.

When I play back a recording, it is just as bad as playing the live stream.

I have uploaded a sample TS file (saved with wget) here:

The video will play at 50% speed and then occasionally catch up with audio.

@LubosD, nice that you could share a record. I did tried to run the recorder addon in vero but it is failing. And recording the channel in a working machine probably does not make sense as I guess it should be fine to play that back on vero…

Please post some logs.

Anything else that I can do to help? @LubosD can you share some logs? This is a big blocker for me and huge regression… I would try a fresh sdcard install but, unfortunately, at this point I don’t have much reasons to believe that it will fix my issues.

  • Nuno Sá

I’ve pasted my logs here: Vero4K PVR trouble -

Live-stream video was playing at 50% speed, but it would occasionally skip to catch up with audio. I’m pretty sure you can reproduce it by playing the .ts file I uploaded previously.

Can you upload logs via My OSMC?



Sorry for the delay, I wasn’t correctly subscribed to the topic. Here it is:

@sam_nazarko Could you please take a look? The PVR feature remains completely broken to me.

What I find odd is that deinterlacing cannot be enabled on these interlaced DVB-S streams.

Just for the record, I’m having a similar problem on my Vero+ with live TV from my MythTV backend. Breaks for a few seconds of black screen, every so often during the broadcast. It seems random.

Recorded TV shows from Myth are not affected. Wasn’t a problem before upgrading.

It’s not a biggie for me as I rarely use my Vero for live broadcasts.

We’ll have an update for Kodi v19.2 shortly – it would be good to check if this issue still occurs after that.

Hi Sam,

Unfortunately the issue is still there. I actually found something else… I disabled the video HW acceleration and the things look better but the performance is horrible though (as expected).

What I mean by “look better” is that the show duration in the OSD screen is completely wrong when HW acceleration is on (at least when timeshift is enabled) . Disabling it and the show duration time is correct and matches the EPG…

Currently I see 2 issues that hopefully are related:

  1. Timeshift + catchup disabled and audio is out of sync with video;
  2. Timeshift + catchup and the video just does not work (audio out of sync, video lags a lot…).

It’s starting to look that the problem might really be in the drivers which worries me a lot. Most likely you need to ask support to your vendor for this and that probably takes a time…

  • Nuno Sá

I’ll look in to this in more detail once v19.2 is out the door.

Hmm, Isn’t it already? I just did a manual check for updates yesterday and I got one… IIRC, in the system info I could see 19.2. Just asking to make sure there’s nothing else odd with my system.

Most likely you have the development repository enabled

We haven’t got a final version ready yet.