[TESTING] Improved multi-channel PCM for Vero 4K

Hi Wuschel,

yes - I did. flac5.1 for example works absolutely fine. This issue is only related to DTS.
I will stress this with the manufacturer of my A/V processor.

thanks, Marc

I still get crackling noise after stopping a multichannel PCM stream and start playing another. It’s always after stopping playback and restarting. Usually no issues on initial playback.

Seems more frequent now than it was before although it did happen before too.

Stopping playback and restarting doesn’t immediately work. I have to stop, wait a minute or so, then start playback again for the problem to go away (at least it seems). I haven’t scientifically tested.

In my setup the only thing that plays back multichannel PCM is LiveTV from my HDHomeRun. So it’s not very often I run into this problem.

Thanks for that. Please confirm you have ‘keep alive’ disabled.

I think the relevant time you have to wait after a track finishes is 10 seconds if ‘keep alive’ is off. If anyone has the time to confirm this it would be useful.

Nothing I have heard. I’ve tested 2,0, 5.1, and 7.1 FLAC, 5.1 and 7.1 TrueHD, and just about every DTS-HD and DTS-HR movie channel layout. The only glitch is the slow sync to DTS-HR, and that’s not the Vero. FLAC sends out PCM with perfect channel layouts every time.

A new thought…I have Audio->Output Configuration set to “Optimized”. Would “Best Match” help with the DTS-HR sync? I have a full 7.1 speaker setup, and have that set, along with passthrough of all Dolby and DTS formats.

Also, with the PCM output update, people who are having trouble with DTS-HR could just tell Kodi not to pass it through, and get channel-perfect PCM. Sure, it would raise the CPU usage a bit, but not that much.

9 posts were split to a new topic: AVR Onkyo RZ820, DTS-HD HRA/Hi Res Passthrough Issue

One last issue: At the moment I have to turn “passthrough off” when I like to hear some DTS music (related to my A/V processor). But after switching to passthrough “off”, the sound is very distorted. Is there a possibility to reset the chipset when switching? Otherwise I have to reboot first.

Cheers, Marc

Can you try describing the distortion (and specifically when it does happen, after which actions, is there a way to stop it, etc.) or even make an audio recording of it?

Ideally that’s what we’re trying to achieve (work out what states are stuck and reset them fully).

Only on specific speaker channels?

I just tried to record the distorted sound, but unfortunately everything was fine. I tested in difference to yesterday when the sound was distorted with my projector turned on (24Hz capability) and today I have only my small Monitor (60Hz) attached. Maybe this could be the cause. I will heck later on with the projection turned on.
Yesterday the distortion was an all 7 speakers.

Vorführeffekt! :grin:

Ok, may we ask that we get some logs from the original issue playing DTS?

For that you need to:

  1. activate logging: GUI settings → system → logging, activate all flags (at the left bottom you can change the view level to expert if you don’t see all at first)

  2. reboot the Vero via GUI

  3. reproduce the issue with playback of DTS material (try a normal one first)

  4. upload the log via MyOSMC in the GUI → log uploader (all configs and logs) and provide the returned URL here

thx in advance

Yes I have it disabled. I will perform the test as suggested by JimKnopf asap.

1 Like

Hi,

here is the log. After having started the Vero with the projector the distortion is here:

https://paste.osmc.tv/eritiparaf

sample will follow…

Here is the sample:

https://www.dropbox.com/s/cj872zlecon585w/Sample.m4a?dl=0

The sample doesn’t work here… It doesn’t contain any audio information. Can you maybe upload it to some site like DropBox and provide a link?

Hi Wuschel_Wuschel and @heimkino-hacki

I’ve edited heimkino-hacki’s post so the dropbox link, now works correctly.

Thanks Tom.

1 Like

Thank you very much. Don’t know what went wrong…

just for information for others with same problems.
I re-encolded all my DTS Music CDs into flac Multichannel format with Xrecode 3. All audio will be recognized perfectly and now, I can use my Vero4K also for all kind of music.

Nice weekend for you all,
Marc

A post was merged into an existing topic: AVR Onkyo TX-RZ820, DTS-HD HRA/Hi Res Passthrough Issue