[TESTING] Improved multi-channel PCM for Vero 4K

Only on specific speaker channels?

I just tried to record the distorted sound, but unfortunately everything was fine. I tested in difference to yesterday when the sound was distorted with my projector turned on (24Hz capability) and today I have only my small Monitor (60Hz) attached. Maybe this could be the cause. I will heck later on with the projection turned on.
Yesterday the distortion was an all 7 speakers.

Vorführeffekt! :grin:

Ok, may we ask that we get some logs from the original issue playing DTS?

For that you need to:

  1. activate logging: GUI settings → system → logging, activate all flags (at the left bottom you can change the view level to expert if you don’t see all at first)

  2. reboot the Vero via GUI

  3. reproduce the issue with playback of DTS material (try a normal one first)

  4. upload the log via MyOSMC in the GUI → log uploader (all configs and logs) and provide the returned URL here

thx in advance

Yes I have it disabled. I will perform the test as suggested by JimKnopf asap.

1 Like


here is the log. After having started the Vero with the projector the distortion is here:


sample will follow…

Here is the sample:


The sample doesn’t work here… It doesn’t contain any audio information. Can you maybe upload it to some site like DropBox and provide a link?

Hi Wuschel_Wuschel and @heimkino-hacki

I’ve edited heimkino-hacki’s post so the dropbox link, now works correctly.

Thanks Tom.

1 Like

Thank you very much. Don’t know what went wrong…

just for information for others with same problems.
I re-encolded all my DTS Music CDs into flac Multichannel format with Xrecode 3. All audio will be recognized perfectly and now, I can use my Vero4K also for all kind of music.

Nice weekend for you all,

A post was merged into an existing topic: AVR Onkyo TX-RZ820, DTS-HD HRA/Hi Res Passthrough Issue

  • With “best match”, passthrough, 7.1 and all formats ticked

I testet starting and stopping the file 5 times and the number shows how many times it worked out of the 5.

Kodi 17.6
Compiled Mar 12 2018

5/5 DD+
3/5 True HD
3/5 Atmos
2/5 DTS:X

Kodi 17.6
Compiled Mar 22 2018

5/5 DD+
4/5 True HD
3/5 Atmos (2 times amp showed “True-HD” instead of “Atmos” and with no sound)
2/5 DTS:X

In the last test of Atmos it did show True-HD instead of “decoder off” and the amps display flickered a little as if it was trying to determine the format.

My gut feeling is that this one is better, although the numbers isnt really there, but i did test Atmos again up to 10 times and got 8/10.

Tell me if you want logs or anything else.
Btw why does my prompt say osmc-Wesley?

Also I dont know if this is any help, but before when I used the PS3/UMS software media server I didnt always automatically get the right audio so you never knew if you had to use mencoder, ffmpeg, avisynth or tsmuxer…

Did you ever get an answer from the Anthem people?


Unfortunately not. I contacted my local dealer to put some pressure into this. Hope that Anthem/Paradigm will issue an update.

For those who experienced some PCM issues (strange noise, crackling or distortion on the rear channels), could you please follow these instructions and provide some feedback:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Seems to work well.

Before this update I started a few videos and the static noise in the side/rear channels was there each time. After the update I haven’t encountered the static noise.


Well this update seems to address multi-channel PCM noise, but now causes an issue when I stop bistreaming DTS-HD or TrueHD movie.

My AVR still shows it’s receiving an audio signal and I cannot play another movie and have the audio play.

Can you post a debug log of that?

Would be good if others can confirm if they can reproduce.

Hi all, I’ve checked this and in my setup, there isn’t a problem like this. Absolutely normal behavior.

Cheers, Marc

Hi Sam and Wuschel,

another question: Yesterday I edited the file. /etc/apt/sources.list
I opened it and it looks like this. Means, the line deb http://apt.osmc.tv stretch-devel main is already there.
Is that normal or must I delete it?

Here is my untouched file: