[TESTING] Kodi 17 (Krypton) Beta Builds for all platforms


Thank you for this hint - although I’ve looked there before.
‘German’ wasn’t available before, now it is and it was activated, too, but still not choosable, but just now I was able to switch to that language (having my wife unhappy while disturbing her TV experience…).

Anyway: thank you!


It should be addons.xml.md5 not krypton.xml.md5


This is annoying. The fourth time I’ve had to edit this file now!


I’m sorry :slight_smile: we appreciate the time and effort you pour into osmc


No problem. It’s better to find, and fix these issues now before Krypton goes final. I’ve updated the builds once more with a URL update. Hopefully for the last time for a while now.


Hi Sam and all the Devs. Firstly, thanks for making my life so much more mediafied with all your hard work!

I’ve been reading through this thread trying to figure out if there is a solution to the issue I am experiencing which I don’t quite understand. I’ve noted the need for logs and also done some testing myself to try and understand what MY specific issue is and what is happening.

The issue has already been discussed above but I was struggling to find the solution there… when I change the settings for the Skin (default Estuary skin running on a RPi2) the settings don’t seem to save. For instance if I remove the display of “TV” or of “Radio” from the main menu it returns on reboot (reboot being completed by using the GUI menu).

Logs (http://pastebin.com/dKGXM1Lt) during the period of the changes don’t show any errors but I don’t see the specific .kodi/userdata/addon_data/skin.estuary/settings.xml file datestamp being updated when i leave the settings menu. The only time I see it updated is if I eidt it manually via WinSCP or if I follow the workaround for the issue as it was seen in Kodi 16 (http://trac.kodi.tv/ticket/16695 - marked as resolved in Jarvis and fixed in Krypton - workaround is buried on one of the referenced threads but I found the below to work) :

  1. Change skin settings to wish to change
  2. navigate back to skin selection
  3. change skin (to for instance estouchy)
  4. Don’t accept the changes
  5. Revert to old skin

then the new settings are written to the file (observed using winscp and directly via ssh).

If i manually change the settings in the settings.xml file they are retained. Initially this seems to be an issue writing to the settings.xml file after making the changes.

I have the issue also on an original Vero. Both installs were completed by overwriting the existing install using the details in [TESTING] Kodi 17 (Krypton) builds for Raspberry Pi (continued). I’ve tried renaming the .kodi folder and starting the settings again from scratch but this didn’t seem to work either.

file permissions on the settings.xml file are rw-r–r-- and owner is osmc as i would expect.

Hope I’ve not missed anything…

EDIT: Just tried a fresh upgrade starting from a fresh osmc build on an RPi3 and then following the instructions to install the beta.

  1. Download installer from osmc website and write out the 2016-12-1 build to micro SD card
  2. Insert card into RPi3
  3. boot RPi3
  4. configure with only standard options available from the wizard and basic DHCP settings on wireless network and use classic skin
  5. reboot and ensure hostname change is effective - change no options
  6. follow instructions as per [TESTING] Kodi 17 (Krypton) builds for Raspberry Pi (continued)
  7. reboot to upgrade
  8. Database updates migration on splash screen completes
  9. error about add-ons not being compatible but no add-ons listed
  10. message in top right about removable storage being mounted
  11. turn on Debug logging
  12. change options in skin settings so as not to display “Tv” or “Radio”, navigate back out of menus to home screen
  13. Reboot
  14. TV and Radio options are still there and error about add-ons also appears again
  15. turn off debug logging

Logs @ http://paste.osmc.io/runimufagi

Oddly the first time that this was run through without debug logging there was a failure to update the settings.xml file, when debug was turned on it then worked ok as i tried to replicate the issue… I’ve just tried removing “music videos” and “favourites” from the home screen in the skin settings and the same issue, the settings file does not update and thus a reboot brings the options back to the main home page.


@ma6cb I have reported exact same issue in RPI kody 17 thread some time ago.
I am not sure that the issue has dissapeared but it is at least much less frequent so maybe some update did fix something…

Before I did try to change SDcard, PSU, and the PI itself : same results.


After upgrade from the notification in OSMC. All went well. Checked the addons.xml issue and all was well.

However the Estuary skin which was fine before upgrade seems to be enlarged. Checked settings all seem the same as before but icons and text are larger so for instance the categories fit less well on the screen.

Seems like it is affecting the whole skin or maybe it’s a new design. Just looks like it is running in a lower res. It’s not. just looks like it. If there is a way to resize the icons and text that would be great.



The default theme has been updated. It takes a little getting used to but is much improved. See kodi.tv they have a blog post all about it


Looks oversized to me. JMHO.

Thanks for the info.



That was my first impression too. Goofy layout IMO.


Is Beta 7 already online? I see it in http://apt.osmc.tv krypton main folder, but when I start apt-get procedure it does not find anyting. Still on Beta 5 …

I have modified sources.list as described in first post, and it worked for the previous updates … Any help would be appreciated.




The latest OSMC version of v17 is effectively Krypton RC1.
(Once you update, it will show that in the info screen in Kodi)

I was able to update v17 beta 5, to the latest version simply by using the MyOSMC’s update function.
I had no need to change the sources.list since I first installed v17 beta 5

What exact commands are you running, and what is the exact output ?



with Kodi 17 rpi3 (clean install of 16 and dist-upgrade today on 17), I’ve noticed that moving on any add-on is very slow: for example searching something in youtube add-on and going on page 2 of the results, then going back to the previous page and to the main menu is slow, I see the minibanner “working” thinking for few seconds instead to go immediately backwards. Tried with Confluence and Estuary skins. The same try on Kodi 16 (rpi2) is working fine, the backward navigation is well performing, no “timeout”. Anyone else have such issue?



This is how I try to update:

And here are the logs in general:

Updating through OSMC GUI sais there are no updates …

This is in my sources.list:

deb http://ftp.debian.org/debian jessie main contrib non-free

deb http://ftp.debian.org/debian/ jessie-updates main contrib non-free

deb http://security.debian.org/ jessie/updates main contrib non-free

deb http://apt.osmc.tv krypton main


You removed deb http://apt.osmc.tv jessie main from your sources.list. add it and try again to update


Unfortunately this is a deliberate kodi change. Addons no longer cache data (to avoid updates being missed) but this has the side effect of making addons slower. See:


I wonder if we should consider making this a GUI setting.


I see other distributions such as elec put there settings inside of the kodi settings too in estuary rather than at the bottom of the main menu. Personally I feel that’s where osmc settings should go

See the bottom of the file


I have plans to change that.

We can put it in Kodi’s Settings menu too.