[TESTING] Kodi 17 (Krypton) Beta Builds for all platforms


Not really big bugs but should be mentioned.

  1. Codec Info Overlay

If i activate the Overlay (CodecInfo) and close it again, sometime some pieces of the overlay font still stay on screen. It dissapears after press pause or jump a step back or forward in the movie.

PS: the old CodecInfo was more helpful as there was more informations, but i think this is nothing you can fix, its a Kodi Team thing :frowning:

2 When i start a movie, it is always asyncron at the beginning, so i jump a step back and all is fine. Maybe there need to be some improvements in the next updates.

I imported my setttings from a Kodi 16 backup, maybe it is a setting with sync fps to display or something that kodi 17 not like at the moment. (when jump a step back all is fine)

At the moment no big problems for me so not really a ugent thing, i just wanted to notice it :slight_smile:


There are some timing improvements for Vero 2 that will be included in the next RC.
We will test them internally first however.


Hi team. I have the original Vero. Today I am trying to put the early release of Krypton on it. I ran the instructions that I read you should run. The machine ends up rebooting but it’s still on Kodi 16.1. I have tried several times and I can’t get Krypton to come up on the machine. I don’t know what I’m doing wrong. Any help would be greatly appreciated.

I don’t have logs yet. I know, debugging is hard without log data. But I thought since I can’t even get it installed on my Vero I would ask first if I am misunderstanding something before getting too deep into the system.




If you have followed the above instructions then Kodi v17 should be running on your system.

Further logs are needed to see why this isn’t the case.


Could you point me to the correct process to follow to get you the data you need to help me please? Thanks.


Have you read the wiki?


Yes I did (now :-).

OK, I turned on debugging. Rebooted, Ran the process that is supposed to get me to Krypton, rebooted, then uploaded the diagnostic log(s).

The message I got was: http://paste.osmc.io/upepejatoy

Let me know when you know something. I already have Krypton installed and customized on my Windows 10 PC and on my Nvidia Shield TV and I would like to get my Vero and Raspberry Pi set up to match.


====================== APT sources.list =================== ZZz2wrJ1
deb http://ftp.debian.org/debian jessie main contrib non-free

deb http://ftp.debian.org/debian/ jessie-updates main contrib non-free

deb http://security.debian.org/ jessie/updates main contrib non-free

deb http://apt.osmc.tv jessie main

---------------------- APT sources.list END --------------- ZZz2wrJ1

This indicates that you have not correctly run the commands that add the Krypton source to your source file.


When I ran the command /etc/apt/sources.list I got “access denied” even though I was running with root access (sudo su).

I did a ‘cd /etc’, then ‘cd apt’ and I looked at sources.list. I was able to open a VI session with the file.

So what do I do to resolve the issue.

Oh, and thanks very much for working with me. I am very computer saavy but not so much so with Linux or OSMC.



All you have to do is run the commands as they are presented in the top post.


I did but I get the access denied message on the second command. I am sorry but what am I missing here?


Each complete line is a command.


sudo -s
echo “deb http://apt.osmc.tv krypton main” >> /etc/apt/sources.list
apt-get update
apt-get -y dist-upgrade && reboot

Shoot, I was about to say this is what I ran but it isn’t. Apparently my Putty screen wasn’t wide enough and I interpreted one command as two :-(.

Yikes, how embarrasing. I will run it all again now and report back… Ugh


Much better result this time :-). So sorry to have taken up your time for such a silly mistake.



@sam_nazarko were my logs sufficient or you need different ones?


Dear all,

I have some trouble updating an RPi from the last Beta to the current RC and hope someone can point me to the reason.

I added the new source as in the top post. I also double checked /etc/apt/sources.list and it does contain „deb http://apt.osmc.tv krypton main“ .

After apt-get update and dist-upgrade it also downloads what seems to be the latest Kodi but then the extraction fails with the following error on the console:

Preparing to unpack .../rbp2-mediacenter-osmc_16.9.8-1_armhf.deb ...
Unpacking rbp2-mediacenter-osmc (16.9.8-1) over (16.8-199) ...
dpkg: error processing archive /var/cache/apt/archives/rbp2-mediacenter-osmc_16.9.8-1_armhf.deb (--unpack):
 symbolic link '/usr/include/kodi/xbmc_pvr_dll.h' size has changed from 75 to 2
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

I have no idea what seems to be the problem. The mentioned link is present but pointing to nowhere and I don’t know where it’s supposed to point to. Any help is greatly appreciated.


Provide complete logs please.

grab-logs -A


I didn’t think this to be a problem in Kodi itself but if it helps – here you go! :smile:


Since the upgrade shuts down Kodi, the log (created a few secconds ago) doesn’t show any recent entries.


Since Kodi v17 i am unable to play Movies with VC-1 Codec.

I got massive lags and buffering all the time.



Can you upload a small sample to replicate the problem?
Can you confirm playback works with Kodi Jarvis?