[TESTING] Kodi 17 (Krypton) builds for Raspberry Pi (continued)

I have the latest version (16.8-048, 25 March 2016) installed and all is good so far.
The only thing is my remote. I use a Logitech Harmony 300 with a Philips TV over CEC to control OSMC. Each button press leads to a double action in OSMC. I have installed the latest libcec 3.1 vie apt-get. I’ve also played with the button repeat settings in Kodi, but nothing helps.
On the stable Jarvis version with libcec 3.0.1 i have no trouble.

Does somebody has any idea?

My device is a raspi 2.

Edit: I have solved my Problem. The Logitech Support had reduce the repeat rate and all is good.

argh, I can’t read, indeed :slight_smile: it works! tx !

@gmc build issues again ?

Version: 16.8-031 Works well
Version: 16.8-032
Version: 16.8-033
Version: 16.8-034
Version: 16.8-035 Works well
Version: 16.8-036
Version: 16.8-037 Works well
Version: 16.8-038 Crashes (sad face on the screen) on Kodi load with next last lines in kodi.log:
00:13:08 76.289505 T:1958339120 FATAL: addon ‘service.xbmc.versioncheck’ is missing.
00:13:08 76.289680 T:1958339120 FATAL: CApplication::Create: Unable to start CAddonMgr
Version: 16.8-039 Crashes on Kodi load. I didn’t look in log.
Version: 16.8-041 Works well
Version: 16.8-042 Crashes on YouTube addon with next last lines in kodi.log:
00:54:32 71.767540 T:1729487856 ERROR: EXCEPTION: Unknown addon id ‘script.module.osmcsetting.apfstore’.
00:54:34 73.510681 T:1729487856 WARNING: CSkinInfo: failed to load skin settings
00:54:36 75.756142 T:1448080368 ERROR: GetDirectory - Error getting
Version: 16.8-043 Crashes on YouTube addon with next last lines in kodi.log:
00:45:57 437.064911 T:1659716592 ERROR: GetDirectory - Error getting
00:45:57 437.070740 T:1958023728 ERROR: Previous line repeats 1 times.
00:45:57 437.070953 T:1958023728 ERROR: streamin_bufferwrap: can’t stream in: requested 16777216 bytes, was read 4446 bytes
00:45:57 437.182861 T:1958023728 ERROR: exception in CApplication::FrameMove()
Version: 16.8-044
Version: 16.8-045
Version: 16.8-046
Version: 16.8-047 Crashes on YouTube addon. I didn’t look in log.
Version: 16.8-048 Crashes on YouTube addon. I didn’t look in log.

Device: RPi2.

He is on holiday

4 posts were split to a new topic: Broken addon

PLEASE don’t threadjack unrelated topics!

@sam_nazarko fzinken told me

Sam ,
In your instructions, for the commands, where in osmc do you issue the commands to request the repository for the update(s).

Thanks

Mike

Well not 100% sure about your question but I assume the answer is “the command line”.
Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

thanks, sorry if I was not clear.

it is pretty clear cause if you dont know how to add repos etc then perhaps testing is not for you since you need some knowledge of checking logs etc for issues… so its not just running the latest Kodi version…

Back again and builds continuing. See first post for latest version.

16.8-048, 25 March 2016: Based off OSMC commit (7d2f65c) and newclock5 commit (bba4122)

Highlights

  • NOTE: DVD playback remains temporarily disabled

newclock5

New commits in this build:

[linux] Move hotplug checking into its own thread (58c3e8e2)
Revert “temp: Add lock around mmal and omx calls to avoid stalled audio issue” (a051a9d7)
Revert “rbp: Use common function with lock for gencmds” (bba4122a)

Commits no longer in build:
VideoPlayer: do not disable stream at processing stage (ae748c96)

4 Likes

Thanks for continuing the builds :slight_smile:

Curious if you have any idea when DVD playback will be available again ?
IIRC there were build issues?

Still no idea when DVD playback will be available yet. I use newclock5 branch which has removed DVD playback due to build issues.

newclock5 hasn’t removed dvd playback - it works fine for me.
It’s removed in your build environment (because the library has moved).

Thanks for the clarification. I’ll check with @sam_nazarko on how we go about getting this back then.

Is my report useless or I posted it to wrong place?

pretty useless check out how to do a proper bug report.

16.8-049, 06 April 2016: Based off OSMC commit (da1953f8) and newclock5 commit (2e022c00)

Highlights

  • NOTE: DVD playback remains temporarily disabled
  • libcec updated so hopefully this solves the previous libcec errors
sudo apt-get install rbp1-libcec-osmc=3.1.0-2
sudo apt-get install rbp2-libcec-osmc=3.1.0-2

newclock5

Too many updated to mention - its been too long since I did the last build.

See Milhouse’s thread on all the previous changes:
http://forum.kodi.tv/showthread.php?tid=250817

I just tested the newest version with my previously provided sample and it is still unwatchable.

Here are some stats showing that how it’s handled has changed

Newest OSMC - 120 dropped and 220 skipped (over duration)
Last OSMC from before your vacation - 300 dropped and 14 skipped (over duration)
OE - 9 dropped and 2 skipped (at start, with perfect playback after)