[TESTING] Kodi 17 (Krypton) builds for Raspberry Pi (continued)

Whoops - forgot to update sync. Should be avaialable within the hour.

Update: Ahh - seems inputstream.adaptive was not added to the last build. Will fix for the next build

Hi there. short question. With the osmc krypton builds im not to be able to load pvr addons. Always the same message “unable to load addon - unkown error occured”. Google told me that this error was solved with kodi krypton beta 5. why it isnt with osmc builds?

kr 3rr0r

hi

running sudo apt-get install rbp1-mediacenter-osmc on pi zero I keep getting:

error processing archive /var/cache/apt/archives/rbp-userland-osmc_1.5.0-1_armhf.deb (–unpack)
trying to overwrite ‘/opt/vc/bin/vcdbg’, which is also in package libraspberypi-bin 1.20161125-1

any ideas?

Thanks very much

This are the errors from log:

21:15:27.104 T:1958359040 DEBUG: CurlFile::Open(0x5c73ca8) http://192.168.0.10:8089/api/status2.html
21:15:27.105 T:1958359040 ERROR: CCurlFile::Open failed with code 404 for http://USERNAME:PASSWORD@192.168.0.10:8089/api/status2.html
21:15:27.105 T:1958359040 ERROR: AddOnLog: DVBViewer Client: Unable to get backend status. Error: Error document empty.
21:15:27.106 T:1958359040 ERROR: ADDON: Dll DVBViewer Client - Client returned bad status (1) from Create and is not usable

DVBViewer is reachable over 192.168.0.10:8089 - but not with /api/status2.html

???

Looks like you are trying to install on Raspbian.

You need to be running OSMC, not Raspbian

Having upgraded to Krypton via this thread [TESTING] Kodi 17 (Krypton) Beta Builds for all platforms do I need do anything other than usual sudo apt-get update && sudo apt-get dist-upgrade ?

As although I’m on kodi 17 when I run the command nothing is available or should it be done within Kodi?

There seems a lot more commands at the top of this thread than I ever ran…:astonished:

These are two different approaches to install Kodi 17 (Krypton). In this thread nightly versions are provided and discussed.
You are using the beta stable approach which you should stick to as it is more stable. For that one you will get updates (when they are provided) via sudo apt-get update && sudo apt-get dist-upgrade

Thank you, finally figured out that all my problems and frustrations have been from a bad WinSCP install, getting things moving again now.

Ok that makes sense thanks :slight_smile:

16.8-198, 01 Dec 2016: Based off OSMC commit (b9120ae19) and newclock5 (a1d171f)

Build Highlights:
Temporarily removed peripheral.joystick due to build errors.

XBMC:
Controller fixes (PR:10630, 12 commits, 27 files changed)
aml: Support for 4K H264 on S905X (PR:10944, 2 commits, 4 files changed)
rbp: Don’t close the display here it should be closed by the opener (PR:11006, 1 commit, 1 file changed)
fixed: tighten vcd .dat file checks to avoid unwanted filtering (PR:11004, 1 commit, 1 file changed)
remove unused variables / members (PR:10980, 1 commit, 14 files changed)

kodi-theme-Estuary:
Tweaked backgrounds (PR:137, 1 commit, 19 files changed)
videoinfo: increase helperlabel width (3813fc0c)
settingscategory levels button (3ac2bfd2)
streamline playlist window (1120f02f)
videoinfo grouping (27528adc)
eventlog tweaks (b8d69931)
eventlog work (9e82c6bb)
tweak fav animations to be consistent with rest (c0d1c274)

pvr.filmon:
Fix EPG after API change (PR:59, 1 commit, 3 files changed)

newclock5:

New commits in this build:
Revert “[hifiberry] Hack: force it to be recognised as IEC958 capable to enable passthrough options” (a1d171ff)

Commits no longer in build:
rbp: Don’t close the display here it should be closed by the opener (0951bbb4)

Inputsteam.adaptive is now correctly built with version 199.

1 Like

Thanks - I could activate the addon. My Amazon prime addon does not start any streams. Need to figure out why … Could be an issue with one of the plugins (obviously).

.199 seems more unstable, I have some sudden reboots. I will see if I can figure out in what situation this happens and post a log then.

You need Widevine libraries installed.

I know … I had it working from .160 to .197 … I never had to re-install widevine after upgrading. But I will check this for .199. I do not think it is OSMC related (so out of scope for this thread); I just mentioned it here because the only change I noticed in this regard was the new inputstream addon.

But as we are talking about this: widevine could not possibly be part of OSMC, right? I assume it’s due to licensing issues?

You need to install the Widevine libraries yourself at this time.

Thanks very much for the quick reply!

and though it makes me feel rather dumb - happy to report that so far it actually does work on raspbian.
I ignored the error and started testing - not done much yet, no addons or playback, but seems fine.
Most importantly, scaling of the touchscreen coordinates works a charm.
The only issue I have noticed so far is the infamous black screen on exit.

Thanks for all the work on this

i’m wondering does this branch include the bootcode.bin and start.elf for USB only booting, i’ve already enabled the mode using the guide on RPI foundation and checked the OTP and i have indeed enabled it in, eager to test out OSMC running on my OCZ in a USB3.0 caddy.

These builds no not interfere with OSMC’s shipped firmware.

OSMC’s firmware includes changes required for USB boot.

IMHO, this is a waste of an SSD. A good SD card will be fine.

1 Like

thanks for the lightening fast reply Sam, so i would be good to go by simply writing the latest stable release to a USB drive? its more a test and tinkering than a long term use just wanna test it out. was considering moving my TVHeadEnd backend over to the Pi and need move storage locally so decided to try a sole USB build, i am aware that the USB and Ethernet are on the same bus so i might experience some issues but still i’ll give it a go. Thanks again man.

Yes – but you’ll need to know what you’re doing (how to configure cmdline, fstab etc), as the current OSMC installer still configures /boot to exist on an SD card.

But some people have mentioned this in the forum already

For storing content such as TV, an SSD is complete overkill.