[TESTING] Kodi 17 test builds for Raspberry Pi

Just checked the latest build - also getting the same error

FATAL: addon ‘service.xbmc.versioncheck’ is missing.

Let me do some digging to find out what’s causing this.

1 Like

ATTN @gmc i installed that service addon and so far it seems to work crude workround as i dont see why is should need it but if this helps anyone else im glad i tried :stuck_out_tongue:

p.s i disabled it from doing any version checking under configuration.

Very odd. I’ve deleted and recreated the Addons22.db and don’t see the service being added.
The addon-manifest.xml contains service.xbmc.versioncheck so I’m not 100%.

Will keep digging - something must have changed

I remove that service in build.sh because it’s not appropriate for OSMC.

Perhaps something has started depending on it

1 Like

hi mates. i installed the versione of the 28th on the official one: everything is working and channel zapping on iptv is a lot faster. then i try to install later versions but both the one of the 29th and the one of the 1st goes on bootloop showing the screen with sad emoticon.
have i to do some kind of cleanings before install a new alpha on an older one?

16.8-039, 01 March 2016: Based off OSMC commit 92f47ce27e3 and newclock5 commit (4cdff06)

newclock5

Commits no longer in build:
squash dropping (c928cc53)
squash me (c3328bb7)

Additional commits/pull requests/changes not yet merged upstream:
Exclude [env] Incompatible with libcec 3.1.0, not required (libcec-03-amlogic-support.patch:)
Added: [pkg] Implement filecache retry logic (PR:8723:)
Added: [pkg] Fix out of memory crash in CArchive (PR:9225:)

RPi1:

wget http://download.osmc.tv/dev/gmc/rbp1-mediacenter-osmc-01032016.deb   -O /tmp/kodi.deb && sudo dpkg -i /tmp/kodi.deb && sudo systemctl start mediacenter

RPi2:

wget http://download.osmc.tv/dev/gmc/rbp2-mediacenter-osmc-01032016.deb   -O /tmp/kodi.deb && sudo dpkg -i /tmp/kodi.deb && sudo systemctl start mediacenter

@toast @chicco Crash issue should be fixed now that was occurring with 038 & 039 (service.xbmc.versioncheck)

The new skin Estuary should be in tomorrows build.

2 Likes

awesome tnx gmc

@chicco if your gonna run alpha builds make sure to read whats in the thread before posting offhand comments on your issues cause likely there is a solution or a fix or that the same question has been posted before…

5 posts were split to a new topic: SD Card failure

I’m still getting looping sad faces with the 0103 version.

21:33:50 157.786819 T:1958597168 FATAL: addon ‘service.xbmc.versioncheck’ is missing.
21:33:50 157.786987 T:1958597168 FATAL: CApplication::Create: Unable to start CAddonMgr

This was fixed is 16.8-040 (02/03) version.

Woops, guess I missed that post :slight_smile:

1 Like

For latest build see here

16.8-040, 02 March 2016: Based off OSMC commit (92f47ce27e3) and newclock5 commit (35c626ced13)


Build Highlights
This build includes a fix for a crash issue occurring 038 and 039 (FATAL error on service.xbmc.versioncheck)

NOTE: For current builds DVD playback remains temporarily disabled

  • Include pkg patch: # Quick fix for libdvd build issues

newclock5

New commits in this build:
fixup! temp: Add lock around mmal and omx calls to avoid stalled audio issue (35c626ce)

Commits no longer in build:
changed: Ignore chapters for large step if there’s only one (60bf5ee5)
VideoPlayer: some cleanup for dropping video frames (4cdff068)


RPi1:

wget http://download.osmc.tv/dev/gmc/rbp1-mediacenter-osmc-02032016.deb   -O /tmp/kodi.deb && sudo dpkg -i /tmp/kodi.deb && sudo systemctl start mediacenter

RPi2:

wget http://download.osmc.tv/dev/gmc/rbp2-mediacenter-osmc-02032016.deb   -O /tmp/kodi.deb && sudo dpkg -i /tmp/kodi.deb && sudo systemctl start mediacenter

Noticed the 03032016 version is also online. Should that include the new skin?

Yes - see first post. (Which always contains the latest build)

16.8-041, 03 March 2016: Based off OSMC commit (92f47ce27e3) and newclock5 commit (6dcbf2af)

Build Highlights
Confluence skin has now been retired and replaced with Estuary. This is now the default skin in the nightlies.

NOTE: For current builds DVD playback remains temporarily disabled

  • Include pkg patch: # Quick fix for libdvd build issues

newclock5

New commits in this build:
fixup! rbp: Support zero copy interface with hevc acceleration (1c7b53c3)
MMALFFPEG: Avoid crash with 10-bit video (6dcbf2af)

Commits no longer in build:
confluence: Remove media-overlay.jpg for when video is backgrounded (b8f7aadf)
fixup! temp: Add lock around mmal and omx calls to avoid stalled audio issue (35c626ce)


RPi1:

wget http://download.osmc.tv/dev/gmc/rbp1-mediacenter-osmc-03032016.deb   -O /tmp/kodi.deb && sudo dpkg -i /tmp/kodi.deb && sudo systemctl start mediacenter

RPi2:

wget http://download.osmc.tv/dev/gmc/rbp2-mediacenter-osmc-03032016.deb   -O /tmp/kodi.deb && sudo dpkg -i /tmp/kodi.deb && sudo systemctl start mediacenter

Estuary looks great, I think @sam_nazarko can stop looking for a skinner :wink:

1 Like

I’m loving Estuary as well - my skin of choice :slight_smile:

1 Like

indeed Estuary is really nice looking gonna have it as my default skin from now on no need for other skins.