[TESTING] Kodi 18 (Leia) builds for Raspberry Pi

When it’s ready.
The RPi version has been ready for a couple of weeks, but we are waiting for other platforms

Sam

1 Like

Any thread but here. since this thread is for test builds for those that wanna test the bleeding edge of Kodi

Hi,

I’m testing OSMC 18, and when i want completed the field MySQL in Network section, i can’t, it’s normal because we are in RC version ?

We can’t translate the add-on MyOSMC ? I could do the French translation if you want…

Akhlan

It’s not possible to translate My OSMC at the moment; but this is something we will work on.

Can anyone check this?

Sam

If the RPi build has been ready for a couple of weeks, how different is it from the last build on gmc-18? I believe there were still some issues with that one? Thanks.

they differ since they include experimental patches that are not merged into kodi.

what Sam is building is the stable release and thats why its taking additonal time.

Now please for those that are soo anxious for the future update on OSMC start a thread and use that instead leave this thread of testing purposes.

I didn’t mean to derail the conversation further. I just assumed that any release build would have been available as a testing build at some point, then promoted to an RC, and then to a release. From the looks of this conversation, no build has gone through that process. Am I misunderstanding the purpose of these testing versions?

What issues are you experiencing with the Pi?

For one thing, I have the same issue on my RPi2 as on my Vero 4K: the Skin Service Helper crashes on startup, as someone else reported above.

As a consequence, I’ve changed my skin from the default to Confluence. That one in turn sometimes shows all TV episodes instead of only unwatched ones. Toggling between watched, unwatched and all doesn’t help. It seems to go away after navigating to other sources and going back to TV Shows. Could be related to the fact that I’m using MySQL and/or Trakt, but it didn’t happen before upgrading.

It’s possible some of your add-ons aren’t compatible with the latest version or there’s an issue with the Skin Service Helper add-on.

Sam

Sure, but I thought the Skin Helper Service addon was installed by default? I’m not 100% sure what it does but I hadn’t changed the skin on either of my devices until now, so I can only assume it came with OSMC.

If the issues persist after the upgrade to the release build, I’ll try a factory reset. Hence my question about access to said build.

The test builds are in the staging repository.
The issue will likely be solved with the next update.

For problems with skin helper service you will need the version from here: https://github.com/kodi-community-addons/repository.marcelveldt you will afterwards have to update some additional plugins to versions that are also part of this repo.

Those newer versions are not needed for our skin! Those do indeed sometimes cause problems of their own.
Please don’t suggest a beta repo to users, @Qoopido. Users may want to use it for skins relying on it, but our OSMC skin doesn’t need any beta scripts to work just fine. :wink:

The OP is probably on a gmc18 build version where the issue described was “normal” - we did some tests in some of the builds that caused this issue. Updating to the newest gmc19 nightly or the stable v18 release - once it’s out - will most likely solve this.

1 Like

@Chillbo Sorry for having caused confusion. I am on GMC-18 nightlies as well, had the same message in my logs and use a skin (Embuary) that does not rely on skin helper service. But, at least in my case, switching to the beta plugins resolved the issue without introducing new problems.

Seems that it would be the best to ignore this message until 18.1 is released officially than :wink:

@gmc any progress with additional emulators ?

Afraid not. I’ve tried a few of them and they all give a black screen. Also tried the same emulators on the latest LE build and had the same issue :frowning:

1 Like

Lets hope Garbear and the rest of the kodi crew works out the bugs really itching for some nintendo 64 :smiley:

With Kodi now branched to 19 and OSMC Leia 18 stable soon to be released its time to close this thread.

See you all in the v19 thread.