[TESTING] Kodi 18 (Leia) builds for Raspberry Pi


#21

17.8-002, 5 Dec 2016: Based off OSMC commit (b9120ae19e) and newclock5 (0222e62e)

Build Highlights:
Added peripheral.joystick back
Temporarily switch back to stock kodi-theme-Estuary

Build Details:

XBMC:
[cleanup][pvr] get rid of obsolete guide views (PR:10838, 2 commits, 5 files changed)
[guilib] Change System.HasModalDialog to System.HasActiveModalDialog … (PR:10850, 2 commits, 11 files changed)
Inconspicuous fix (PR:11022, 8 commits, 245 files changed)
Mir windowing system for Kodi (PR:10898, 1 commit, 20 files changed)
[PVR] context menu rewrite & major gui actions refactoring (PR:10870, 21 commits, 66 files changed)
Integrate CSettings into CServiceManager/CServiceBroker (PR:10848, 3 commits, 223 files changed)
[cmake] linux: install game headers (PR:11035, 1 commit, 1 file changed)
fixed: do not use move into member variable here (PR:11026, 1 commit, 1 file changed)
[Estouchy] update (PR:11030, 1 commit, 3 files changed)
Revert "This makes the SubtitleDialog remember the last service used,… (PR:11036, 1 commit, 2 files changed)

inputstream.adaptive:
.gitignore adapted (4cfc3a29)

newclock5:
Commits no longer in build:
[hifiberry] Hack: force it to be recognised as IEC958 capable to enable passthrough options (e907db29)
[rbp] [retroplayer] Initial support for mmal renderer (c55fcb77)
Revert “[hifiberry] Hack: force it to be recognised as IEC958 capable to enable passthrough options” (e36ac2a4)


#22

The Front door method in OSMC using the the Update app was not working for me as the logs I posted above will show. Getting Error unknown package

The fix for me

Using Putty sudo apt-get update
sudo apt-get dist-upgrade now we have 17.8-003


#23

Updating via the gui is a known issue and you need to update via cli.

I’ll add this info to the top so others are aware.


#24

Could you also add this up to for others :
editing /etc/apt/sources.list use this

sudo nano /etc/apt/sources.list

At the bottom of the screen you will see instructions on how to “write out” (save) your edited file (Press Ctrl and “O”), and exit (Ctrl-X). So just make the changes you need, press Ctrl-O to save and click enter then Ctrl-X to exit the editor.

P.S you can not jump from Jarvis to 18 you need to update to Krypton first


#25

ummmmmmm I did something STUPID !! While trying to get these updates corrected on all my pi’s for testing…and not checking out my live tv streams I now have video studder. Lesson learned !! Always keep older copy working to compare !

Any instructions how to go back to 17.8-001 ?


#26

You should be able to update directly to Kodi v18, assuming @gmc has imported all of the dependencies. What error did you get before upgrading to Krypton?

Editing files is already covered in the Wiki.

This is covered above: just search for ‘downgrade’


#27

I followed the above instructions to upgrade from Jarvis and it wouldn’t do it. So I upgraded to Krypton and everything works


#28

Good news !! Found a pi-2 with 17.8-001 and not plugged in !! So turned off Updates went to CNN HD channel and the lower scrolling marquee is the test for studder running smooth.

Pi-2 with 17.8-003 same channel a lot of studder

Pi-3 with 17.8-003 same channel running smooth

Let me know if you need anything for testing

P.S. I keep forgetting to post about the splash screen is screwed up on TV’s less the 32" my 55" is perfect


#29

Are you sure you upgraded via CLI and not the My OSMC interface?

Some picture of the error you received would be handy.

@gmc – did you import all the Debs which are dependencies in to v18 repo?


#30

All I did was install on the first post here. Didn’t know about the other stuff


#31

That’s probably the issue - have just done that now.
Will also do some testing going from jarvis to v18

Update:I’ve added libcec and libbluray to the repo. Tried a fresh build going from latest Jarvis (16.1.0-27) to 17.8-003. No upgrade issues or problems playing any content.


#32

I just installed this version - works very nice for me at the moment. Very very smooth - seems great to me at the moment.

Are there any plans of including RetroPlayer in this version of kodi soon?


#33

It’s planned :slight_smile:


#34

What does that mean in detail?
Do you think installing a Libreelec with Retroplayer makes sense? Or do we have the first Testimplementation of retroplayer within the next days? :wink:


#35

17.8-003, 7 Dec 2016: Based off OSMC commit (b9120ae19e) and newclock5 (56b9be9)

Build Highlights:
NFS dir symlink fix

Build Details:

XBMC:
[NFS] - in case we resolve a symlink - don’t accidently manipulate the original dirent memory (PR:11049, 1 commit, 1 file changed)
[doxygen] improve coding guidelines for header includes (PR:11043, 1 commit, 1 file changed)
FIX: [rar] deadlock with cbr + net vfs (credit notspiff) (PR:10830, 1 commit, 1 file changed)
[PVR] CApplication::PlayMedia: Use new PVRGUIActions functionality for playback of PVR channels and recordings. (PR:11052, 1 commit, 6 files changed)

pvr.mythtv:
4.10.1 (PR:79, 2 commits, 5 files changed)
4.11.0 (PR:80, 4 commits, 9 files changed)


#36

Raspberry pi3 using HDhomerun Comcast cable on gig network

CNN HD channel shows studder

http://paste.osmc.io/elugimizon


#37

17.8-004, 10 Dec 2016: Based off OSMC commit (b9120ae19e) and newclock5 (8c3dddf0)

Build Highlights:
Update inputstream.adaptive with widevine decryption support
Revert “remove autotools buildsystem”

OSMC:
When building add-ons, ensure that we check the bootstrapped directory for add-ons to build, or we won’t find any (afd1f0ef2fa)

XBMC:
[PVR] Fix PVR channel OSD display conditions. (PR:11054, 1 commit, 1 file changed)
allow absolute item focus (PR:11019, 1 commit, 2 files changed)
[PVR][EPG] Feature: gridcontainer orientation (PR:10795, 1 commit, 4 files changed)
FileBrowser: fix multiple item selection (PR:11011, 1 commit, 2 files changed)
BinaryAddonCache: Fix deadlock (PR:11057, 1 commit, 1 file changed)
fixed: tag updates on shoutcast streams with low meta data intervals (PR:11061, 1 commit, 2 files changed)
[python] allow setting the videoinfotag path (PR:11012, 1 commit, 2 files changed)
[cmake] Fix FindXSLT.cmake typo (PR:11071, 1 commit, 1 file changed)
FIX: [droid;dyload] never dyload dependent sytem libs (PR:11059, 1 commit, 1 file changed)
Two game fixes (PR:11069, 2 commits, 3 files changed)

inputstream.adaptive:
version bumb (1.0.1) to force update (a6d8f0cd)
add decrypter library (ce951add)
compile issue in DEBUG (e930b961)
fix provisioning (ca9de740)
add cdm/build (df48d052)
transform all NAL units to ANNEX-B (ab78291b)

peripheral.joystick:
Added buttonmap for PS4 controller (PR:68, 1 commit, 1 file changed)
Added buttonmap for PS4 controller (connected through USB) (PR:69, 1 commit, 1 file changed)
[buttonmaps/keyboard] Add simple configuration for 2048 (53127b1c)

pvr.argustv:
Initial Kodi v18 version. (5ed461b2)

pvr.demo:
Initial Kodi v18 version. (b1ae5cd0)

pvr.dvblink:
Initial Kodi v18 version. (2848f737)

pvr.dvbviewer:
Initial Kodi v18 version. (f5fd3911)

pvr.filmon:
Initial Kodi v18 version. (05f058ec)

pvr.hdhomerun:
Initial Kodi v18 version. (abff86b7)

pvr.hts:
Initial Kodi v18 version. (3fa771b0)

pvr.iptvsimple:
Initial Kodi v18 version. (85866f96)

pvr.mediaportal.tvserver:
Initial Kodi v18 version. (5724cea9)

pvr.mythtv:
5.0.1 (PR:82, 2 commits, 3 files changed)
Initial Kodi v18 version. (47468724)

pvr.nextpvr:
Initial Kodi v18 version. (8963ad70)

pvr.njoy:
Initial Kodi v18 version. (73ff100a)

pvr.pctv:
Initial Kodi v18 version. (a876816b)

pvr.stalker:
Initial Kodi v18 version. (e10a7873)

pvr.vbox:
Initial Kodi v18 version. (7e75ada7)

pvr.vdr.vnsi:
Initial Kodi v18 version. (4d17aaf4)

pvr.vuplus:
Initial Kodi v18 version. (ccacc6d1)

pvr.wmc:
Initial Kodi v18 version. (c4a8c80f)

newclock5:

New commits in this build:
test: Add advancedsetting for AC3 bitrate (83519f91)
testing: Try minimal libass cache size on all devices (8c3dddf0)


#38

Have the issues just started? Were they present on Krypton?


#39

Running 17.8-003
Saw Update message so downloaded I think I saw -005 and clicked OK to install

Error installing ( Unknown Package )
Please report this in OSMC forum

http://paste.osmc.io/vutaceribe.vhdl

Clean install on Pi3. No add-ons or other peripherals.
Repeated this twice now with same error message

(Hope the Log is right, first time I’ve done this)


#40

We need complete set of logs. The kodi log you provided here is of little use in this situation…