[TESTING] Kodi v19 builds for Raspberry Pi 2/3/4

Will play fine with next update.

1 Like

Settings/Player/Videos.

In the lower left corner switch to expert, instead of standard to display the option.

1 Like

Confirmed working fine. Thanks.

1 Like

I’m having issues on my RPi 4 (4 GB) with 2160p video playback of some large files (10-70 GB), both with h.264 and h.265/HEVC encodings.

  • some files don’t show any video at all and only play audio (the Kodi UI is visible, no black screen)
    disabling the DRM Prime decoder helps to show video, but it stutters and buffers a lot
  • some files show video with both DRM Prime on and off, but stutter in both cases
    video often lags behind the audio here
  • I’ve even encountered severe UI glitches, seemingly as the result of stuttering

I’m happy to DM some logs and help with debugging this :slight_smile:

PS: The build version shown in MyOSMC is OSMC November 2020 2020.11-1, not sure if this is expected? It’s a RPi 4, so I definitely have a newer image installed…

Yes. All testing builds still show that. Internal version numbers are being updated so that fixes will be installed on update. The build date for Kodi (in kodi.log) should be recent.

1 Like

I installed the new OSMC on a Raspberry Pi 4 and here are the problems I encountered.

At the first boot, the screen remained black. I had connected the HDMI-0 (next to the power supply). I plugged it into the HDMI-1 and it worked.

CEC was not working with my Samsung TV. The solution of turning off the RPI and the TV for 60 seconds didn’t work. I switched back to HDMI-0: the picture and CEC works.

When I launched a video, the image was not displayed, but I had the sound. The following error was in the logs:

ERROR <general>: 
                 Object: plane	ID: 68
                   Property: FB_ID	ID: 17	Value: 227
                   Property: CRTC_ID	ID: 20	Value: 74
ERROR <general>: CDRMAtomic::DrmAtomicCommit - atomic commit failed: Invalid argument
ERROR <general>: CDRMAtomic::DrmAtomicCommit - test commit failed: (No space left on device) - falling back to last successful atomic request

I decreased the size of the display (Settings / System / Display / Video calibration…) and the image is displayed. Maybe the problem comes when OSMC tries to display a pixel outside the screen. (v19 - RPi4B cannot play some video: CDRMAtomic::DrmAtomicCommit - test commit failed / vc4_place: Don’t reject fractional source coords)

So far, I haven’t had any other problems. Thank you very much for your work.

Testing the rpi 4 image. Was successfully able to boot, update, and reboot. Now trying to get it to work with the official 7’’ touchscreen display for rpi. Touchscreen powers on, shows a few boot messages (upside down) [something about waiting for the root filesystem then two others that are too fast to read], shows the OSMC logo (upside down) then goes white. Pi is still accessible via LAN ssh. I have re-positioned the ribbon cable multiple times to no avail. Any thoughts?

Any ideas Sam? Or should I sit tight and wait for updates?

There’s some issues with add-on installation that we hope to address soon in a new build.

1 Like

CEC was not working with my Samsung TV. The solution of turning off the RPI and the TV for 60 seconds didn’t work. I switched back to HDMI-0: the picture and CEC works.

Can confirm this, exact same thing for me

UPDATE:
Tested the LCD-touchscreen with an RPi 3b+ running raspbian and it worked fine so I assume that the display is in working order (still upside down, but that seems to be a configuration file issue that I will try to tackle later). Updated RPi 4 over the command line via apt but nothing new was available. Still exhibiting the same behavior as mentioned previously when LCD is connected to the RPi 4 running OSMC.

UPDATE 2:
Ran some additional tests with my RPi 3 that I confirmed was working with the touchscreen earlier. I tested the Kodi 19 test build and the current Kodi 18 release build and found the white screen issue also present in the RBP2/3/3+ testing version (though I learned that this issue is NOT present during the first startup/installation phase) and I found that the issue is NOT present in the current release build for Kodi 18 on the RPi 3 at all.

Sam, is it safe to assume this is an issue with the testing build at this point? If so, should it be added to the list of known issues? (Sorry, I’m kind of new here.)

I noticed that opening the “Pi Config” from My OSMC doesn’t work :slight_smile:

1 Like

Most of my 4K files play fine (RPI4), but a few don’t show any video. Is there any point in submitting bug reports or is it better to just wait and be patient?

Assuming that it is related to the resolution devision bug no need to post a report, just wait for next release

On my rpi4 when i press the exit button in the power menu the blue screen with the osmc logo never comes up and kodi is still showing but i can not do any thing there either
Thought I would report the problem thanks for the great work

2 Likes

When I open the “My OSMC” show up " My OSMC service is unavailable Please wait a few seconds and try again"

  • I try later and nothing changes
  • restart system still nothing

:slight_smile:

This issue is known and on our list :slightly_smiling_face:

Two issues

  1. Why doesen’t work analog output?
    In kodi 18.9 I have options: hdmi and analog together.
    Matrix does not have this option.
    Matrix has not option analog output.
    I must enable analog output in config.txt?

  2. I can not change the skin.
    Now I have set estuary.
    When I change to OSMC skin I see screen (yes/no).
    2 seconds later screen disappears and I no time to change.

When I change to OSMC skin I see screen (yes/no).
2 seconds later screen disappears and I no time to change.

yeah, I noticed that too, now that you mention it. you need to be quick, then it works :slight_smile:

is uname supposed to return aarch64 bit as opposed to the 32bit userland?