[TESTING] Kodi v19 builds for Raspberry Pi 2/3/4

Overview

The next version of Kodi v19 (codename Matrix) was released in January. Since then, we’ve been working on bringing this up for OSMC. There have been a number of technical challenges, but we now should have a release that is of the standard you would expect from us.

Just over a month ago, we outlined a list of things you need to know before considering upgrading to this version. We will release this as a stable build with the Kodi v19.1 release, which we expect to be made available at the end of the month.

Supported platforms

This release supports:

  • Raspberry Pi 2 (all models and Compute Modules)
  • Raspberry Pi 3 (all models and Compute Modules)
  • Raspberry Pi 4 (all models and Pi 400)

Support for Raspberry Pi 0 / 1 has now been discontinued, as the platform has reached end of life status. We will continue to keep older images on the website available for download.

How to update

Updating from a stable version of OSMC

If you’re running a stable version of OSMC, then you should be able to update from a compatible platform without issue. Please make sure that you system is up to date first by going to My OSMC → Updates and initiating an update check; installing any outstanding updates.

Updating via the command line

To install the update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv buster-devel main

Go to My OSMC → Updates again, and initiate an update check. Install the updates when prompted.

Fresh installation

Installation images are available here for the following platforms.

As we haven’t released any images for Pi 4 / 400 in the past, you can only upgrade to Kodi v19 if you are using a Raspberry Pi 2 / 3.

RBP2/3/3+
RBP4

Please note that these images enable the buster-devel repository by default. You may wish to change this back to busterif you do not want to receive experimental updates.

Also note that even though you’ve installed a fresh image, we are pushing updates regularly, so we’d recommend checking for updates immediately after installing.

Tracking releases

There are outstanding issues, so we plan to push some further test builds over the coming days. You may wish to keep the modification to /etc/apt/sources.list, but we would recommend keeping this active until the final release is made available. When we do this, we’ll make a clear announcement on the forums and blog.

Known issues

Currently, we are aware of the following issues:

I’ll update this section as more issues are discovered.

Frequently asked questions

Q: I’ve installed the update and now I only have a black screen or a sad face loop, how do I fix this?
A: It’s possible that your Kodi userdata is causing an issue with the new version. The first recommendation would be to move it away and allow Kodi to generate a new userdata directory. This can be done by executing the following commands after accessing the command line:

sudo systemctl stop mediacenter
mv ~/.kodi ~/.kodi-backup
sudo systemctl start mediacenter

Before attempting this, you may wish to try a more conservative approach, and delete ‘Addons.db’ only, as reports from users suggest that add-on migration is the problem

Q: I only see a black screen / hang on migrating add-ons, what should I do?
A: If you encounter this problem and a consider amount of time (more than half an hour) has passed, you should log in to the system and execute the above instructions from the previous question.

Q: I am using a shared library? Has the database version changed?
A: Yes. You should check that your other Kodi clients are compatible with Kodi Matrix before upgrading.

Q: Are add-ons supported by Kodi Leia supported in Kodi Matrix?
A: Not necessarily. Kodi has now moved to using Python 3 as the add-on interpreter, so add-ons which only support Python 2.x and haven’t been updated won’t work.

Q: I can’t find my add-ons anymore
A: To ensure compatibility where possible, Kodi disables any non-official add-ons by default when a new major version is released. You should be able to enable them manually under Settings. Note that this does not necessarily mean they be compatible with the new version of Kodi. Kodi will also disable add-ons that are not Python 3 compatible.

Q: Will my current skin work with Kodi Matrix?
A: The new version of Kodi has reworked the skinning system extensively, and as such, only a handful of skins are currently ready for Kodi Matrix. You should check with the developer of the skin to see if there is a Matrix compatible version available

Q: My add-ons are not working, what can I do?
A: You should notify the developer of this add-on and ask them if there is a version compatible with the new version of Kodi. Unfortunately OSMC cannot do anything about this.

Q: How can I downgrade?
A: Unfortunately, downgrading is not trivial. However we will maintain Leia images on our website for some time. If you discover a bug or issue, we are more interested in fixing it, as there will be users in a similar position, rather than having users downgrade.

Q: I don’t see all of my skin’s menus. What can I do to resolve this?
A: Please wait a few moments for the skin menus to be rebuilt. This may take a while to update if you have a number of add-ons on your system. If the issue persists, you should check that your skin is indeed compatible.

Q: CEC has stopped working, what can I do?
A: Power off your TV and device at the mains for 60 seconds, including your AV receiver if you have one. This usually resolves CEC issues.

Q: My question is not answered and I am experiencing an issue, what can I do?
A: Please start a new forum post, with detailed information so that we can assist you with your problem.

Q: Can I update my Pi 2 or Pi 3 and boot the SD card in a Raspberry Pi 4 / 400?
A: This is not possible. We have specific optimisations for the Pi 4 / Pi 400 hardware and intentionally prevent booting Pi 2 / Pi 3 images on Pi 4 / Pi 400 hardware as a result.

Changelog

  • 15/04/2021: initial release
  • 28/04/2021: updated to top of Matrix upstream tree; fixed add-on dependency issues.

Let me know how you get on

Cheers

Sam

1 Like

Thank you so much Sam for the effort and the time taken to deliver this.

Testing it now on rbp4 :-).

All the very best,

Greg

Hi,

The test build is working great overall. I am just running into one issue. I am trying to get netflix to run and also an iptv provider. I have installed pycryptodomex wheels and setup tools as well as the necessary python dependencies for those. Netflix however prompts me with a pickle: 5 Value error. The iptv provider prompts me with an error that says widevine is not supported for 64 bit and I need a 32bit userland. I was under the impression that this release would have a 32bit userland. Both apps work fine on libreelec matrix.

Am I missing something? I can provide a log later if needed.

Regards.

The userland is indeed 32-bit. Let’s see some debug logs.

Does this build support 4k30 or 4k60 playback? What about hdr or hlg or HD audio formats ? Thanks for the awesome work

Your questions have largely been explained here: Kodi v19 Matrix is here. Here's what you need to know - OSMC.

  • Pi 4 supports 4K output, but you must manually enable this in config.txt.
  • No HLG
  • HDR EOTF will be sent, but the colour space won’t be correct. This is a known issue on Pi presently.
  • HD audio is hit and miss. We need a new version of libasound which will come with Debian Bullseye in a year or so; but some AVRs are clever enough that it works anyway.

I have done a completely new install of osmc as previously I restored a backup. I don’t have the pickle 5 error in netflix anymore and it has extracted widevine. It gives a new error saying direct play is not available. On the plugins github it says there is nothing really to be done other than a few steps which I’ve tried. This may not be the fault of the test build however it is strange that it did work on LibreElec and it does throw out some erros.

I’ve first opened the netflix app. Afterwards I’ve tried to use the plugin.video.nlziet this one throws out the 32 bit error.

To give some more background. Both apps require pycryptodomex. Since simply using sudo pip install pycryptodomex uses python 2.7 I’ve used sudo python3 -m pip install pycryptodomex and the other dependencies.

The log file:
http://paste.osmc.tv/abayelikiq

Thanks for trying to help me out :slight_smile:

I just made a fresh installation (RasPi 4, 8GB). Some notes:

I’ve tried to stream from my Plex Server (Synology NAS) via UPNP/DLNA. I am not sure, if KODI really tries to stream the file. Maybe there is complete download (?) because at the beginning it takes some minutes until the playback starts (same observation with libreelec 10b). With my RasPi 2 (Kodi 18), the playback starts immediately.

1080p HEVC with 7 MBit/s was playing well.
But with a 720p H.264 file, I got a black screen (with sound).

The Pi guys seem to be working on a lot of changes and quite quickly, so there should be some improvements by the time of the next build.

Sam

How are you connected to the NAS?

Via LAN 100 MBit/s

Ok, all good. Just read it is a 720 file, that problem is know by now and should be fixed with the next update.

Hi, Thanks for releasing the pi4 test builds.
After a fresh install and taking the latest updates and installing send-to-kodi addon, I tried two basics things:

  • playing a stream through send to kodi
  • playing a movie from an nfs share

In both cases, same symptom: no video, audio OK.

What shall I try differently? What info do you need to assist?

Nothing to do with the above: can you point me to an ‘how-to’ for netflix? I tried and installed the Matrix netflix addon, but there seems to be unmet dependencies.

Thanks

What are the mediainfo of the file?
Are they 720? Then fix will come with next update!
If they are not 720 then upload debug logs.
For netflix I suggest to wait till @joakim_s found time to update his scripts.

I turn off the DRM PRIME decoder for 720 video and it works normally.

I tried a 1080p and I now have the video stream playing just fine. Thanks for pointing me in the right direction for Netflix.

The video stream from the movie stored on nfs that failed earlier was:
Video
ID : 0
Format : MPEG-4 Visual
Format profile : Advanced Simple@L5
Format settings, BVOP : 1
Format settings, QPel : No
Format settings, GMC : No warppoints
Format settings, Matrix : Default (H.263)
Codec ID : XVID
Codec ID/Hint : XviD
Duration : 2 h 12 min
Bit rate : 1 343 kb/s
Width : 720 pixels
Height : 304 pixels
Display aspect ratio : 2.35:1
Frame rate : 23.976 (24000/1001) FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Compression mode : Lossy
Bits/(Pixel*Frame) : 0.256
Stream size : 1.25 GiB (91%)
Writing library : XviD 67

Thanks for the hint. How do I turn off DRM PRIME decoder, please?

Will play fine with next update.

1 Like

Settings/Player/Videos.

In the lower left corner switch to expert, instead of standard to display the option.

1 Like

Confirmed working fine. Thanks.

1 Like