PINN image

Hello @d22b
I also like to use Pinn.
I modified Sam’s test image for Pi4 ( [TESTING] Kodi v19 builds for Raspberry Pi 2/3/4 ) for my Matrix tests for installation into Pinn.
I can share it if anyone is interested.

That should be handy. Yes, I am interested.

I’ll save the download link here tonight.

So here is the link for download of OSMC Pi4 for PINN

The file is necessary unpack to root of some flash disc and put to raspberry USB and reboot to PINN maintenance menu.
OSMC will be in sheet Media and you can use Install button (clear all systems) or use Replace button for replace only one existing system (ProjectSpace_-_* or other)
edit: Please don´t forget after installation make update to last version to repair some initial troubles.
Best regards

Hi, install works. But ssh is broken even after update the os. At this point it is quite broken for me because I need ssh.

How is it broken?

Unable to connect via ssh. Tried multiple Installations and networks. Any suggestions?

We need details. What error is given? This is not an issue reported by anyone else.

After a fresh install and connected via Ethernet or WiFi:

Ping — works
Http- works
Tvheadend Frontend (Port 9981) — works
SSH (Port 22) — did not work

Mobaxterm — ssh (ip) —> network error: Software caused connection abort

I tried different clients. Also the local „trick“ (power, exit) to access the local terminal doesn’t work. The system is freezing and I have hard to power off it. My thoughts was that maybe something is wrong with the local ssh config.

The Service is running of course, tried also multiple on/ off restarts.

Tried also with putty:

Remote side unexpectedly closed network connection.

Tried with win10 onboard cmd:

Connection closed by (ip) port 22

That’s a little bit strange, because I have multiple other devices in my network which work flawless.

  1. Are you trying to connect to root@<IP address>?
  2. Please supply logs via the MyOSMC >Logging menu, and post the URL it returns.

@d22b It is true - SSH not working - also not working on original SD card. I will prepare new image, because on my previous image SSH working. I already install script for X11 simple desktop

@dillthedog MyOSMC >Logging menu was not working for me from beginning of my tests this image - over SSH grab logs working, but if not working SSH :frowning:
Also not working 5GHz wifi - I can see it, but cannot connect.
After making of new image I will send some logs.


Thanks Jan!

Ok, so SSH is broken on the PINN image? Not an OSMC issue. Good luck.

@d22b Here is a new image. Sorry for this inconvenience.
Please use button Reinstall , test this image and let me know in case other problems.
For me is SSH working now. I will also test my image in next few days.

Edit: Image is now already updated to Kodi 19.1, but I don´t know hot to setup initial setting of region, skin, language etc. So it is necessary to adjust manually.

Thanks for sharing. Now wifi doesnt work but ssh works perfekt :rofl:

It is possibe to share an “untouched” osmc image? I think something is going weird while you change something inside.

Unfortunately i am currently unable to reach sams test repo.

2,4 GHz wifi working good for me. Only 5 GHz I have problem. You have problem with both bands?
This problem is also on “untouched” image - does not depend PINN
For wifi may be help this [TESTING] Kodi v19 builds for Raspberry Pi 2/3/4 - #243 by fzinken
(Country with capital letter)
I will try prepare " untouched" image again and better.
Test repo? You mean that not working installation of Samba, TVH etc. from Store?


crda works for me. Now I am able to connect via WiFi.

Here is the new PINN version of initial Sam Nazarko image for Pi4 with Kodi 19.0
For me working all what I tested excluded 5 Ghz wifi - installation of crda not help, but I have all my Pi wired, so this is not big problem for me.
Please test it