[TESTING] Kodi v19 builds for Raspberry Pi 2/3/4

Since the RPi 4 has a micro hdmi output you would have to be using an adapter of some form to connect with the same cable you use for your RPi 3. It sounds to me like the issue is most likely this adapter not passing pin 13 across which isn’t really unheard of and would keep CEC from working. As long as you are sure CEC is enabled (settings>system>input>peripherals) I would recommend acquiring a proper micro hdmi to full size hdmi cable.

CEC didn’t work with my RPI4. I switched from the HDMI-1 port to the HDMI-0 to fix the issue.

1 Like

Also here fore reference

2 Likes

I doubt that Addon aligns with the OSMC Piracy guidelines and therefore I removed it from your post.
https://discourse.osmc.tv/faq#piracy

Ok. Sorry.

Hi there,
I was using wireguard on stable version of osmc. The configuration was done based on this topic Has anybody tried to install Wireguard? - #4 by sam_nazarko.

Right now I’m on 19.1 with kernel version 5.10.32-1-osmc . The old manual doesn’t work anymore because wireguard module was merged into the kernel in 5.6, so neither installing wireguard-dkms or building from sources doesn’t work:

WireGuard has been merged into Linux >= 5.6 and therefore this compatibility module is no longer required.

At the same time wireguard package is not present in main distro repos and it’s not possible to create a device with wireguard type:

[#] ip link add wg0 type wireguard
Error: Unknown device type.
Unable to access interface: Protocol not supported

is there something I can do? should I create a feature request?

It was the cable. A $5 Amazon micro HDMI to HDMI cable works great. Thanks!

1 Like

Hello,
thanks for your work,

I want to try kodi v19 on a raspberry pi 4 4gb with my data.
Actually, I have a “prod” kodi v18.9 (osmc 20.11-1) on raspberry pi 3 and a “test” kodi v19 (osmc 2021.07-1) on raspberry pi 4.
How can I transfer all config (NFS share/read/unread movie, etc) from v18.9 to v19?
knowing that the db changed, how can I do that?
Tks

Assuming your NFS share is through a Kodi path and not the OS you should be able to get away with just a backup and restore either through My OSMC or the Backup Kodi add-on. The database should convert automatically after the restore. If you get a sad face boot loop after that (I don’t know if you will as I’ve not tried this myself) then you will likely need to ssh into your box and…

systemctl stop mediacenter
rm ~/.kodi/userdata/guisettings.xml
systemctl start mediacenter

Note that this is assuming your not using profiles which would require deleting that file from each profile folder as well. Deleting that file will return most of your settings back to default but will leave your database, sources, thumbs, etc. intact.

When will the stable version be available?

I just bought the micro hdmi to hdmi adapter.
Now can boot without forcing the hardcoded EDID. the parameter if now off
But the CEC is not working.

What port are you in? Some people have reported CEC working on one port where it doesn’t on the other

When it’s ready, there will be an announcement on the blog.

1 Like

I’ve read about the fix but don’t want to mess with libcec
thanks for your consideration

Are plugged into the hdmi port closest to the USB C power input?

Big update and improvements
I’ll will make my story short.
I noted in the Input/Peripheral LibCEC was not installed.

For history :
I have the RPI4 with the micro HDMI cable supplied by the RPI foundation.
This cable seems to be widely incompatible unless the 2 other have are faulty.
At the beginning i wasn’t even able to launch the OSMC installer after the micro SD was written.
I had to use different parameters and spent hours digging on solutions.
This resulting the installer probably messed up with the installation due to a bad link with the TV.

What changed ?

I just bought the micro HDMI to HDMI adapter and plugged a standard HDMI cable on both ends.
I did a fresh install and now everything works well from the scratch.
I updated it all to the latest version.
CEC is good and the TV displays everything right.
I also restored OSMC settings from the backup without issue
The Vero 4K is still the best choice

Apologies for missing your post.

I have a Pi4 running the development branch:

osmc@osmc:~$ uname -a
Linux osmc 5.10.32-1-osmc #1 SMP PREEMPT Wed Apr 28 05:45:57 UTC 2021 aarch64 GNU/Linux

and wireguard seems to work – though I’ve not actually tested its connectivity.

osmc@osmc:~$ sudo ip link add wg0 type wireguard
osmc@osmc:~$ ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,DYNAMIC,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DEFAULT group default qlen 1000
    link/ether dc:a6:32:b7:81:4c brd ff:ff:ff:ff:ff:ff
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,DYNAMIC,UP> mtu 1500 qdisc pfifo_fast state DOWN mode DORMANT group default qlen 1000
    link/ether dc:a6:32:b7:81:4d brd ff:ff:ff:ff:ff:ff
4: wg0: <POINTOPOINT,NOARP> mtu 1420 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/none 
osmc@osmc:~$ lsmod | grep wireguard
wireguard              73728  0
libchacha20poly1305    16384  1 wireguard
ip6_udp_tunnel         16384  1 wireguard
udp_tunnel             28672  1 wireguard
libcurve25519_generic    40960  1 wireguard
libblake2s             16384  1 wireguard
ipv6                  552960  33 wireguard
osmc@osmc:~$ grep -i wireguard /boot/config-5.10.32-1-osmc 
CONFIG_WIREGUARD=m
# CONFIG_WIREGUARD_DEBUG is not set

It might be working on Pi4, but on Pi2/3, the wireguard module is missing in the kernel.
Had the same issue, as nimbleguardian.
My solution in the end was, installing wireguard-dkms (from raspbian repo) and just commenting out the check for kernel >= 5.6 in /var/lib/dkms/wireguard/1.0.20210219/source/compat/compat.h and dpkg-reconfigure wireguard-dkms

We can add it in the next kernel.

Sam

1 Like

I’m also using pi2

would be great if you could add it to the kernel, so it’s available by default